SmartThings Community

[DEPRECATED] EchoSistant Version 4.0 ~ Evolved

Found the bug, fixing…Update coming shortly. Thanks for reporting :slight_smile:

Please update the Profile to Version:4.0 R.0.0.2

Do I have to have a speaker other than the Echo to use Echosistant? I’m guessing there will be some features that don’t work.

The feature that would NOT work, is sending messages between devices. Other than that everything works

1 Like

Service simulator shows success I guess below but still no message to my android tablet. Live logging for profile is " 8:44:01 AM: warn start - reminder = null"

“response”: {
“outputSpeech”: {
“type”: “PlainText”,
“text”: “Message sent to Kids , , send another message to Kids”
},
“card”: {
“content”: “Message sent to Kids , , send another message to Kids”,
“title”: “EchoSistant Free Text”,
“type”: “Simple”
},
“shouldEndSession”: false

What was your “message”?

Just a simple “test new profile” message

Sweet! I’m off to install. :grinning:

1 Like

Stand by, there is another bug. New update coming shortly…

Ok, so the problem is that app’s defaults are not set because you haven’t had a chance to set them up by navigating through other pages on your Profile. I fixed that from the back end, so you don’t have to open and close pages that contain defaults if you don’t want to visit them. Pushing update shortly…

Bug fix is live…please update Profile to: Version:4.0 R.0.0.2a.

And like with any other ST app, don’t forget to open the Profile and click done, after updating, to apply the changes.

Would appreciate some advice. I have installed and deinstalled a couple of times and i am doing something wrong. After loading the SmartApp and opening it i get an “installed and automated message” in green followed by a “unexpected error” message in red. When I go to the General Settings tab i see an Access token: null and when i jump over to the Live Logging I see STtoken = ‘null’.

I have tried Revoke/Reset with no success

Thoughts?

You need to activate oauth in the app. Follow the steps in the wiki for that.

Sorry I don’t follow. I thought I had followed the wiki to the letter…

Did you enable the OAuth in ide for the Main EchoSistant app? That might be the problem.

Step # 2 enable Oauth in the ide

1 Like

Yes. Thanks. In fact went back again and started from scratch. Can’t seem to get past this issue. Thanks for the help.

1:31:20 PM: error java.lang.NullPointerException: Cannot get property ‘value’ on null object @ line 560
1:31:20 PM: debug Creating new Access Token
1:31:13 PM: trace STappID = ‘xxxxxxxxxxxxxxxxxxx’ , STtoken = 'null’
1:31:05 PM: trace STappID = ‘xxxxxxxxxxxxxxxxxxx’ , STtoken = ‘null’

Thanks Bobby as I just confirmed Version:4.0 R.0.0.2a fixed my EchoSistant V4 installation hurdle! Yes, it helps as I didn’t think about needing to go through all the newly created profile defaults so your fix on the back end is a good solution for end users. Have a great weekend!

1 Like

Ok, I am looking now. This is your first ever install, correct?

Ok, I identified the bug. Fix coming shortly.