[DEPRECATED] EchoSistant Version 4.0 ~ Evolved


(Bobby) #91

That’s the best stress test we can get :smile: Do you mind leaving those out dor now? We can explore what we can do with them later :smile:


(Brian Diehl) #92

Not a problem. Like I said, they exist as Media Player Type Device and it took them just fine in that list.


(Steven) #93

I ran the test again with ST Live Logging open and it didn’t post anything in the Live Logging.
I’ve gotta get to bed though so I’ll be on tomorrow after work.


(Jason "The Enabler" as deemed so by @Smart) #94

go into the app settings on the main page and turn on live logging


(Bobby) #95

Yeah, I am not sure why the handler has Media Controller capability if it doesn’t have any activities, unless is using some custom attributes for the device, in which case I need to add them to EchoSistant in order to be able to add them as Media Control devices…It should work fine as Media Player to change inputs and volume…


(Brian Diehl) #96

Here is the DTH if that will help you.

https://raw.githubusercontent.com/iamcanadian2222/ST-Kodi/master/devicetypes/boshdirect/kodi-media-center.src/kodi-media-center.groovy

It’s this integration:


(Bobby) #97

Thanks, EchoSistant should be able to handle every command if the handler is selected as Media Player…


(Jason "The Enabler" as deemed so by @Smart) #98

Everyone make sure you stay up to date on everything. The easiest way is via the Github integration.

We are pushing out bug fixes as fast as we can fix anything, so if you’re having any problems after the install, make sure you are on the latest code.


#100

Very clear instructions for setup…I certainly need a walkthrough as I have no idea what I’m actually doing.

I’ve got stuck:

I’m at “Main Intent Skill - Create” - Step 6 of the wiki:

I’ve added the values to my List_of_Devices and List_of_Controls as displayed in the IDE…but where do I get the List_of_Profiles values from?

I’m thinking they are the names of the ‘Messaging & Control Profiles’ you set up in the app, right? Do I copy a list from somewhere, or just type them in?

Also, I don’t really know what I’m doing with regards to setting up the Messaging & Control Profiles to be honest …or what I’m actually specifying/what their purpose is. Is there a guide to that part too?

(I did set up at least one, as per “Install SmartApp in SmartThings Mobile App” - Step 9 of the wiki…but didn’t really know what I was doing!)


(Bobby) #101

List of profiles has been removed. You don’t need it. Please skip…


(Bobby) #102

Their purpose is:

A. they enable messaging between multiple speakers
B. they enable Group control for lights, vents, fans, TV…in one room (E.G. Alexa turn the lights off in the Profile - where Profile name might be Bedroom)
C. they act as Routines (you can define actions to take place when Profile runs. This is helpful for reminders, as an example, you may want to turn colored bulbs when reminder is due, or flash lights. Also you can trigger Pistons in CoRE by just triggering the Profile. You could say - Alexa fire the < Piston Name > and have Core take actions. You could actually say anything you want and fire a Piston every time when you invoke the Profile.


#103

I’m also getting the below message at the test step - same observation as @Graffix3001

I’ve enabled Debug Logging in the App settings, but nothing appears in the IDE Log after I click “Ask Echosistant…”

(Can confirm that the Live logging is capturing Echosistant events though, because I just called my list of devices and it shows fine)

{
_ “response”: {_
_ “outputSpeech”: {_
_ “type”: “PlainText”,_
_ “text”: “There was an error. If this continues to happen, please reach out for help”_
_ },_
_ “card”: {_
_ “content”: “There was an error. If this continues to happen, please reach out for help”,_
_ “title”: “Lambda Error”,_
_ “type”: “Simple”_
_ },_
_ “shouldEndSession”: true_
_ },_
_ “sessionAttributes”: {}_


(Bobby) #104

Can you please post the EchoSistant logs after your test? I assume that it might be a default value that hasn’t been activated…but that’s just a guess without some logs…


#105

That’s the issue…I know you asked @Graffix3001 to do the same…but running the test results in nothing being displayed in the Live Log in the IDE


(Greg) #106

INSTALLED AND EVOLVED!!!

Great job Bobby and Jason!


(Bobby) #107

Where are you located? Could you please post the link of your ide? Both of you may be on a different shard…@Graffix3001

Wiki Troubleshooting…
Step 1 - Log into the ST IDE at https://graph.api.smartthings.com/ (your log in page may be different if you are on a different shard)


#108

UK

My IDE is at:

graph-eu01-euwest1.api.smartthings.com

All that has appeared on my IDE for Echosistant so far (and that’s not in response to running the test…but noticed it sometime after) is as follows:


(Bobby) #109

Ok, could you please go into Lambda code and update line line 30, to reflect your API path correctly?

var url=‘https://graph.api.smartthings.com:443/api/smartapps/installations/’ + STappID + ‘/’ ;

SHOULD BE

var url=‘https://graph-eu01-euwest1.api.smartthings.com:443/api/smartapps/installations/’ + STappID + ‘/’ ;


#110

Yep - that fixed it. I’ll carry on working through…I hope all the rest goes smoothly so that I don’t have to bother you again.

Thanks!


(Mark Kaplan) #111

I’m stuck at the Service Simulator of the HallBath Profile. I’ve recreated and check the steps up to this point and I get the same error.

One unrelated (or not) point.
when I created the main and child apps. I published the main and not the children, but when I updated from Repo, I hit the Publish box and hit update which publish the rest of them. was there a better way to do this. could this have caused problem?