[DEPRECATED] EchoSistant Evolved ~ Amazon Echo's Only Assistant with Robust Scheduling and Flexible Reporting

What he meant, is that you will run out of words trying to confuse Alexa, because any command you are giving, would be executed, right @bamarayne. Correct me if I am wrong :smile:

2 Likes

I was really going for a… You’ll be so amazed that you’ll be speechless!!

But yeah, what @SBDOBRESCU said… I meant that too.

2 Likes

Guess it’s time for that ASL to text module to be implemented

1 Like

Free text to speech using sign language! Now that’s what I’m talking about! Get everything you can out of Echo Show!

2 Likes

YYeah, you can even clap your hands and make the lights turn on. See how far we made it since the 80s?

2 Likes

Now that was technology at it’s finest. The Clapper! Clap on, clap off, the Clapper!

No wake word needed whatsoever with that technology. Just clap and go!

1 Like

I just installed and configured ES and a bunch of profiles/skills - it is truly exceptional software and a lot of fun to use. I have two questions about door locks.

I created a doors unlocked report which is like the “External Doors” report in the wiki and the main intent successfully reports the number of unlocked doors. I’d like to know if it could also report which doors are unlocked? I’ve tried the normal natural language questions and can’t seem to find the right phrase (if it exists).

The second question is how to have ES lock all the doors. I tried creating a device control profile but I think to do this I’d need to use virtual switches or ifttt which I can do but I was wondering if there is any native support in ES for something like “tell home to lock all door locks”?

thanks

1 Like

Should be able to do that with webCoRE. Maybe use a virtual switch that triggers the piston?

Make sure you have selected your locks in the main app devices section. Then simply say, Alexa, tell home to check the locks.

We are actually in work on this feature now. Please look for an update soon. There have been several request for this sho we will be pushing it out as soon as we are done testing it.

2 Likes

Thanks! When I test the phrase “check the locks” under main intent/service simulator, I get “Sorry, I heard that you were looking to check something but Echosistant was unable to help with that”.

I do have my door locks enabled/selected under main home control/select devices/allow these locks

Ok. Let’s go over to a PM for troubleshooting.
Please send me a screen shot of the live logs when you perform that action.

Robert,
No need for the troubleshooting. I already know what the problem is. Unfortunately I am not able to get to a computer at the moment, I’m on my phone.

I will get this little issue fixed as soon as I get home. I’ll let you know when it’s ready.

Thanks for your input.

1 Like

Thanks very much!

2 Likes

I am in the process of installing the EchoSistant app but it won’t let me get past the part where I need to enable OAuthorization. I believe I have installed everything correctly, the main EchoSistant App and the children apps. I installed and published the EchoSistant VDH as well.

It actually seems to give me a Client ID and Secret, but then says “Access Denied” and won’t actually do it.

I believe I just saw an issue that this is a SmartThings issue right at the moment and they are working on it.

1 Like

This was a post over in NST Manager 5 hours ago:

8BitNinja
5h
Getting the message below trying to enable OAUTH and clicking UPDATE. Will search the thread in the meantime…

OAuth Client ID: -removed-

OAuth Client Secret: -removed-

Access Denied

We’re sorry, but you are not authorized to perform the requested operation.

Where did you see this? Their status page says all is well… I had a feeling it might be something like that… I knew I shouldn’t have tried uninstalling and reinstalling everything… well practice makes perfect I guess!

Thanks

1 Like

And this is a follow up reply that they received from Support:

From support:

I’m sorry to hear this is affecting you.

The issue lies with all custom SmartApps currently that need to “Update”.

We are aware of the issue and are working on correcting it as we speak.

I will follow up with you once it’s been corrected.

No I didn’t see it on the Status page either. They prolly havent updated it yet.

For the posts I pasted above you can see them at the bottom of the MOST Manager thread, here:

Ok, I think I know whats going on… @coreylista could you please see if you can enable the oauth on Notification add-on to confirm my theory…