[Deprecated - DO NOT INSTALL] ADT Tools 2 for Smartthings ADT alarm sytsems

Trying to install the ADT Tools but when I copy the source code and hit “create” I am getting the following error"startup failed: script_app_metadata_7db11910_3960_40b1_960a_70e8ec1c918e: 256: unexpected token: @ @ line 256, column 1. @@ -0,0 +1,200 @@ ^ 1 error"

I am getting source code from “https://github.com/Mavrrick/Smartthings-by-Mavrrick/commit/cbcca730c9bc89f492e48083a0a16da166e85613

thanks in advance

I am still a newbie to Smartthings but I have installed a custom handler and app. Trying to figure out how to get the APP. First I tried to cut and paste the source code. That did not work (sent a separate post on how I did that one.

I have an account oo GitHub and think I found your repository (https://github.com/Mavrrick/ADT-Tools-2 & https://github.com/Mavrrick/ADT-Tools-2/tree/master/smartapps/mavrrick) but I do not see any way to “download retrieve” the app. It appears the the parent app is no longer on this page.


Can anyone help with how to set up this app? From the files that are currently on the Github, it does not look like the instructions in this thread work for setting the ADT Tools 2 up.

thanks in advance

Everything is in the github location. Smartthings puts the device handler in a different folder. Easiest way to deploy it is simply setup the github integration with the the github location and then use the options in the IDE to deploy.

There are a tone of good td tutorials at thingsthataresmart.com about how to use the IDE and github integration.

Thanks Maverick that helps.

Can anyone tell me where the Smart Home Monitor is at? I searched this website and found it is supposed to be in the Marketplace section of the official mobile app. Using the “Classic” app I can’t find anything called Smart Home Monitor in the Marketplace. Thanks

Still being new to Smartthings I was having problems getting this to work even with the instructions on this web page: https://thingsthataresmart.wiki/index.php?title=ADT_tools_2#How_do_you_get_ADT_Tools

Little things like liking my account and using Github. I found a post by FredderfFRED that had YouTube links that were very helpful, reposting because they were a ways back in the post. Also don’t forget to enable OAuth

Fredderf FRED

Feb 15

@ramar I too came over from Iris a little over a week ago getting the SmartThings ADT Starter Pack. I was in the same boat as you. I did not and still do not know anything about coding, programming or any of that stuff lol. I wanted to download ADT Tools 2 as well so i could do everything i could with Iris and more. I tried looking over all the instructions on these forums but was still lost. I got a lot of help from members with my questions but still was about to give up on ADT Tools 2 as i couldn’t figure out how to install it and go through all the steps. I came across this 10 min video just yesterday that fully explains and shows you on screen how to install webCoRE. I still dont really know what webCoRE is but it’s the same steps that you use to install ADT Tools 2. I installed webCoRE first then went back to watch it again and replaced webCoRE’s information with @Mavrrick58 (who created it) information and it should work for you. I had a few hiccups but wasn’t bad watching the step by step video. Here is the videohttps://www.youtube.com/watch?time_continue=191&v=y_ElUwmmI6Y 6
and here is @Mavrrick58 post with the info you’d replaced the webCoRE information on his first post
[Released] ADT Tools 2 for Smartthings ADT alarm sytsems 2

haven’t had a chance to go though the forum/update the app recently, so forgive me if this has been added already. But, checking to see if you were able to get an alert set up (push and/or text) for a timed event, i.e. “Back Door has been left open for XX minutes”? That was one of the alerts I really liked in the Iris system but haven’t been able to figure out a way to make it work in ST.

Thanks, Erik.

This has worked well for me…

Once the ADT smartthings panel is added to the location some Smartapps are hidden and SHM is one of them. Unfortunately the only way I know of now to get it added is to scratch your entire setup and in the process of rebuilding install SHM to your Smartthings location before adding the ADT Smartthings Panel.

What are you trying to do and maybe I have a alternative option for you. Allot of what SHM does is possible in ADT Tools already. The only thing I know doesn’t work is the ability for external systems(Actiontiles) to see the alarm state and the exit delay function for non ADT Sensors. The latter is something I could possibly fix.

Maverick, from reading the posts I thought I needed SHM. But it looks like I don’t it. The problem I am having now is the ADT 2 tools didn’t create the virtual buttons. I followed your procedures:

You want ADT Tools 2 to create it’s virtual buttons**

This will only be needed if you either don’t have virtual buttons already created or if you simply what ADT Tools to create them. This is optional.

Because the buttons will be used by the mode change component they will need to be created first.

  1. Open the ADT Tools 2 Smartapp.

  2. Select the “Optional Setup Steps” section.

  3. Select the switch on the right to tell ADT Tools to turn on the button creation.

  4. Click on the option to return to the ADT Tools Main Menu.

  5. Click on Save.

  6. Open the Smart app and follow steps 2-5 again, but turn the switch off for button creation.

  7. You now should have 3 new buttons created under your devices.

ADT Tools is now installed, and you should have virtual buttons created by ADT Tools.

But it did not create the buttons. I tried it again and got “unexpected error” when trying to save with button toggled on. I then tried your old method under ADT tools to create the button on the IDE website. It created just fine but for some reason keeps toggle back off on its own. I have the “maintain sych between alarm panel off (I also tried it with it on). This is what I get in the event log:

Date Source Type Name Value User Displayed Text
[2019-09-05 7:35:22.045 PM HST
moments ago ] momentary pushed Alarm On momentary is pushed
[2019-09-05 7:35:22.025 PM HST
moments ago ] DEVICE switch off Alarm On switch is off
[2019-09-05 7:35:21.970 PM HST
moments ago ] DEVICE switch on Alarm On switch is on
[2019-09-05 7:35:21.958 PM HST
moments ago ] APP_COMMAND on ADT Tools 2 sent on command to Alarm On

What is going wrong?


Make sure you downloaded and published the ADT Tools Button device handler. That is likely the reason for it failing to create.

It is installed and published. it wasn’t the first time i tried making the tiles, but the second time i tried it was published. Yet I still got the error.
Thanks in Advance.

These are my DHs:
Namespace/Name GitHub Repository Status Capabilities OAuth Sessions
krlaframboise : Aeotec Doorbell 6 Published Actuator, Alarm, Audio Notification, Health Check, Music Player, Refresh, Speech Synthesis, Switch, Switch Level, Tamper Alert, Tone
krlaframboise : Aeotec Doorbell 6 Button Published Battery, Button, Refresh, Sensor, Switch
Mavrrick : ADT Button Tile Published Actuator, Health Check, Momentary, Sensor, Switch

Can you please use the IDE to generate live logging while you are trying to create the buttons so i can see the error and let me know what occurs with that.

8:35:53 PM: debug Checking Device Thresholds

8:35:39 PM: debug Parse returned ManufacturerSpecificReport(productTypeId: 260, manufacturerId: 134, manufacturerName: AEON Labs, productId: 117)

8:35:05 PM: trace getPhrases(), state.welcomeIssue = null

8:35:03 PM: error physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘ADT Tools Button’ in namespace ‘Mavrrick’ not found. @line 74 (initialize)

8:35:03 PM: debug initialize: Creating virtual button devices ADT Mode Change

8:35:03 PM: debug child app: Security alert action

8:35:03 PM: debug child app: Security alert action

8:35:03 PM: debug there are 2 child smartapps

8:35:03 PM: debug Updated with settings: [phone:(xx) xxx-1492, alarmPowerState:true, messageArmedStay:Alarm Armed Stay, createVirtButton:true, alarmTamperState:true, sendPush:true, myArmAway:Alarm On, messageArmedAway:Alarm Armed Away, armedAwayOn:Alarm On, messageDisarmed:Alarm Disarmed, delay:1, panel:SmartThings ADT Panel, armedStayOn:Alarm On, locAlarmSync:false]

8:34:32 PM: info Waiting on events…

That means there is a problem with the device handler. Please make sure it is loaded properly. and published.

It looks like you got the old button device handler from my general purpose repo instead of the ADT Tools 2 repo. The routine for the button creation needs you to get all of the code from the ADT Tools 2 repo.

Thanks got the Siren 6 to trigger off an alarm event and turn off when alarm is disarmed.

Follow on question. I would like to have a siren 6 beep when the ADT smart-thing HUB is counting down for the delayed entry or exit. I don’t want the Hub to sound off because a burglar can follow the sound after entering and destroy the hub before it goes off and defeat the system (I do not have monitoring service). Is this possible to setup?


That is not something ADT Tools will control. ADT Tools doesn’t change anything on the ADT Pannel itself, but just effects how it interacts with Smartthings. I would suggest you check the ADT Smartthings panel settings themselves to see if there is a way to mute the count down tones though. I would suggest a quick search to find the toolbox code and see if that tune can be turned off from their. I suspect it can be.

Thanks I just disconnect the speaker (there is a quick disconnection on it). I guess I will just hard wire it to a different location.

I installed ADT Tools 2 and button handles so I could control modes with action tiles.

However, I have noticed two things. My smartthings app (modern, not classic) does not report or change device state anymore. Also, I no longer get push or text notifications when it goes off.

Could any of this be related to the ADT Tools 2 install,?

There was a change to sms text a little while back were Smartthings was requiring you to opt in.

I am still working fine. Could you please open live logging while generating the problem and send me the logging for the app.