[DEPRECATED] Blink Camera Device Handler with Motion Sensor, Live Video Streaming, Integration with SmartThings/SHM, Temperature, Signals and Push Notifications

No change to existing configuration, nothing required to do after updating the code, it’ll take care of the migration internally. Just copy, paste, save and publish the code.

@Turb02 yes both need to be updated, DTH first and then app

1 Like

This is an interesting development. I’m not convinced depending on a proprietary communication protocol is a good long term strategy, however. On the other hand such an ecosystem gives Blink more control over quality and robustness. The latter is lacking when most home automation companies apply open standards today (in my opinion).

In the end, Blink is a great value and it just works. Most buyers won’t care how they do it.

Blink flyer from CES

2 Likes

About a day on with this issue, still no IDE Live Logging. ST support just sent me an email saying that it looks like my live logging is working again, but not sure how they made that determination as I still see nothing, and the problem persists. I just sent them back a screen image showing the lack of anything on the live logging screen.

Just to be clear on this end, by “Live Logging” I presume you mean just clicking the “live logging” link at the top level of the IDE UI and from there I should just see some sort of log from whatever I’m doing (in this case trying to finish installation of the smartapp by logging in to Blink) ? And not, for example, events such as are found at My Locations > List SmartApps > (Choose a Smart App ie Blink Camera Manager) > List Events > All

Appreciate your patience as I’m new to this arena.

Another possible cause of my problem (can’t login/OAuth not recognized/something-like-that) just occurred to me. I had already found and signed up for the IDE before I heard about RBoys. Your instructions say that when I create the login for the IDE that I should be sure to opt-in for the developer account. While I’m no stranger to coding, I had no intention to pound code for this system, so depending on how it was phrased, I might easily have said “no” to this.

Looking through the IDE now, I see no way to alter that. Another thing perhaps to take up with ST support, or … ?

I’m sure this will be great if I can ever get it to work, but the potential sources for error and the weak and slow feedback loop is a little discouraging for now. Thanks in advance for insights.

For now I’m trying again with your updated device handler and smartapp on the off chance that somehow that makes things work (I will follow up here if/when I get things working).

Just drop a note to ST support to enable the developer account for you.

Sorry for so many messages here; but it’s working for me now!
Unfortunately I don’t have a clear idea of what happened. I installed the most recent device handler and smartapp, but was (very) surprised to find when I went to install the updated device handler that the one I originally installed didn’t show up — only showed a couple of older device handlers I had obtained elsewhere (and installed a couple of weeks ago). I am truly 100% certain that I installed the blink camera device handler exactly as instructed — paste in code, create, publish (for me).
Might smartthings support have deleted it in their attempt to help me?!? I’m baffled, and a little alarmed that it disappeared.

But I’ve got cameras now through the ST UI, and look forward to programming and working with these.

Still puzzled that live logging never worked, still never shows anything. I guess that if everything is working fine on the surface now that I won’t poke the calm waters of the lake, less long tentacles reach out and grab me!

1 Like

And now live logging is suddenly working; maybe ST support got round to it, maybe a phases-of-the-moon thing. Interesting stuff in there!

1 Like

I’m confused by this item in the instructions at the beginning of the thread:
C.3: “After updating the Device Handler click on the Refresh tile for the changes to take effect”.

Where is this “refresh tile”?

Thanks,
Chris

The big round circular arrow (that’s the refresh tile in ST)

1 Like

Is there a blink server/network issue email subscription that I can get added to somewhere? About an hour ago my Sync module went offline and I deleted and re added it for no reason since its a blink server outage.

@RBoy The offline ST notification worked great btw!

Hello,

Thank you for contacting Blink. I’m very sorry that you’re experiencing this issue! We are currently experiencing a server issue that brought a small number of Sync Modules offline. Our server team is hard at work to resolve this issue as quickly as possible. When systems are back to normal, your Sync Module will automatically reconnect to our servers. We appreciate your patience while we work to resolve this problem.

Thanks,


Blink Customer Service

I don’t know about an email list, but http://support.blinkforhome.com/ shows a message about the current outage. I hope that’s what my problem is – can’t turn cams off in ST and I can’t even get the Blink app on Android to load. There was a recent update so I installed that but still can’t launch it. It starts to load and then just crashes without an error message.

Same here, Android app just closes trying to open. Camera state changes require the SYNC module which is the cause for your other issues.

Just trying to get this all set up, When I try to enter my login credentials I am getting " Error Getting Account detail, check login credentials or service is offline" I have triple checked my password with the Blink app. Is there a way to check if the service is in fact offline? Thanks for any ideas on what I may be doing wrong.

###Requesting everyone to please update the latest version of the Blink SmartApp (05.08.00) and Device Handler (05.04.00), Blink has disabled access to all the old versions and they will no longer work.

1 Like

@RBoy

I am tryingto update the smart app and am getting this:

groovy.lang.MissingMethodException: No signature of method: script14848459625591129026485.metadata() is applicable for argument types: (script14848459625591129026485$_run_closure1) values: [script14848459625591129026485$_run_closure1@659c1412]
Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure) @ line 65

Im not in an area where I can spend much time troubleshooting this as I am in a combat environment at this time.

Please advise.

You’re using the wrong instructions/type, separate links for SmartApps (SA) and Device Handlers (DH), see the links in the first post for the respective SA and DH

1 Like

Yeah, I figured it out just before getting back on this forum.

Thanks.

I am out of the country for 2 weeks…I can not due this till Feb. 8th…any issues because of this?

Help, I have an issue with the Blink account password ‘cached’ on my iPhone.
Sometime within the last 3 days the password is now Invalid, and I am unable to change it to match my Blink account.

When I go in to the Blink Camera Smart App, and clear the password, using the ‘x’, it goes blank.
But as I enter the password, it autofills from an incorrect store.
Is there an option to edit them in the IDE?