[DEPRECATED] Blink Camera Device Handler with Motion Sensor, Live Video Streaming, Integration with SmartThings/SHM, Temperature, Signals and Push Notifications

As of this last weekend, I’ve been unable to enable motion detection on any of my blink cameras via Smartthing - either via the Blink Camera manager or via CoRE. I’ve tried any number of things, from recreating the pistons in CoRE through to reinstalling the Smartthings Android app, then deleting the devices/camera manager/device manager and reinstalling them.

Now I’m stuck with the Blink Camera Manager app at first attempt refusing to recognise the Blink login from my password vault, then successfully logging in and listing the cameras inside the manager, but coming up with one of the following errors:

Error creating Blink camera device
Error saving page

Either way, the cameras do not appear in my list of things so I cannot use them with SHM.

This is with the latest version of both the device manager and camera manager app, as well as clearing out the data/cache on the Smartthings app.

As well as this I’ve also been having a variety of other fun and interesting issues with Smartthings, with routines deciding to not bother firing automatically when previously they worked flawlessly.

I’ve also rebooted the hub a couple of times too.

I wouldn’t care but this setup has been working without issue for weeks, only to fail not long before I go on holiday, so this is really inconvenient.

Anyone got any ideas/is experiencing the same thing in the UK?

I’ve got the exact same thing, just this minute messaged @RBoy with details and logs. Hes normally fantastic with replying and fixing - so shouldnt be long for a fix :slight_smile:

1 Like

Cool - can you (or @RBoy for that matter) advise as to what data/logs to send to him? I figure the more info he has to work with the better.

I just sent him the logs from my IDE for the Blink SmartApp - https://graph-eu01-euwest1.api.smartthings.com

Dont post them on here though (only via PM if needed) as they contain access tokens etc


Oh wow - just looking at the live logging page something is certainly not right - I’ve got the same camera showing up 6 different times (and none of the others), despite the fact it’s not listed in the devices section. In fact the other thing I’m having problems (Netatmo Connect) is also showing up more than once - coincidence?

How do I go about pulling those logs off to send, is it just a copy and paste from the page?

Yeh just a straight copy/paste, you can narrow it down to a single SmartApp by selecting one from the top of the logging page.


I am a newbie to this, so I apologize if this has been discussed, I wasn’t able to find it in a search feature. I just added the code for both Smart Apps and Device Handlers, published for me, checked the OAuth multiple times and appeared good to go. However, when I go to my ST apps, the options to selection My SmartApps doesn’t appear. I’m sure there is something simple I’m not doing.

Firstly, have you clicked ‘publish - for me’?

Secondly, when you say you go into your ST apps, do you mean your installed smartapps on the same menu option as the hub status and notifications tab? If so, you may have missed out the step where you select the published app from the marketplace section. To go there, click on the star to the bottom right, then Smartapps at the top, ‘My Apps’ at the bottom then find Blink Camera Manager in the list.

@Dave_George Thanks for the quick response.

  1. Yes, I clicked publish - for me for both the Device Handler & Smart App

  2. That is my confusion, the “My apps” option does not appear for me in the Marketplace section.

@Dave_George Disregard… I repeated the whole process and now it’s there. So sorry for the premature post.

Don’t worry - I didn’t find it the most straightforward process to start with either!

Just a note, I had a look at the logs. This is a ST platform bug they had patched a few days ago. Looks like it has resurfaced. I’ll find inform them.

1 Like

Great, thanks for looking. Are they likely to be fairly quick in rolling the patch out do you think?

hope they fix this quickly… i am also having similar issue

What ST server are you on? Na01/na03… Etc

i am from US… how to check which server i am in?

I installed from scratch. i was getting invalid login. but it created smartapp and when i go the menu and smatapp and try the login again it throws error but detects the cameras. but still get old interface.

Ask ST support or look at your live logs or check your IDE URL. Where it says “graph” it will mention the server also.

Thanks for your support and quick response.

i contacted support. they told it is US region server.

Ask them what “shard” you’re on. I’ve tagged you in another thread with the ST engineers, you may need to provide that information to them.

‘shard’ is NA01. i provided in the thread you tagged me.

Thank you for help

1 Like