[DEPRECATED] Ask Alexa 2.3.8

Yes I did get it setup but then I had to setup my echo dots into my developer account which meant I had to reset all my skills, etc. And then I discovered that I didn’t have prime on the developer account. I setup the developer account with the same email as my amazon account but it still saw it as a different account. So I just reverted back to the original amazon account. I don’t know if something went wrong in the setup of the developer account.


Sorry to hear about the issues. Were you able to get past them? That is one thing I believe Amazon has to improve is its account management piece!

@MichaelS Micheal, I don’t know if there is anything you can do about this, but here goes.
I have two garage doors, Garage one, and Garage Two. If I say “Alexa open garage one and open garage two” I just get a blip from Alexa. If I say “Alexa open garage one” I get an error saying I have no reports with that name. So I see the conflict, as Open=Reports and Open & Close not in Ask Alexa utterances. I can open and close my garage doors with Alexa as they are not actual garage door controllers. I built my own using a Inovelli two channel smart plug and two relays. And in the Alexa app I created two routines, which one is “Alexa open garage one” and the other is “Alexa close garage one” same for garage two. I thought about using the virtual Alexa button, but prefer not as it adds to the delay. Any ideas, or can we add open and close?


Well, your assumption about ‘open’ isn’t quite right…Open is the verb and it looks for a noun (device or macro), so you can “open” a door, or open a voice report. In this case Alexa looks for the noun and then does a look up on which utterances might be applicable.

First and foremost, did you update your developer’s slots when you add these ‘nouns’? That would be the first thing that comes to mind with the error you are reporting. To kind of ‘trick’ Alexa you could name your routines “Open Garage Door” and it will see that before the verb ‘open’ and might actually work better. But again, you have to update your slots after adding anything new (devices, macros, extensions, etc) to Ask Alexa.

I think you are on the right track however…I assume you DIDN’T name the actual routine with Alexa in their name and that they are simple “Open Garage One” or “Close Garage One”…

Finally, when using numbers in your words you really have to look at how Alexa is interpreting them (as words or actual numbers). For example, if you spelled out ONE and it is hearing (or translating) to “1” then it won’t work. Opposite it true as well…1!=one :slight_smile:

Let me know if this helps at all.

OK I figured one thing out. In ST app the garage one is called Alayne’s Garage Door. And Garage door two is called Joel’s Garage door. That being said. When I said “Alexa tell the house to Open Alayne’s Garage door” I got the response that “Up, On or toggle was needed” What do you suggest, as Open doesn’t seem to be available. What next?

I assume Alayne’s Garage door is a device, but not a true door actuator (sounds like just a switch/relay). In which case there are a few things you could do. Create a macro called “open door one” that activates Alayne’s relay switch which I assumes opens the door. Then create a companion macro called “close door one” and have it turn ‘off’ the relay. The other thing you could do it create a virtual door in the IDE, then use WebCore to ‘translate’ between the door open/close commands and the on/off required for the relay.

Many options, but again remember…update your developer’s area when you change anything.

Hey Michael, no I ended up reverting back to my amazon account that has Prime. I was definitely a real pain to try to setup the amazon accounts. I have other issues with amazon accounts as I also have both an amazon.ca account and amazon.com account. Had issues with my fire tablet because it is under my amazon.com account because amazon.ca wasn’t selling them so I bought it from .com and had it shipped to a family member living in the US. It just seems to create problems.:frowning_face:

Yeah…again, Amazon needs to figure this stuff out as I have multiple accounts as well and it becomes confusing.

OK sounds good, just a Macro, and nothing in the Alexa App.

OK very strange. I created an Open Alayne’s Garage Door macro and one for mine, also close for both. The first time it worked for Alayne’s but then after it gives the same error. Toggle, Off or on command. Below is the macros on AWS.
exterior lights
close alaynes garage door
open alaynes garage door
open joels garage door
close joels garage door
master bedroom
living room
family room
In the device settings for the config, I choose the switch and said turn on as it goes off by timer.

You should look in your Amazon app to see what she is hearing. My bet is that you are running into a length problem or the apostrophe issue…the good thing is if you can see what she is hearing you can build aliases based on that variation. You can also look at the Live Logging to see how she is breaking the commands down.

Well according to the Alexa app she heard exactly what I said. Take a look. Ogs below also.

Yep…but again, is “Joels Garage Door” a device or a macro. If it is a macro the only way to really get this to work is to name it “Open Joels Garage Door” so it picks that up as the full noun instead of trying to activate the device (which only have on/off capabilities).

Does that make sense?

Look in the above post two up, the Macro is called Open Joel’s Garage Door. The post with my config screenshots.

Ok…but do you still have just “Joels Garage Door” in your List of Macros or List of Devices?

I think it is in both places, as it is a switch also. I just removed it from the devices list.

Well, that would explain it…if that name exists in the List of Devices but you aren’t wanting to control it directly then you will want to remove it…then the macro will be the one that activates.

OK works with single commands, not compound. I believe it is an understanding problem. Look at the logs.

Yep…it is still looking for a device to OPEN…Did you remove BOTH of the garage doors from the List of Device? It appears to still be finding those first.

If they are both removed try adding these to your sample utterances:

ObjectOperation {ExtA} and {ExtB}
ObjectOperation to {ExtA} and {ExtB}
ObjectOperation to {ExtA} and to {ExtB}
ObjectOperation {ExtA} and to {ExtB}

That will probably fix your issue. I will add that to my upcoming release as well.

OK thanks added this to my sample utterances.