SmartThings Community

[Deprecated as of Apr 8, 2018] Smart Home Monitor Exit and Entry Delays (Version1)

My feeling is this is a device hardware, firmware, or handler issue, beyond the control of the SHM Delay App. I regularly perform similar tests using a GoControl Siren that does not create this issue.

One other thought. After triggering an alarm with SHM, try using the siren’s DTH in the Smarthings Phone app to sound the alarm rather than creating another alarm.

So your saying the siren is suppose to turn on after every intrusion even if you dont clear/dismiss the alert in SHM?


However, when the siren does not support the beep command, beep simulation commands sent to it by the SHM Delay app during EntryDelay may cause it act in an erratic manner. Hence my suggestion to remove it from the Contact Sensor profile and retry your test.

I never added it to the Delay Profles in SHM Delay. I only have the siren setup in SHM.

Perhaps I’m misunderstanding something here. When you refer to “clear the alert in SHM” does this mean going into the phone app and clearing the Intusion alert or something else?

Hitting the “Dismiss” button for “Intrusion Detected!” screen.

The funny thing is I just added the Siren to the Contact Sensor profile and the siren makes a beep on entry but the siren doesnt go off as I explained until I dismiss the previous alert.

Time to contact whomever supports the siren’s DTH and remove the siren from the profile. It’s some sort of timing issue.

Arlo support asked me to try changing the Siren alarm time from 5 minutes to 2 minutes to match the video recording time. I did that and now the siren goes off every time. But now I have a new problem where the Entry delay isnt working anymore.

I tried setting True Entry Delay to On but it didnt help.

Please turn off true.entry delay. Make sure there is a entry delay time coded in the profile. Then try running your test using on button not partial

True Entry was off. There was an entry delay of 6 seconds. I only use the On and Off buttons on the panel.

After fiddling around, entry delay works again but the siren doesnt go off anymore after 1st intrusion like before. It’s either or right now.

Increase entry delay to 30 seconds. Wait at least two minutes between tests.

I did all of that, stll no siren until I dismiss.

Also, I tried setting Arlo apps mode to Armed instead of SmartThings and that didnt help either.

After you issue the alarm reset go into the device Handler and see if there were any commands issued to the siren.

Alarm reset? Do you mean disarming the system? Or dismissing the alert?

First trigger the alarm and set it off by entering a PIN code. That should send an off command to the siren. You should see that in the device recent activity or in the dth in the IDE. Then issue the reset in the smart home app to clear the intrusion alert. Were any additional commands issued to the siren?

2017-12-09 4:23:49.272 PM PST
moments ago DEVICE alarm off Home alarm is off
2017-12-09 4:23:15.923 PM PST
moments ago DEVICE alarm off Home alarm is off
2017-12-09 4:22:11.153 PM PST
moments ago DEVICE alarm off Home alarm is off
2017-12-09 4:22:08.366 PM PST
moments ago DEVICE switch on Home switch is on

the switch on seems to be the siren turning on. the alarm off after it is when i disarmed the first time.

there doesnt seem to be another switch on event for the 2nd intrusion. the 2nd and alarm off is from the 2nd intrusion disarm. i think the 3rd alarm off is from hitting Dismiss for the alert in SHM.

Since my siren works it would seem it is the Arlo device Handler that for some reason is skipping the on command

Alright I tried one more time using only the keypad to arm/disarm because I dont remember if I used my phone for one of the disarms.

Anyway here is output:

2017-12-09 4:30:01.828 PM PST
moments ago DEVICE alarm off Home alarm is off
2017-12-09 4:28:19.433 PM PST
moments ago DEVICE alarm off Home alarm is off
2017-12-09 4:28:13.509 PM PST
moments ago DEVICE switch on Home switch is on

first switch on is siren. first alarm off is disarming with keypad. then used keypad to arm system. then no siren on 2nd intrusion and i disarmed with keypad again which is the 2nd alarm off you see.

I think if somehow SHM Delay or Lock manager could send a 2nd alarm off command that it may fix the issue?

I’m not really sure what to tell Arlo. Should I send them this device event and say that its not triggering the next siren intrusion because the switch on is not present? would they even know what to do? i really doubt any of there developers are in touch with there support department.

Neither smart home delay or lock manager code is responsible for the behavior of the siren. Perhaps SmartThings support working with Arlo can fix this issue