SmartThings Community

[Deprecated as of Apr 8, 2018] Smart Home Monitor Exit and Entry Delays (Version1)

Never considered using the App for mitigating ST presence issues, but I’m pleased to know it’s working for you. My phone presence issues were severe, so I stopped using presence for anything and went with a Centralite Keypad.
Arn B

Yeah I don’t know if the the construction of the house, or position of the hub, but every time I entered the house after the house was set armed(away) I would get an intrusion notification. I have a contact sensor on the door and a motion sensor in the hall. This mitigates the slight time lag for the hub picking up my tag.

So far so good anyway.

Presence operates in the cloud, so even if it’s working perfectly, there is a delay before the system is disarmed. Based on my personal experiences using presence, I know the stress of having the system create an intruder alert when it is least expected as you walk through the door. My alert includes a 105DB siren. :scream:

Hence my reason to hold off buying a siren until this issue was worked out. :raised_hands:t2:

4 Likes

I’d like some clarification of the Caveat paragraph. It says… "During an outage if you are using SmartHome and your system is armed, locally supported devices monitored by SmartHome should trigger an alarm, and locally supported sirens should sound, you just won’t be able to turn off the siren. Also, you will probably not receive SmarthHome’s intrusion messages, and you can forget about arming or disarming your system with your phone app.

Are you saying that If the system is armed and Smartthings goes offline, an intrusion is trigger automatically
that can’t be turned off? Or Are you saying if Smartings is offline when I reenter my home,I can’t disarm the system and the siren will be active and unable to be turned off? If the system is offline when I return how would it trigger the siren in the first place? Just confused by this. please explain. Thanks

The best way for me to explain this is for you to take a look at where your applications are running.

Login to the IDE–>click “My Locations”–>Click on the name of your location–>scroll down then click “List Smartapps”

Apps showing as “Cloud” do not function when there is an internet outage or the Cloud (your execution Shard) fails.

Now on the top menu click “My Devices”. Devices showing “Cloud” in column Execution Location do not function when there is an internet outage or the Cloud (your execution Shard) fails.

Also the ST Phone App communicates with the cloud which then communicates with the Hub, so during an outage it may not be possible to arm/disarm your system. That is the reality of using a non-ADT Smartthings system. In my case I had no security system so I’m OK having a system that works 99.something percent of the time, without a large financial outlay, and no monthly monitoring charges.

One method of mitigating the internet outage issue is using a Router with CellPhone backup that has battery backup or is plugged into a UPS.

For more information search this site for “Local vs Cloud” and check out this thread

@JDRoberts if I’ve missed something or you have additional information, please feel free to respond.

3 Likes

No to statement #1, yes to statement #2.

As Arn mentioned, some components of ST can run even when the ST cloud is down.

This includes the SHM security rules you previously created, and may also include some of your devices like a siren or contact/motion sensors. Unfortunately, the ability to toggle SHM between armed and disarmed requires an active internet connection and functioning ST cloud.

So it’s possible that if smart home monitor is armed at the time the cloud goes down, you will be unable to disarm it, and if a monitored contact or motion sensor is tripped, your siren (or lights etc) will go off.

This situation occurred in the spring of 2016, for about a week or two, if I’m remembering right.

2 Likes

Hmmm, I get it. That makes sense. My internet does go down a couple of times a month . Maybe for a min or two. I was going to convert my wired ADT system to Konnected. If I use a monitoring service such as Scout, that could be a problem.

I heard that Smarttings was going to move some of the functionality out of the Cloud and to the HUB so that issues like this would go away. Anyone hear more about that?

They definitely intend to do it… But they’ve been intending this since Hub V2 was released in September 2015. So don’t hold breath! :fearful:

3 Likes

I was afraid of that :frowning:

1 Like

I’m having an issue for about a week or two, where SHM Delay triggers an intrusion every night between 11-12pm, while in home/stay.

When I look at the alert, it will say that it triggered at 11:56pm (for example), but where I look at the door history, it never opened. When I look at the simulated contact sensor history it has a lot of activity from SHM delay?

Can you help me debug? I have to disable all alarm responses because the wife will kill me if this makes her up every night!


That is strange and must be very annoying.

When SHM Delay triggers an alarm it issues an intrusion (optional by contacts, nofitiication and SMS) alert message with the name of the source sensor. Was this issued, received, and was it “Garage Interior”?

I can think of a few scenarios that may be the cause:

  1. Some software (Webcore/Smartapp) “Opens” the Z_simulated_contact_garage. Is it used by any other app? Look in the phone app My Home–>click on device–>Smartapps. Also, tapping (Opening) that device’s “Closed” button while SHM is armed should trigger an alarm whenever it is monitored by SHM.

  2. The source sensor “Garage Interior” is has a hardware issue, communication issue, or low battery

  3. Smarthings App settings are not in sync with your phone app settings. Sounds odd, but I’ve had this occur a few times. Try resaving all Smarthome Monitor settings and then the main Save button, do the same with SHM Delay and it’s profiles

  4. The Source sensor, Garage Interior is simultaneously monitored the SHM Delay and SHM. In this case remove from SHM

Should you find the cause please post it here, and if there is anything else I can do I’m ready to help.

This is normal when SHM Delay initiates a SHM intrusion. Command sequence follows:
Close the virtual sensor (SHM does not react, but insures it will react to the forthcoming Open command)
Open the virtual sensor (SHM should react)
(Issues intrusion messages as directed by contact sensor profile)
Close the virtual sensor with a 4 second delay (SHM does not react)

[Update] Dec 02, 2017 Away Mode false alarm during Entry Delay.

A followed motion sensor is defined and during away mode: you open a door starting entry delay time, walk in, then close the door, trigger the followed motion sensor prior to disarming, creating a false intrusion alert. Updated logic correcting the issue.

Module SHM Delay Child updated, install from repo or Gitub.

1 Like

Hi, I have follow the instruction and I installed the SmartApps, but I still not working. I created a virtual sensor from the IDE and linked to the virtual sensor. I have an Piezo that make a beep beep sound every time the doors open. I can’t find the Piezo in the option for the entry countdown setting.

24474551_10156093689581742_897993211_o

Re: Piezo device.
The app supports beep command sounds on devices that have capability: alarm (generally sirens) and optionally issues an entry delay command to a keypad which causes an on/off tone.
For DLNA or speakers voice and sounds try @rayzurbock Big Talker. I use it with LanNouncer on a tablet.

Suggest turning off True Entry Delay option unless there is a device that can’t be controlled in a profile causing an alarm during the delay time

Should you have other issues please post them here.

Hi, I turn off the True Entry Delay, but the virtual contact sensor not working. when I open the front door, but virtual sensor show closed and my actual contact door sensor show opened.

It would be most helpful if I knew how your system is being armed/disarmed. However, the simulated sensor and Entry Delay, can be easily tested without that information.

Test the simulated sensor with the ST phone app:

  1. Tap Dashboard
  2. Tap Armed Away
  3. Tap My Home
  4. scroll to the Sim Front Door contact sensor device. Should show “closed”. (if not tap it one time to close it.) Tap it to open it.
  5. Alarm should trigger. If not make sure SmartHome Security is monitoring the device. (Turn off alarm tap Disarmed on Dashboard then clear alarm)
    No Intrusion alert: Add Sim front Door to SmartHome monitoring

How to test Entry Delay after getting simulated sensor to function

  1. In the SHMDelay Profile set exit delay to zero, 0
  2. close Porte Principal
  3. Tap Dashboard
  4. Tap Armed Away
  5. Open Porte Principal
  6. Wait “entry delay” seconds
  7. Alarm should trigger
    No intrusion alert: verify the contact SHM Delay sensor profile info; save it then, save again on main page, retry
    Immediate intrusion: remove Porte Principal from Smarthome if not already. If motion sensor was triggered add it to profile as a followed motion sensor and remove it from Smarthome security monitoring. If multiple motion sensors were triggered then True Entry Delay must be used.

Kindly post your results.

For the exit delay I need to know how SmartHome is being armed / disarmed

2 Likes

How to test Exit delay, assuming no motion sensors create an alarm

  1. In the SHMDelay Profile set entry delay to zero, 0, set exit delay to 30 seconds (save it)
  2. close Porte Principal
  3. Tap Dashboard in phone app
  4. Tap Armed Away
  5. Open Porte Principal–>Alarm should not trigger
  6. Close Porte Principal
  7. Wait “entry delay” seconds
  8. Open Porte Principal–>Alarm should trigger
    No intrusion alert: verify the contact SHM Delay sensor profile info; save it, then save again on main page, retry
    Immediate intrusion: remove Porte Principal from Smarthome if not already.

Should something create an alarm during the Exit Delay

  • Install SHM Delay TrueExit then follow setup instructions
  • Set AlarmState by using SHM Delay TrueExit monitored SmartHome Routine
  • In the SHM Delay Profile: Set ExitDelay to 0
2 Likes

I have follow the instruction and it worked perfectly. Thank you for the help.

1 Like