DD-WRT Help


(Marc) #1

All,

This has NOTHING to do with Smartthings but I am posting here since this community rocks and is very helpful. I know there are a lot of bright folks here…I find the DD-WRT forums completely useless as it’s impossible to search and help is scarce.

So I have DD-WRT running on my AsusACRT68 router with OpenVPN and I am trying to get it to work with Duo’s two factor authentication (https://duo.com/docs/openvpn). Since DD-WRT is a stripped down Busybox Linux distro, I downloaded Tomatoware so I can cross-compile, but I am stuck on getting Permission Denied every single time I run the Make command. It’s not a file permissions issue as I am logged in as root and have rwx to everything. I have Tomatoware mounted under my jffs rw mount in /opt. The exact error is below. I am wondering if perhaps this command doesn’t run properly for my architecture since it’s not really meant for an Asus router?

root@Asus Router:/bin# make
-sh: make: Permission denied


(Chris) #2

I don’t have much to add that will be helpful as far as fixing this issue. It sounds like you’ve already looked over the most obvious things (which should include making sure that the actual files in question are rwx, and not just relying on that you can execute them). I did some poking around the web for solutions, as I’m guessing you did too. The number one Google result for this question was your post on the dd-wrt forum. I came across other sites/forums of people asking similar questions (found two posts asking for help getting Google Authenticator working with OpenVPN), and those went unanswered also.

My guess is that you are correct, that there is something specific about the chipset that doesn’t allow for the installation to proceed correctly and that it manifests as a Permission denied error. That leads me to the my next theory, that the reason these questions about how to set up two-factor authentication with OpenVPN go unanswered is because there isn’t a huge demand out there to do it. I have a similar setup as you, only I’m running OpenWRT and my OpenVPN setup is running on a Synology NAS (because setup was much easier). I’m not worried about two-factor authentication for a few reasons: 1. Connecting to my network won’t really get you a whole lot of stuff. 2. Anything that I would hate to lose I have backed up off-site. 3. I only allow one user account (with a very strong password) to connect to my VPN and that user has no access to anything else on the network. I’m guessing other people running personal VPN’s have similar thoughts (or don’t really care too much about security).

Anyway, sorry I couldn’t be of more help, but I’m hoping that hearing about a similar setup and why I’m not using two-factor helps in some way.


(Marc) #3

Thanks. With OpenVPN today, I am using certificate based authentication. It’s secure, but I like the concept of having a second factor and Duo’s two factor push technology is extremely easy to use. I can’t even run a Make command in general on my router, so it has less to do with the Duo binaries, but rather basic Linux ones.


(Nicholas Wilde) #4

Perhaps you can use Authy two-factor for OpenVPN instead of Duo’s. I’m using authy-ssh on my Raspberry Pi and it works great. I haven’t attempted using it for OpenVPN, however.


(Marc) #5

Thanks, still need to compile with “make” command. That is where I am stuck…


(Nicholas Wilde) #6

Yeah, I thought that you might have better luck with compiling Authy’s version. Perhaps it’s the compiler on Tomatoware that’s having issues with your setup. Are you able to compile anything else with your setup?


(Marc) #7

Nope, that is part of my problem. If I run “make” anywhere, I get permission denied.


(Nicholas Wilde) #8

Perhaps the there are issues with permissions and the destination directory or the actual mounting of Tomatoware.


(Marc) #9

I actually looked into mounting issues as well. All of my mount mounts are set to rw.


(Chris) #10

If you aren’t able to run the make command at all, this seems like a larger issue. If that’s the case, then how did you get OpenVPN installed in the first place?

I’m not familiar with DD-WRT, but it looks like you can run commands through the gui as opposed to connecting directly through SSH. If you’re executing these commands through the gui, then that could be problematic: http://stackoverflow.com/questions/20020469/script-works-in-the-shell-but-not-via-gui-dd-wrt-router If you are indeed using the gui to execute the commands, I’d try SSH’ing in and seeing if that produces a different result. If that isn’t the case, I’d consider blowing it all up and starting over (sometimes quicker then trying to troubleshoot an uknown issue).


(Marc) #11

Thanks. OpenVPN is natively built into DD-WRT and can be setup in the GUI. As far as running commands in the actual GUI, I am not having luck with that either. I have been trying via SSH previously. Thanks for your advice though :slight_smile: