Daylight Savings Time


(Mark) #1

At 2am, well 3am, ST stopped working. Had to hard reboot the hub to get it working again. Could be coincidence, but time is very suspicious.

Anyone else?

Don’t ask me what I think about Daylight Savings TIme. I want my post to remain free of curse words.


(jkp) #2

Okay, I have to put on my @JDRoberts cap for a moment. It is Daylight Saving Time not Daylight Savings Time :slight_smile: ok, cap off now


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #3

It’s a fact that SmartThings has always had “issues” with the change to or from DST.

There’s never been an explanation, and the issues may or may not have occurred last night / today.


(Mark) #4

I got one less hour of sleep and I still have a few clocks that have to be manually set and I think Daylight Saving Time is an obsolete, irritating convention. So, go ahead and be the grammar police…


#5


(jkp) #6

I prefer this wiki page…


(Kevin) #7

Yup, my automations didn’t set home to ‘Home’ mode based on sunup. I see it say ‘sunup’ in the activity feed, but related to that, my ‘good morning’ routine is to set home to ‘Home’ mode. and once again… DST changes strike again.


(Mark) #8

Same here plus a few other things. Thank you for staying on topic instead of policing my spelling.


#9

You can prefer whichever you like, but the fact remains that in this hemisphere it is commonly referred to as “daylight savings”. We having checking and savings accounts here and with the hour taken into account, it goes into savings. Color vs colour :slight_smile:

And you can thank Ben Franklin for this confusing and useless function in the first place. DST will be eliminated in the next decade.


(Steven Nelson) #10

How is this still an issue? Cursory Google search shows SmartThings having issues as far back as 2014 with this. W.t.f.


#11

My sunrise Routines are still running an hour early. 24 hours after time change. Hub was already rebooted yesterday.

Cloud servers clocks been updated with correct time?


(Graham Charles) #12

Is there a way to see my hub’s “time”? I can’t find it in the app. And yes, my automations are all off by an hour, too.


(Bob) #13

Has anybody affected by this issue raised a ticket to ST.
Everybody appears to be scratching around with no resolution.
Would be interesting to hear what ST have to say.
I’m in the UK so unaffected. At the moment…


#14

In IDE, you can see your timezone setting and sunrise / sunset times under Location.

Under Hubs you can see reported activity which is in utc.


#15

Nothing I’m investing more time into. Just an observation I made for others who end up seeing the same behavior. I’m sure it’s their servers haven’t been updated. Could be the fault of Y2K :joy:

We could be on a server in a state that doesn’t observe dst. :joy:


(Graham Charles) #16

So, you’re saying the answer is No?

Sunrise and sunset times and Z activity time don’t readily tell me what time the hub thinks it is at its location.

G.


#17

Not a direct setting that displays time. But you can list events under locations and that will show the last event and the current time in your locale. You can fire off a routine and then list events and see if your time is current. I’m betting that your time will display just fine.

It’s either ST or AWS servers.


(Bob) #18

You could try going into the ST app on your phone.
Go into settings.
Click on the map.
Resave your location.
Might straighten things up.
Failing that, raise a ticket to ST.
Tagging @jody.albritton. Perhaps you can ask the right people your end.


#19

Time is correct and current in IDE when listing events. Routines are firing 1 hour early (550am versus 650am) a day after dst change.


(Bob) #20

I appreciate what the issue is.
I’m just making suggestions that might straighten things up. Who knows. Has anyone tried it?
Nobody seems to want to raise a ticket to ST.