Danfoss lc-13 UK supported?

Hi all,

I can see that the lc-13 is now officially supported by ST in the ‘new things’ section in the app. However, I cannot find the device listed on the UK webpage…

Can anyone confirm that the Danfoss lc-13 is in factor officially supported?


The device handler is available…I tried and it looks to be working.

“Officially supported” and “has a device type handler created by SmartThings” are two different things.

And “officially supported” and “appears in the SmartThings mobile app” are two different things.

For example, in the US, the GE link bulbs have SmartThings-created device type handlers and appear in the mobile app, but they are not on the official “works with SmartThings” list because they have a firmware problem which causes them not to pass the “works with SmartThings” certification process.

So it depends what you’re concerned about when you’re looking for something that’s “officially supported.”

Sorry to intercept this thread - but I am having some issues with joining LC13 to my network. I already own one and that one was easy to join but the new ones I have wont connect. I have tried reset and some googling.

Any ideas to debug this?

In my experience the LC13 are VERY sensitive to interference. It never affected the connection process, but I’ve had many issues with them not receiving temperature changes. Thus, if possible, try to add the thermostat only a few feets away from the hub and then mount it afterwards(?)

Thanks. Tried to add it just few cms away from the hub but no luck. Will keep on searching for a solution.

Fyi. A hub hard reboot fixed it. Now I can join the network again.