Custom Hue LAN Edge Driver Not Working (15-16 Sept 2023) [SOLVED]

Same here stopped working. Any update on this?

I’m in the same situation as many of the above. I use switches, dials, zones and rooms through this driver and they’ve all become unresponsive after the latest update. I’m not positive if it was the 9-16 or the 9-15 update that broke it, though. The last action I see taken in my history was around 12:49AM EDT last night.

Everything shows as connected, but if I try to take any action I get the same “network or server error occured. Try again later.” Taking the same action via the official driver, the hue app, or the hue essentials app seems to work fine. I did notice that when I logged into the hue app that I had to accept a new terms of service, so I’m not sure if that’s related to the new version of their app from 2 days ago. I’ve tried re-linking the driver by starting the link process and clicking the button on the hub, but I get the same error.

ST Hub: Aeotec Hub
ST Hub Firmware: 000.049.00009
Philips Hue Hub Software: 1.59.1959194040

1 Like

I forgot what driver I was using, but looks like I’m in the same boat as many others. Noticed last night when none of my hue bulbs participated in my good night routine

I noticed I was not getting any logs from the driver at all. I restarted my hub and managed to connect and grab logs as soon as it came back online and this is the error I’m now seeing:

2023-09-16T14:50:52.269436667+00:00 FATAL Philips Hue Beta  runtime error: [string "init.lua"]:150: [string "handlers/capabilities/bridge.lua"]:7: [string "eventsource.lua"]:41: attempt to call a nil value (field 'read_only')
stack traceback:
	[C]: in function 'error'
	[string "env builder"]:95: in global 'require'
	[string "init.lua"]:150: in main chunk
^[[B2023-09-16T14:51:19.539707670+00:00 FATAL Philips Hue Beta  runtime error: [string "init.lua"]:150: [string "handlers/capabilities/bridge.lua"]:7: [string "eventsource.lua"]:41: attempt to call a nil value (field 'read_only')
stack traceback:
	[C]: in function 'error'
	[string "env builder"]:95: in global 'require'
	[string "init.lua"]:150: in main chunk

That error seems to repeat for a while now, every 30 seconds or so. I’m not sure why I wasn’t seeing it prior to the hub restart. I hope this helps.

UPDATE: The error seems to eventually stop, so I suspect that’s why I didn’t see any logs until after a restart. I’m guessing the hub just stops trying to initialize the driver after a certain point.

1 Like

@blueyetisoftware any update on the issue? our houses are dark and full of terrors right now

1 Like

I am a newer user. I am experiencing issues as well. I would like to support somehow.

Thank you for the log file. There is something odd there as the error in the log file isn’t from the latest driver. Can you verify the version of the driver ST shows that you have installed?

I believe this is the latest version, but please let me know if it’s not.

1 Like

FYI,
On the 9-16 here, as well, and it’s still experiencing the same issues as the 9-15 update.

More than happy to grab logs if anyone can direct me how exactly to do that.

Philips Hue Beta 2023-09-16.16.38.41.39

  • Fixed bug caused by versioning problem during driver deployment

So the recent issue was caused by an incorrect version of a file ending up in the driver during deployment, not in the code itself. This started with the deployments on 9/15 which lines up. The issue was fixed and the driver re-published with the correct version. This should alleviate the issue for everyone that didn’t delete all of their devices and left it alone. Thanks @HyperNeon for the log file. Led right to the issue.

8 Likes

I am now able to re-add the driver to my test hub. Rebooting live hub now to clerk it’s back to normal.

Thankfully I hadn’t touched the live hub

@blueyetisoftware

After rebooting the hub, new driver kicked in and normal service has been restored.

Thanks again for your support

2 Likes

I restarted my hub and it grabbed the newest version. I just confirmed everything is back to working as normal. Thanks very much for the quick fix @blueyetisoftware!

2 Likes

Hi Chris,
I’m not getting the new driver when I reboot my hub - do you need to do anything else in order to get it?

Just need to wait until ST pushes it out. There are a few workarounds to trigger it, but most of them will screw up your device if you aren’t careful.

1 Like

@blueyetisoftware as always thank you, all back and working… I can walk into a room as see where I’m going again :nerd_face::crazy_face:

:pray:

2 Likes

@blueyetisoftware thank you for the quick fix! I was dreading redoing up my hues lights for the umpteenth time lol

2 Likes

I definitely wouldn’t do this. It almost never works and just causes additional headaches.

I had a problem today - think my hub must have updated to the latest version, and all my automations stopped working.

Came to this topic and rebooted my hub - still not working.

Checked in the drivers section of the new SmartThings and there was a driver that wasn’t installed - Midea. Not sure what it does, exactly, but installing it immediately worked.

@blueyetisoftware - what does it do? But also thank you for your tireless work on this.

That driver has nothing to do with lights. It is a prototype for a dehumidifier driver. You should remove it. Only the Hue driver is used for Hue lights. You just need to make sure you are on the version listed above in the solution.

This probably just forced ST to check the versions of each of your drivers and you grabbed the latest Hue driver in the process.

Okay - thank you for the helpful update!

I’ve removed the Midea driver, but it’s worth noting that the description of the driver isn’t very intuitive, so perhaps changing that up a little?

Thank you again for this work and your rapid update.