Custom driver for Aqara Contact Sensor not listed

I have created a simple edge driver that (for now) counts the number of times a Aqara Contact Sensor has been opened and closed. Everything seems to be working and I have enrolled and installed the driver. It is however not associated with the device. I can see the driver and the device, but I cannot select the driver in the available drivers for this specific device. Any idea where I need to define this association? I thought it was in the fingerprint.yaml and then in the lua file.

Hi, @Meltinis. Welcome to the SmartThings Community!

If the correct fingerprint for the device is included in this file, it should be recognized as compatible.
Which driver is currently controlling the device?
Have you checked if the “model” and “Manufacturer Code” values that appear for the device in the Advanced Users app match the ones you used in the fingerprints?

2 Likes

Thank you for the quick reply. I have updated the fingerprints.yaml and re-installed the driver - but still not on the list in the Advanced Users App or mobile app. Do I need to reconnect the devices?

Currently it is running on another custom driver - Yakov’s SmartThings Edge Drivers (Beta) which works fine - I just need to adjust it for a different purpose.

My fingerprints.yaml looks like this:
fingerprints:

  • id: “Aqara/Sensor”
    manufacturer: “LUMI”
    model: “lumi.sensor_magnet.aq2”
    deviceLabel: “Aqara Rain Gauge Sensor”
    deviceProfileName: rainGaugeProfile

Found the issue - I used " in the model string… works now.

Thank you for your help

1 Like