Custom Capability and CLI Developer Preview

Thank you, @RBoy for letting us know about this issue. Our team is looking into it in detail.

It happens automatically, you can check your version by going to any random device in the app, press the 3 dots in the corner and then information. The version number should be there

the workaround to kill the app, edit device label in ide then restart the app is no longer working to pickup updated device config.

kind of dead in the water here.

Is there any update regarding creating automations using custom capabilities??

1 Like

so automations can’t control simulated devices? was trying to setup SPS to mirror the phones using automations … since phones don’t show as up presence sensors anymore. that’s how i found out.

writing generic code to control any device from any automation and allowing automations to execute any command supported by the device is simpler than supporting controlling some devices and not others. won’t even go into the bewildering decision of why phones don’t show up as presence sensors anymore.

so ST … if one is permitted to ask … why on god’s green earth doesn’t automations support controlling simulated devices?

thank you.


this needed a solution. hate doing one offs. so ported WATO … something i had coded for the HE platform last year. solved my presence sensor problem but is capable of doing much more than just that:

Anyone else have trouble getting there custom capabilities to appear in the REST API. It seems sometimes they will appear when I make a request to get the status of a device and then sometimes they will be missing.

Any help/tips would be helpful!

When generating custom capabilities I can’t get the associated control to show up in the device’s details. Is there any new steps that are missing from the guide?

That makes 2 of us. Anyone?

I’ve lost track of what is going on. Last time I experimented I found that capability presentations were now updating independently of the device presentations. Any change I made to a capability presentation would now be applied to every device that was configured to use it. This solved the problem of needing to generate a new device presentation every time, but created two new ones because there was no way to stop it being used for a device, and no way to make it appear instantly. I just had to wait all day or all night and see what happened.

I was surprised that others didn’t seem to also be seeing this, but perhaps they are as it would explain why capabilities often seem to show up when others try them.

how does one present these full width cards with tabs like home monitor does?

thank you.

Hi, @RBoy

I’ve been testing around this issue and now the Thermostat Heating Setpoint capability is displaying correctly with DTH and ST Schema devices.

Can you please confirm if it is working for you as well?

Yup it’s back in all the heating thermostats, thanks for the update @erickv


Awesome! thanks for the update.

1 Like

Up to now, it’s not available the option to change the appearance of the different display types (State, toggleSwitch, etc.), e.g. font size, icon, etc.
The same applies to develop something similar to Home Monitor because this is a SmartApp with a customized UI.

ok. thank you for the update.

when is the ability to customize UIs going to be available to us?

There’s not an ETA yet, we’ll update you once we have news about it, and also, the announcement of this feature will be hard to miss.

are there any ETAs available for any of the upcoming features and fixes?

sorry, wasn’t asking about the announcement of the feature. was asking about when a working version of the customize UI feature would be released.

thank you.

I’ve been trying to follow this conversation as I am one of the users affected by a loss of setpoint control on my Master Bedroom Thermostat device (GoControl TBZ48). Ironically, I have two such devices in my home. The other device, Living Room Thermostat, has the controls for adjusting the heating and cooling setpoint. Do I just need to delete the Master Thermostat device and pair it back to reacquire that capability on the Master Bedroom Thermostat?

It’s not working for me. Should I delete my device and re-install it?