CT101 Thermostat Missing Battery Status


I recently removed then added back my CT101 Thermostat, but after adding it back the Thermostat screen is now missing the battery info. I have another CT101 Thermostat and it still has the battery info. I checked the device and both are using the “CT100 Thermostat” type. There’s nothing different between the two devices, just that I removed then added back one of them.

I’ve only seen old posts about this and doesn’t apply to the new SmartThings app. Any idea what is going on and how I get get the battery info back?


Try re-pairing it and hopefully it’ll be fixed.

Otherwise if you have access to rboyapps use this device handler

It also provides you access to advanced CT features like control locking, humidity and temperature sensitivity adjustment, fan state, pairing mode and more


Thanks for replying! I was playing with re-pairing and stuff, that’s how it lost the battery indicator. I just don’t know why it’s gone when it’s using the same SmartThings provided device handler.

Oh well, I guess it’s not that important, the battery life is pretty good on these. I think the one that lost the battery indicator is going on 1.5 years already. LOL

Try changing the device handler in the IDE to Z-Wave Battery Thermostat.


Already tried that, but for some reason, the Z-Wave Battery Thermostat doesn’t have the set temperature function. It does show battery but makes it kind of pointless without the ability to set the heating temperature.


From the IDE create a new device handler using “From Example” and chose Z-Ware Thermostat. Save and publish.
Then make the following changes to the DTH and save and publish:

Replace line line 15 with:
definition (name: “Z-Wave Thermostat with Battery”, namespace: “smartthings”, author: “SmartThings”, mnmn: “SmartThingsCommunity”, ocfDeviceType: “oic.d.thermostat”, vid: “generic-thermostat-1”) {

Insert the following below line 26 (will be a new line27)
capability “Battery”


Thanks for the tip! This is giving me battery, but state, mode, and fan mode are duplicated in the app. I’ve tried something like this before by modifying the existing CT100 Thermostat DTH, but it seems the app doesn’t show any of my changes except when I change the “vid” in the definition to some values I found in another forum post.

That’s strange. I did not get any duplicates. I was using the z-wave battery thermostat DTH before I switched last night. When I made the change instead of using published I used draft on the thermostat update page. I closed the mobil App and cleared the cash. When I open the mobile app I got the following.

Yea, I’m finding the new app very strange, it just doesn’t work as well as the classic app. I don’t know if maybe something happened with the migration from the classic app. I tried to install the classic app on my new phone and it’s not even in the play store anymore.

Top part of my screen with your changes, you can see the battery indicator is at the top.

Bottom part of my screen with your changes, you can see fan mode, mode, and state is repeated.

It’s odd to me how the same DTH labeled “CT100 Thermostat” displays differently for me. One was migrated from the classic app, and this one I recently removed and re-added now is missing the battery status. I’ve tried many different things, that’s why I posted to see if maybe I’m missing something.