Cree & GE ZigBee Bulb Issues

Mine worked the other way around.

Turned off the lamp with Cree.
Click on + to add devices (did not select specific device)
When in discovery mode, turned on the lamp with 2 crees plugged in. Both discovered.

Note: when I tried adding it with the specific “Cree” bulb, I was presented with the same two options that you mention.

Works. Each paired in under 10 seconds.

Using a wall-switched fixture on the opposite side of the house they were reset and paired like breakfast and bacon. In this case, I just reset bulb, turn them on, and search. Took all of 10 seconds to find each.

I have to say, without having you guys to bounce things, this would have been a fail. Oh, and @chuck_pearce, thanks for pointing out how cheap these are. That kept me in the game.

I found finally from help at ST, that I had a paired “Unknown device” that was my “almond + window switch” that I was messing with. By advice from the help crew for ST, they directed me to delete the unknown item and Voila! the Cree bulbs started to detect. So if you have any paired “unknown” devices that have nothing to do with the Cree bulbs, delete them and then try a reset / re-pairing of the bulbs.

I put to GE Zigbees into the system last October. They worked fine.
One of them appears to have died. The app is still running the schedule but The light is not on when I check my security cameras (they’re in a vacation home). I’ll be checking it out shortly but figure the bulb went bad and will have to exchange it

I have 6 cree bulbs set up in our master bathroom. They paired after a while, but they aren’t working reliably at all. Sometimes they work as intended, other times one or two become unresponsive. The one or two that become unresponsive is random it seems. My ZigBee firmware is up to date. Any ideas on what the issue could be?

I’ve had reliability issues with both the GE and Cree bulbs. I was really hoping that the Cree bulbs would be better.

I picked up 6 Cree bulbs Saturday. They are working great so far, better then my 1 GE Link I have.

One question, some of the bulbs are on a regular switch. If they are switched off and back on, they come on. However, ST does not realize they are on. I have a rule set to turn them off after X minutes, but ST does not realize they are on. Any ideas on how to get ST to realize they are on?

This is the same with all connected lights i am finding. My Hue bulbs do the same thing in SmartThings. i mentioned this to support for the issue I had with my Cree bulbs,

Here is my statement to them:
Josh Koehler
Mar 3, 11:20 AM

Yep, when I turn it off and then back on.
When it’s off at the switch, but the bulbs were on prior, smart things still shows them as on. When you change the state manually in smart things to reflect that they are off, and then turn the switch back on, the bulbs light up, but they still show as being off in smart things. It’s like the hub doesn’t know what state they are in any more as it’s waiting for an action to trigger the polling of the state from the bulbs.

and this is their response:


Thanks for the info – that first part is expected for now, as the state is essentially “unknown” when the bulb is turned off from the switch. But the second part seems like it should work better than that. I’ll pass that along to our QA team to take a look.

Thanks again, and let me know if you have any other questions.


This is just how zigbee bulbs work, any brand. Not an ST issue. They are intended for always on installations. You will find much discussion of this in the forums. The simplest solution is to use smart switches, but that does cost more money.

A cheaper alternative is just to put a switch guard on the light switches so they can’t be turned off from the switch.

It seems like a simple fix. When the bulb regains power, it should send a ping back to the hub to say I’m back and I’m on.

Am I right?

Not in zigbee networks. The bulb isn’t smart enough to know it was off, and it doesn’t ping the hub.

What you’re describing would fit a WiFi network. But not mesh, it’s just not what they’re intended for. Minimal cost because of minimal traffic and pretty stupid (and therefore cheap) end devices.

JDRoberts, I respectfully disagree. The allure of a mesh network is that devices can come and go and the mesh stays strong…

Bulbs should be fine, but it seems like something in ST is causing it to “forget” the deviceId as part of the poor fingerprinting and join process.

My apologies, and good catch.

There are two separate issues discussed in this topic.

The first one, that the hub gets confused about the status of a bulb turned off manually, is the one I was referring to as just a fact of life with zigbee devices.

The separate issue you’ve brought up earlier in the thread of the zigbee bulbs forgetting what network they belong to (or perhaps the hub not recognizing them when they return) is indeed a flaw that may be specific to SmartThings, and definitely shouldn’t happen. That’s the whole point of mesh, as you mention–the nodes should not have to be re-paired after a temporary absence, regardless of the reason for that absence.

It may, as you suggest, have to do with ZHA vs ZLL, I don’t know. But that’s one that needs fixing.

Thanks, I can say that my 100+ zigbee C4 mesh has devices dropping and adding all the time. Heck my sr250 c4 remote lost battery power for over a month, just pop in new batteries and its syncs right up…

Same thing with my motion sensors, had one lose battery in the winter up high, outside… Replaced battery, boom, working again.

I still think there is something I can’t put my finger on, but a flaw in the HA light profile / fingerprinting that just causes ST to gain amnesia over the deviceId (not the MAC) and upon re-joining creates a new deviceId instead of picking up the old.

Finally getting enough of these bulbs to try to isolate so I can work with support to try to fix. Problem is I think it might be when ST reboots a server, of all things that could be causing the issue…


I just bought 4 cree bulbs and all of them paired with ST and are working great as of now. I have used them for all my lamps as i want them to turn on and off based on a schedule anyways.

I did have a tough time getting one of the bulbs connected but use the following two tricks if u have issues. They worked for me

  1. Dont put the hub in pairing mode first - first turn the light on and then within next 2 secs click on the “connect now” under the cree bulb option of smart things app - 3 of my bulbs connected immediately that way.
  2. For the fourth bulb which was giving issues, i followed the same process as above but still did not work. So i took the bulb right next to the hub and followed the same process. It connected immediately.
    Then i shut the hub down for about 10 mins and powered it again… To help the zigbee network repair itself… Just to be sure and now all 4 bulbs are working great.

Hope this helps others as well.



Turned out the fixture had been turned off so there was no power to the bulb.
All is well now

How long are people seeing for the Cree to update it’s on/off status in ST? Even though I only operate mine via minmote, the status isn’t getting updated which is playing hell on the “toggle” function of the minimote app.

My Cree bulbs have been hit or miss using the app, the minimote or automation tasks. I may try pairing them to my Hue bridge instead of Smart things and see if the reliability increases to the level of my Hues (Which I control outside of ST due to its bugginess). I am hoping that the Zwave lights from Aeon Labs work more reliably than the Zigbee lights. At least then I should be able to pair them up with my GE secondary controller for the times we lose internet. To answer your question, i’ve had it delay up to 3 to 4 seconds, other times its instant, and thats the 50% of the time it works at all. The other 50%, nothing happens. I see in the app that the remote press works, or the hello home action fires etc, but the light just sits there…and does nothing.

1 Like

Mine never update. if we drop power all the lights come back on full power. Some of these lights are outside the house and I might not notice they are on. Why don’t they get polled for their state. it can be one for days and still shows off in the smart app. And because smart things thinks it is off even when it is not it never shuts it off unless i call for it to turn on then back off. is there any trick to getting these to report what state they are in.