Cree Bulbs Listed as Unavailable After Power Outage

Hi Guys,

I thought I’d pass on something that happened to me today. I’m hoping maybe you have a more elegant solution to this problem, but as a worst case, maybe this will help someone? I should point out that I am a relative newbie to SmartThings.

We had a power outage last night, and when power returned, everything was fine except for my Cree light bulbs. Another brand of bulb, Sengled Element Classic A19’s all were unaffected.

After power was restored, all of the Cree bulbs were listed as “Unavailable” in the SmartThings app. Sure enough, they were not controllable. I tried cycling power on each, and the state didn’t change. I rebooted the SmartThings hub, and no change.

This morning, after having left each of them off all night, I tried again to turn them on, and was hoping I’d see they were available, but no luck. My next step was going to be to delete them, and re-connect them. However, after actually removing and restoring one, I discovered a happy accident that restored the remaining Cree bulbs without having to delete them first (which of course ends up messing up all the automation routines which referenced the deleted bulb).

What I did was this:

I tried to add a new device (in this case, I didn’t remove the device first). Then turned on the “Unavailable” Cree bulb. No device was found, so, I clicked on “Find Manually”, and then clicked on Light Bulbs. Interestingly, there was a device listed (and unfortunately, I can’t remember the terminology now) that indicated it was a unnamed Cree bulb already known to the system. At this point, I just backed out (“Cancel”), and to my surprise, the previously unavailable device was now listed as “On”, and no indication of being unavailable. I repeated this process for each of my unavailable Cree bulbs, and it restored every one of them.

Any thoughts? Hopefully there’s a better and more logical way to restore unavailable Cree bulbs?

I used to have that issue with my Cree bulbs and I decided to use the power outages to my advantage. I removed the batteries from my hub. An extended outage will force a rebuild of the zigbee mesh when power is restored.

I had the same experience as the OP. The power outage occurred while I was out of town, so my security lighting was dark for the better part of a week.

It sounds like removing the batteries from the hub is the answer, and then plugging the hub directly into a outlet (I currently have my hub plugged into a UPS.)

I wonder if there are any other implications resulting from removing backup power on the hub? How long does it take, once power is restored, for the hub to rebuild the mesh?

Thanks!

I’m sure the total rebuild time is dependant on how many and type of other zigbee devices you have. I’ve read where some meshes can take hours to rebuild, but in my case, the Crees and all of my motion sensors are up and functioning in about 30 seconds.

The only implications i could imagine would be automations tied to the states of those devices. I do have my hub behind a surge protector as it seems the power company is always doing line work in the neighborhood.

So glad I found this thread. I pulled the power and batteries, but after a reboot, I still had no control on my Cree bulbs. I did the thing where you went and added a cree bulb specifically, switched it on, and just like you said, it found it again. Had to do it for each bulb, but great not to have to rebuild automation. Thanks all!

Just had my first Cree blub meltdown. For no specific reason I had 7 Cree bulbs running 0x20A firmware go offline yesterday. I unplugged the V2 hub for 30m and they failed to rejoin after 24hrs. Ended up doing a painful experience of reset. This is the combination that finally worked for me.

  1. Turn the light on and leave it for a couple minutes.
  2. Turn off and do an index-finger to thumb tap for 3 counts, then turn on and an index-finger to thumb tap for 2 count.
  3. Do this for at least 5 times; or until when you cycle the light on - it will give an obvious BLINK.
  4. Turn the bulb immediately off after the blink and go to the app, marketplace, cree, and start the search.
  5. Turn the light on - the app (classic in my case) should find it with the defined name you set previous.

I think this was more successful when I didn’t have another Zigbee close to the one I was resetting, but can’t this say this for a fact.

I was a big supporter of IP devices, but wanted to move to Zigbee or Zwave to have better security. Looking at big box of WeMo switches and thinking at least IP was a devil I know.

Good luck to whoever is reading this attempting to rejoin your Cree!

May 24, 2019 - happened again after the 25.32 firmware upgrade to my V2 Hub. Edited this post.

And an even simpler path, based on the latest iOS software version:

  1. Add Device/Scan nearby
  2. Toggle the lights off/on

All lights on that switch will show up again. Move to the next station and repeat.