Creating new topics on Android is impossible - Solved!


(Eric) #1

I tried creating a new topic on my android phone in Chrome and Firefox, but the page formatting made it impossible to see the line where I label the Topic. Is anyone else having this problem? I even tried “Request Desktop Site”, but that didn’t help.


#2

Yes, I’ve noticed this as well.


(Mike) #3

same here, impossible to create topics on Android, i have to switch to a tablet or pc if i need to create a topic


#4

Hey all,

This is very possible. Yes it’s a little inconvenient, but it is a viable workaround so that you can do it from your Android and not have to resort to a laptop or other non Android device.

You were on the right track with requesting “Desktop site”, but that doesn’t work.

Here are the steps:

From the Main screen in the community:

  1. Select the Hamburger in between the Magnifying glass and your Profile icon and scroll down to bottom and select Desktop View

Now, it will be a little harder to navigate because of how it is rendered on your phone, but you can manage.

  1. Click on the + symbol

  1. A New topic will open and at first it will appear that you have the same issue:

  1. Now if you simply press the back key on your phone, the keyboard will disappear and you will see that you have the Topic title available to you:

  1. Now with your finger, press inside the Topic, your keyboard will reappear and the Topic field will be hidden again. Now type in your topic title carefully.

  1. If you fudge it or mess it up or want to change it, just press your finger at the end and then either backspace to remove everything or continue typing.

  2. If your topic is similar to another, you may see the blue bar pop up to the right which you can simply press the small X and the topic recommendation screen will disappear

Now that you have your topic typed in successfully, you can now Categorize and complete the Summary section.

After submitting your new topic, select the Hamburger again and select Mobile view.

There’s a workaround for everything. :joy:

Eric, make sure to mark this post as a Solution.

giphy (7)


#5

Yup. But if you type the title and then move to the body you can edit the title afterwards.


#6

You can only edit the Topic title/field if you hit the Back key so that when the keyboard disappears, the Topic field reappears on the screen and then you have to place your finger on the Topic field again to begin typing in that field and when you do it, you are typing blindly in the the Topic. I posted the exact steps with screenshots as to how it behaves on Android. Please don’t add confusion for people.


#7

No. You can edit the title after you post.


#8

All you are doing is adding additional confusion for everyone. The basic steps for what I posted will allow people to be able to use Android and create a topic, PERIOD! Where they otherwise couldn’t before my post. The little nuances in between and how my Android behaves, it doesn’t react the same way on mine. If someone has that ability in their Android, they will be able to see those little nuances where they can edit or reedit the title. I appreciate that others want to help, but you throw out a vague post, yup…but… which is so not helpful.

The steps I documented and spent the time documenting work to allow those including yourself who couldn’t create a topic on Android prior to this. How they get between the dots within the procedures I posted and how they edit the title is of little relevance. Glad you can re-edit without it disappearing. Mine does not allow for it, so if anyone has the same experience as mine, they follow those instructions. If they have the ability to find a different shortcut to re edit it, great. But your first vague little post just adds confusion for people and then your screenshots all scrunched together without an extra line return, makes it that much harder and more confusing. Thanks for the help, but the instructions I posted will work for EVERYONE on Android.

Also what you failed to mention or convey in your post was that you were able to EDIT the existing Topic title AFTER you had already submitted / created it. This was / is not the issue that people were reporting. It was for on CREATION and NOT being able to TYPE in the TOPIC field to even CREATE a NEW TOPIC. I realize you are trying to be helpful, but in this case you aren’t.


(Sam Saffron) #9

Can you test in safe mode?

Head to: https://community.smartthings.com/safe-mode

Tick “disable current theme”

And then see if you can create a topic on android


#10

Yes, that does work. This functionality is identical to changing to Desktop view in the main site without having to go to safe-mode and uncheck / check options. And when you close the window, that function is gone. So there are two ways of achieving this, so people can choose whichever method is easier for them. Thanks for the additional workaround and helpful post.


(Eric) #11

Done, sir. Thank you. :slight_smile:


#12

:slight_smile: doesn’t look like it got marked. Select the little ✓ box on that post


(Eric) #13

Ah, I figured it out. All fixed!