Could not create mobile presence device

My wifes Samsung S8 has been “Present” for months. I haven’t had a chance to mess around with it until now. I verified the following:
-Location accuracy set to highest
-App is not optimized for battery life
-She is logged in with her own account
-Device showed no activity for greater than 7 days according to the app.

I figured I would just uninstall her presence sensor and the app and start over. But when I get to the point of adding her mobile phone back as a presence sensor, it gives me “Could not create mobile presence device”
Not showing anything in the IDE logs.

I’ve scoured the forum and the internet and have found “similar” problems, but none seem to flat our deny you from creating a mobile presence device. Anybody have any ideas??

try logging out of the app and re-login

Have you verified that after uninstalling it’s not in the IDE any longer?

Are you using the classic app?

Have you logged out and logged back in on her phone (without uninstalling/deleting the app)?

Are the presence devices that are showing up in the IDE the only ones that should be there with hers deleted?

I have verified her device is no longer in ide.
I only have my presence sensor (phone) showing.
I’m using the classic app.
I’ve tried logging out and logging back in without uninstalling (several times)

Ok so I broke down and went with life360. I’d prefer to not have to use a third party app to fix a broken feature of the native app, so if anyone has any suggestions…

Have you contacted ST support. They can work wonders when given the opportunity.

That’s a good idea. Thanks!

Did you ever get an answer to this? I am having the same problem on my S8…

I’m having the same problem with my LG G6 android smartphone. I try to add my phone as a presence sensor (mobile phone) and I get the error message, “Could not create mobile presence device”. I tried rebooting my phone, but nothing works.

Same issue here on LG G5

Same issue here on Galaxy S7. Any resolution to this issue???

I ended up resorting to the wifi work around with virtual presence sensors.

This same thing happen to me but I did find a fix. What I did was remove smart things app. I remove my Samsung account from my phone and restart the phone. Then added the smart things app back. I remove the account to that phone from another phone (Master account) and then put it back on there. Then I logged back in from the phone that was giving me problems and it worked.

I think the problem has something to do with the Samsung account .

So, you removed smartthings from the old phone or the new phone? (Or both)

Then you revoked access to that phones account and re-added it?

Just trying to follow the steps you said you took.

I think the key is you have to remove everything from the old phone. Samsung log in and Smart things app. Once you do that go to the master phone or another phone where you can add and remove users from smart things and remove the user that the old phone is for. Then add them back . Then add smart things back on the phone you want to to add that user back too . Hope that helps.

Sorry, I figured it out… it was indeed the Samsung account on the old phone causing the issue. I wound up creating psuedo accounts for the old phones so that I could still use them as well on wifi. :slight_smile: