Correct Device Type to See Who Unlocked a Z-Wave Schlage Connect Touchscreen?

BINGO. Thank you. I had to delete a user and re-add because it kept saying “Unlocked by Code 30” but now it’s working like it should. Thank you, @Automated_House.

1 Like

Where do you change this Device Type?
Using the new app and Schlage BE465 Connect Z Wave

Https://account.smartthings.com

Thank you. I can see on the event report that code 5 unlocked the door at a certain time. My SmartThings send a message to say “Front door unlocked”. But it doesn’t send the code to say who arrived home? Can the message be extended to contain who is coming and going?

Do you have Smart Lock Guest Access installed?

Yes I do plus 5 user lock codes

Interesting. And when you look at the Type field for the device in the ide, what was it set to?

That is on the lock itself. I also used to be able to manage user codes through my hub when on Wink but I have jumped ship and just migrated full over to SmartThings. I just don’t seem to have full functionality other than lock or unlock with a message being sent

Z Wave Lock

Name Z-Wave Lock
Label Front Door
Type Z-Wave Lock
Version Published
Device Network Id 11

Hmm, may need to reach out to support then. My lock uses the same device handler and with Smart Lock Guest Access it sends the specific code used each time. Did you re-setup the codes through smart lock guest access after your migration from wink?

No, I did not do that. Maybe I should try a restart again.
Sorry Jimmy, I am trying to understand. I found this but there is no Smart Lock Guest Acces that comes up. Maybe it is not on the New App?

Setup Smart Lock Guest Access

To get started, first enable the Smart Lock Guest Access Recommended Automation in the SmartThings app:

  1. From the Home screen, touch the Plus (+) icon and select SmartApp
  2. Select Smart Lock Guest Access .
  3. Touch CONTINUE .
  4. Touch Allow to confirm

The Smart Lock Guest Access card will be automatically added to your Home screen.

Current States * battery: 84 %

||Current States|* battery: 99 %

What country are you in? It should be listed at the top when adding a Smart App.

Canada. The weather app doesnt show either

Ah. The new app has regional restrictions. So this may be what’s happening.

Is LUM available on the new app or is it a classic?

LUM can be used in both apps