CoRE - Get peer assistance here with setting up Pistons

Fire up IFTTT and start a new recipe:

name it speak, or something simple you’ll remember, you’ll put this in CoRE

if SMS (make sure it has your phone number setup)

Send IFTTT any SMS from {your number}

then Maker

Action Make a web request

URL:{your token}/smartapps/installations/{your core install}/ifttt/speak

Method: Post

Content Type: application/json

Body: {“message”:{{Message}}}

Save that.

Do a new piston:

Make sure under the If Trigger you select "Import event data on true.

That’s it, send a text to IFTTT’s number that they gave you in the setup of the recipe, and whatever you send comes out of whatever devices you’ve setup in the Piston.

Get your URL from the dashboard for CoRE.


i have also found that core doens’t update the simulated presence sensor (stock one) as a THEN output.

Did you find another presence device type that works at all?

No problem, I’m glad it’s working out for you.

Ok, so – we’ve just gotten this all set up, and have CoRE running several pistons, and all is fantastic, with one exception. There are two of us, and both of us want to have access to the same CoRE, but whenever I try to add a piston, “You are not authorized to perform the requested operation” comes up, and I’m not able to create my own stuff. I’ve tried restarting the app, my phone, logging out and back in, uninstalling and reinstalling the app, and resetting the security tokens, but
I’m still unable to add anything (I can, however, edit previously existing pistons).

Any thoughts here would be hugely appreciated!

I think you have to use “stays inside range” if you want to use for at least 20 minutes, and the counter starts when the condition (Lux between 100-400) meets.

Have you tried playing with Universal Virtual Device Type (uDTH)? You can use a virtual switch on/off as input and output present/not present.


Make sure to access CoRE from with the SmartApps menu and not from the Marketplace.

That’s how I’ve been getting in - in fact since he published CoRE it doesn’t even show up on MyApps in the marketplace. I can only see it in the Automation > SmartApps menu. I just can’t add any pistons.

Hmm and you’re able to edit existing pistons. Did you have to readd those pistons after you uninstalled/reinstalled the CoRE app?

Is there documentation somewhere that goes over the basics for CoRE? ex: the logic behind the various piston modes, how often the software evaluates all pistons, etc.

Look here…

And this is also of interest…


Thanks Michael, I will try this out!

This worked for the first text that I sent but not for the subsequent texts. When I check the IFTTT recipe log it is giving me a Maker Action Error. I set it up exactly as shown and like I said it did work the first time. Any ideas why it wouldn’t work after that?

1 Like

Mine works consistently - what error are you getting? Check the URL, even try and open it manually in a browser…

The below piston is sending the push notification for closing when dark right before it closes and then once again right after the garage is closed. Any idea why the second notification is occurring?

It works when I put it in a browser but it uses the same text that I first sent to test it. And it says it over and over for about 3 times. Now I just sent another text with something different in it and it did work but again it keeps repeating.

And in the IFTTT log it says Maker Action Error and then Action Error Skipped and then it fired.

My guess is that the first IF is True so it sends the notification and then the OR IF is true after 6 minutes so it then sends a notification as well. Maybe it takes over a minute to do the first part and so it makes the OR IF true also.

Could be because the lux is right around 2800 lumens and goes up and down slightly? Enable the “only execute on piston state change” restriction, see if it helps

The Bloomsky lux only updates every 5 minutes, so it’s unlikely that it would fluctuate like that. Especially since both notifications come within a minute of each other. It’s like the state change on the garage door contact sensor somehow cause the second notification. I’ve enabled the piston state change restriction for the actions. Thanks for the tip!

You can always enable the logs and see what’s happening… got any logs?