Cooper Aspire RF syncing master and auxiliary switches

I’ve been trying out a few different dimmers and switches for a new home I’m currently building, and I finally settled on the Coopers. Everything was looking and functioning great until I decided to hook up the 9540/9542 combo for a 3 way. The bidirectional association with the Minimote worked great to keep the switches synced when manually pressed, but any control from ST would throw them off. My troubles truly began when my wife had to double tap the aux to get the light to turn on in the morning. I honestly didn’t pay it no nevermind, but when the wife started to complain it was all over. I decided to try the Smart Lighting app as suggested, and it has been working great to keep the aux switch synced even when turning off the master from ST. Now, it doesn’t keep the dim levels synced but that really isn’t important to me. The way I set it up is as follows:
Which light to control? 9542
What do you want to do? Turn On
How trigger action? Switch Turned on/off
Which switch? 9540
Turn on lights when… Turned On
Turned off as well? Yes

Hope that helps someone.

I had some compilation issues with your device @Lgkahn - (Org.springframework.dao.DuplicateKeyException, fixed by removing the 2nd capability “Switch Level” line).

No luck with device discovery on my RF9540.

Can you elaborate on steps to get discovered?

Try excluding first. In and off multiple times should work for exclusion and joining.

to exclude goto my locations.
select the gear on top right
scroll down
select the hub
select zwave utilities
select general device exclusion

start hitting the on off button on the switch till it excludes

then try rejoining

I toggled on/off multiple times, then as I was RTFM’ing on inclusion, saw this bit about inclusion:

“Then press the device switch one time to include it in the network.”

So…I went to discover device, then hit the switch ONCE…boom - there it was. Device type works great.

Thank you for assist!

1 Like

Can someone please explain the details on how to use the minimote for device association? The manual that comes with the remote only talks about adding or removing devices from the network.

I have 1 RF9540-N master dimmer and two RF9542 accessory dimmers connected in a 4-way setup. All 3 devices have been added to my home hub (v2) network but when I couldn’t get the accessory dimmers to control the lights, I found my way to this most helpful thread. I’m trying to follow Ash’s 8 step bi-directional association instructions. Just can’t quite figure out step 1, “Enter association mode”.

Thanks

Did some additional searching and figured it out. The minimote I purchased (DSA03202 v1) need the firmware upgraded first which makes the lower left unlabeled button the “associate” button. Do a google image search for AEON LABS minimote and you’ll see the difference.

I added the minimote to my home hub although I’m not sure I really needed to do that.

I did six separate associations, exiting association mode after each step.

  1. Master+Acc1
  2. Acc1+Master
  3. Master+Acc2
  4. Acc2+Master
  5. Acc1+Acc2
  6. Acc2+Acc1

Scroll down to the section of this minimote manual for instructions on Associating Z-Wave Lights/Switches/Gateways to Z-Wave Sensors in the Network.

2 Likes

Maybe this sounds a little bit dummy but my knowledge on electricity are very primary. The accessory dimmers RF9542 are the non RF, if I currently have a 4-way setting that I want to replace with the Cooper RF9540 I don’t need the accessories to have z-wave, correct?

Thank you,

YP

Here are end to end steps to create bi-directional associations with Cooper Aspire z-wave dimmers + minimote (DSA03202W-ZWUS v1 with firmware 1.19) and SmartThings Hub v2.

A) First Add the minimote as a secondary/inclusion controller;

1)	Press the button labeled "Learn" – The blue LED will blink slowly.
	(“Learn”  is the lower right button “Join” on the minimote DSA03202 v1 after upgrading to firmware 1.19)

2)	Press the button labeled "Include" on the other Z-Wave controller – The blue and red LEDs will blink quickly to indicate detection of the other Z-Wave controller.
	(On the ST hub, this would be the “add a thing” process)

3)	Consult the operation manual of other controllers for instructions on how to add the Minimote as a secondary/inclusion controller into an existing network.The blue LED will stay solid for 2 seconds to indicate success; the red LED will stay solid for 2 seconds to indicate failure.
	(On the ST hub, this would be the “add a thing” process)

B) An association is required to create a 3-way between 2 RF switches or dimmers. In such a case, 2 associations must be programmed; the first would be from the Master to the Accessory; the second from the Accessory to the Master.
The Minimote is capable of setting bi-directional associations:

1)	Press the button labeled "Associate" – The blue LED will blink slowly to indicate that the Minimote has entered Association-Mode.
	(“Associate”  is the lower left unlabeled button on the minimote DSA03202 v1 after upgrading to firmware 1.19)
2)	Press the Z-Wave button on the product you wish the sensor to communicate to – The blue LED will blink quickly to indicate detection of the Z-Wave device.
	(press the main toggle button on the Cooper Aspire zwave switch)
3)	Press the Z-Wave button on the sensor – The blue LED will stay solid for 2 seconds to indicate success, the red LED will stay solid for 2 seconds to indicate failure.
	(press the main toggle button on the Cooper Aspire zwave switch)
4)	Repeat step #3 for all sensors you wish to be controlling the device in step #2 or press any button on the Minimote to exit Association-Mode. (The blue LED should be blinking quickly again as in step #3.)

	For 3 locations, create six separate associations, exiting association mode after each step.
	1.	Master+Acc1
	2.	Acc1+Master
	3.	Master+Acc2
	4.	Acc2+Master
	5.	Acc1+Acc2
	6.	Acc2+Acc1

1 Like

Hi. Could someone with 95xx-N + 9542-Z associated, let me know if:

  • 95xx-N is off
  • 95xx-N dim level is physically changed while it’s off
  • 95xx-N is turned back on with a physical tap

Where does the 9542-Z level end up at (same as 95xx-N or at the level 9542-Z was previously at)?

Thank you!

(I am new to all of this, and am surprised at how obtuse it all seems.)

Disbelief:
I can’t get my 4way to behave as I would expect they should in a simple situation.

My 4way dimmers were just installed (1 RF9540-NAW master, 2 RF9542-ZAW accessories). Lets make this easy and pretend that I didn’t actually have a Z-Wave controller… I’d assume the dimmer accessories and master would communicate (over the wire?), and all the switches would turn on/off and dim/status together regardless of which dimmer I was manipulating.

When this 4way went live, they all had the “ready to pair” blue light blinking so I associated them with ST, and they all seem to be peers in ST and in physical manipulation. Can I kick them back into independent mode and have them behave properly? Then tell ST about the master only?

For Later:
My though is that once the above that works, I’ll tackle them controlling some Phillips Hue bulbs. I’ve heard that the bulbs need to be always-on, so I’ll associate the “well behaved” Cooper 4way master with a “Smart Lighting” rule to control the Hue bulbs. The next question would be how to have that Cooper dimmer actually dim the Hue bulb, instead of just being an on/off switch.

George, Both of my 9542-Z accessory dimmer level’s end up at the same level as the Master (9540-N) when I follow your 3 step procedure.

1 Like

You have to associate the accessory dimmers with the master before you do anything else. That process is completely independent of the ST Hub. The association process is described in this thread. Once you get that working, then you can add the master dimmer to your home hub network.

Ok, so even though I have the set hard wired for 4-way, I need the Aeon Labs DSA03202 v1 ?
(Then I’d follow the directions above.)

Actually, what is the remote doing?
Is the association only in the remote? Or can the remote’s battery be removed and the switches will still communicate?

Thanks,
-AAron

[quote=“aadhoc229, post:44, topic:10547, full:true”]
Ok, so even though I have the set hard wired for 4-way, I need the Aeon Labs DSA03202 v1 ?
(Then I’d follow the directions above.)[/quote]

The minimote is probably the most cost effective way to perform the associations needed between a Cooper RF master dimmer and the accessory dimmers. Cooper controllers are very expensive. The hard wires you connected only provide a pathway for 110V current to get to your light fixture(s). Association is a z-wave (wireless) function that must be established in order for the dimmers to all work together. Check out the “What is Association” portion of the Cooper ASPIRE RF Frequently Asked Questions (FAQs)

[quote=“aadhoc229, post:44, topic:10547, full:true”]Actually, what is the remote doing?
Is the association only in the remote? Or can the remote’s battery be removed and the switches will still communicate?[/quote]
The remote acts as a controller to establish the dimmer associations. Once the dimmers all know about each other the remote is no longer needed. You can’t remove the minimote battery as far as I know. It is rechargeable via the USB port. I re-purposed mine to control other devices on my Smart Home HUB.

Step 1) Got dimmers associated
I’ve used a minimote to associate the 3 switches of my “4way wiring”.
All 3 dimmers are talking and updating each other regardless of which switch I toggle or dim.
I did notice the minimote lets you associate one-to-several to save some steps. For example:

  1. Enter association mode, toggle Master, toggle Acc1, toggle Acc2, exit association mode.
  2. Enter association mode, toggle Acc1, toggle Master, toggle Acc2, exit association mode.
  3. Enter association mode, toggle Acc2, toggle Acc1, toggle Master, exit association mode.

Step 2) For Later (use in ST)
I’m working through this so I have a helpful post or a concise question.

Thanks the help!

The dimmers and the ST app don’t seem to work well together.
In fact the ST App ignores the associations.

NOTE: I started over for clarity. With all 3 dimmers NOT added or associated and in pairing mode (top light blinking), I did the following:


With the minimote…

  1. Added all three to Z-wave network
  2. Created the 6 associations (each with its other two siblings)
  3. Verified all associations work by manually pushing switches.

With ST app…

  1. Went to add the dimmers, saw 3 were not configured
  2. In “Not Yet Configured / Select Dimmer Switch”, I used the on/off buttons for the dimmers…
    2a. Turning an accessory dimmer on/off via the ST app merely turns that ONE dimmer on/off. Associated dimmers did nothing. (So this puts it out of sync with the master.)
    2b. Turning master dimmer on/off via the ST app turned on that ONE dimmer (and the light it was wired to). Associated dimmers did nothing. (So this puts it out of sync with the accessories.)
    2c. Turning a master or accessory dimmers on/off manually generally did not affect the on/off status in ST app. A few times it showed ON when the dimmer was off.

NOTE: I haven’t even configured these dimmers in ST app yet.

Let me know what else to try,
Thanks

I’ll add more later specific to the Cooper’s, but meanwhile, just one quick note:

Never have a dimmer, smart or not, directly control the current to a smart bulb like Phillips hue. The two devices will confuse each other and you are likely to either burn out the switch or reduce the life of the bulb. The best bulbs to use with the Coopers are dimmable dumb LEDs.

If you have a Smart dimmer. which is not directly controlling the current draw to the bulb, such as the battery operated Cooper 9500 or a dimmer on another circuit, then you can have the bulb follow the switch wirelessly by passing messages through the hub.

Smart bulbs are intended to always be on full power and then they themselves will control the current draw. You can find this information in the user manuals for the bulbs.

It may be helpful to understand what zwave association is.

Z wave association is a method included in the standard zwave protocol which is intended to allow two devices which are in the same room to talk to each other without having to talk to the hub at all.

Its purpose is really to reduce lag as much as possible for a motion sensor triggering a light switch or in some cases an auxiliary switch triggering a master switch. when both are a long way from the hub, such as in an attic room.

So it’s understandable that smartthings ignores it – – by definition, the devices will not notify the hub about anything that they have done.

You shouldn’t need association between an auxiliary switch with zwave capability and a master switch with zwave capability when you are using SmartThings. Instead, you will have both talk to the hub and the Hub will pass the messages between them.

You can use smartlighting to have one switch follow the other, or even have each follow the other, very easily.

So while you can use zwave association if you choose to, it will almost always result in synchronization issues with the hub because the hub is left out of the message communication.

Also note that if you use the hub as the middleman, the devices don’t have to be within the same room and they don’t have to even use the same protocol. You could have a Z wave switch in the living room control zigbee bulbs on the far side of the house if you want to. Or a WeMo switch up two floors.

So while zwave association is useful in a few specific situations, most people using SmartThings will use hub communications instead. It’s more flexible, it lets you include anything that the hub can talk to, and it lets you cover a much wider area.

The instruction manuals for most Zwave devices, of course, don’t have any understanding of how a multiprotocol platform like smartthings works. They’re assuming you’re using a simple Z wave only controller. So their instructions will include associations that really are not necessary when you are using SmartThings as the network controller. :sunglasses: :bulb: :level_slider: :bulb:

1 Like

If you just want on/off from the auxiliaries, don’t use association at all. Instead, use smart lighting as described in post above:

you will find the detailed instructions in the community-created wikiHow to article on how to group lights. You just have to add each of the three switches to your smartthings network, and then follow the instructions:

http://thingsthataresmart.wiki/index.php?title=How_to_Group_Lights_Together

If you also want them to dim together, you certainly can. Unfortunately, smartthings does not provide this in the built in features, so you would have to use custom code like “dim with me” or “dim and dimmer.”

I know @Lgkahn has a custom device handler, I’m not sure if he also has a custom smart app to do the dimming.

I know this probably seems like there’s been a lot of discussion on features that just end up being confusing… Different people have different use cases, and some people do want to specifically use association. But it’s actually easier without it.

That’s great information, and I think the thread topic has been nailed with the how-to’s and the deeper explanation you just posted.

I am now moving on to “phase 2” and want to do what you suggest by configuring these switches to wireless control my always-on Hue bulbs. I assume we should take that conversation to a thread about “Cooper Aspire + Hue” where we can play with the concepts for association vs ST configuration? Do you know of a specific topic thread for this, or shall I start a new one?

1 Like