Controlling Shelly UNI with Aqara Temperature sensors?

I just installed two Shelly UNI to my heating central.
And I need to buy some temperature sensors to control the UNI’s

I wonder if it’s possible to do this with a Aeotec Smart Home Hub (SmartThings compatible), and Aqara’s temperature sensors (ZigBee).

Can I get the reading from Aqara’s temperature sensors and set up a rule to turn off and on the Shelly UNI relay based on temperature readings?

Can I then control this via the app? Change temperature thresholds?

Hi @Legostar

With this edge driver, which supports the Aqara lumi.Weather model and other models from more manufacturers, you can control any switch with routines and control your heating.

You can also create a virtual thermostat with all the functions of a real thermostat to control more comfortably and more accurately.

I used it all last winter with a Sonoff TH01 temperature sensor and a zigbee switch and it worked great and running local.

In the first post of this thread is the complete description of the functions of the thermostat.

1 Like

Thanks for the answer, I will buy the hub and the temperature sensors tomorrow and try to set it up.

What I don’t know is the Shelly UNI relay is compatible with the aeotec V3 hub.

I use a zigbee switch and a zigbee temperature sensor

Have you tried your Shelly Uni with @TAustin Edge Driver for Shelly?

The Uni is listed, but I don’t know if it is fully functional.

1 Like

@Legostar I haven’t implemented the Uni yet, as no one has asked for it. But I’m certainly open to adding it if you are willing to test it for me :slight_smile:

1 Like

Hi, Thanks,
I’m a newbie to SmartThings just bought the Hub.
Got a Samsung v3 cheap, instead of the Aeotec one.
I also bought the Aqara temperature & moisture sensors and installed the Edge driver above and also tried some other drivers for the Aqara sensors.
Really nice driver with thermostat and easy to set up the rules to switch state in the UNI.

But I can’t get the sensors to fully work, they work for an hour and then they stop the updates.
If I warm them in my hand they work for a while again.
I tried to change ZigBee channel, without result. So don’t think it’s interference problems.

Regarding the Shelly UNI, I used the “Link account” that you get when choosing Shelly as vendor, when adding devices.
It work’s flawlessly, but not sure if this way is removed when they remove the cloud/groovy?

Thanks for the help

The Shelly integration is part of the new platform and should continue working after the Groovy shutdown.


Hi @Legostar

To use the sensor as a thermostat you have to configure the reports with the maximum precision: 5 minutes of maximum interval and 0.1°c of reportable change.

Go into settings and check that they are like this.

Even if you see that they are like this, try to re-enter the values.

The preferences infochange routine, which sends the configuration, is only called if the value has changed. I explain:

  • If it already puts 0.1, it changes to 0.2 and saves.
  • rewrite 0.1 and save.

If the sensor is not close to the hub, move it closer. Some times configue device can failure.

In the history of the device you will only see temperature values when change at least 0.1°c, you will not see repeated values, although the device sends them and the driver processes them

With CLI and a PC you can see the logs of driver and device messages

Thanks, I think I already tried to change the values in the settings.
But I will try again, to be sure.

I also thought I would not see new values if the temperature were constant, that’s why I warmed them in my hand to start with. So, I thought that was the case when they started to work again.
But then I tried to turn the radiator on and off manually during periods, without getting new values.
Unless I put the sensor really close to the radiator, it only seems to work if the temperature is increasing and decreasing rapidly. Then it sends out changes every minute.

I have only tried in one room so far, so I have no mesh and working close to the hub. Also tried to put the sensor as close as 30 cm (12 inches) to the hub without result.
Going to buy some IKEA Trådfri sockets to use as repeaters today, to see if it solves the problem.
I already have some Philips Hue and IKEA lamps, but I have not joined them in the hub. And I have unpowered them while testing. Don’t rely on them as they are quite old.

I also removed the sensors and rejoined them again in the hub, then they work for a while again, but same behavior after a while.

I’m on Wi-Fi channel 13, and ZigBee channel 20 right now.
Neighbors is not using Wi-Fi 1,6,11 as usual. most of the close ones are on channel 3.

Regarding the thermostat function in the driver, I would like to see a thermostat were you pulse the radiator in intervals. like 15 minutes on and 20 minutes off and repeat.
And if it gets to hot or cold it automatically changes the interval, so you set the interval in percentages.
Want to control this with both temperatures reading outdoor and the room temperature.
Then if you miss one reading it will not be as serious if the loop/interval is working and you get a more even heating.
Think maybe the Fan circulate mode works a bit like this, but don’t know how to configure it, guess it’s just for cooling?

I can help programming such feature when I got the current solution working.
I work as a programmer (C++, C# .NET, Java, JavaScript) and would be easy to learn Lua by checking your code.

Thanks, again.

I think I got one of the sensors to work now, out of the two I’m testing with.
But it updates only when temperature have changed 0.5 degrees. Celsius.

And have a theory that when it updated with smaller interval in Celsius change, it was the humidity that triggered the send. I did not look closely at those values as I’m only interested in temperature at this moment.

I tried to change the “Temperature Reportable Change” in the settings, but still only sends data at 0.5 degrees Celsius.

Maybe this is a limitation with Aqara sensors, or the settings is not working for them.

The other sensor though the app says is offline, last reading 07:04am it’s 11:30am now.
The sensors have been 30cm (12 inches) apart from each other.

It could be, I don’t know.
I use a sonoff ZNZB-02 and they work great
The smartthings (samjin, now aeotec, they all configure temp very well)

In zigbee devices, the reports are configured in the following way:

  • Temperature reportable change: Temperature increase that is always reported, regardless of the configured minimum and maximum intervals
  • Minimum interval: No report will be issued until the interval or reportable change is met.
  • Maximum interval: a report of any temperature change less than the reportable change will be sent when the maximum interval is met.

The default configuration is:
minimum: 30 sec
maximum: 300 sec
reportable change: 0.1°c

If you want to check if the sensor really works well you have to let it stabilize and observe the readings in the history.

  • If the temperature increases are >= reportable change: The history readings do not have to coincide with the maximum interval.

  • If temperature increases < reportable change: The readings correspond to the maximum intervals or maximum interval multiples.
    With a reportable change of 0.1°C there could be repeated events since the sensor sends readings with 2 decimal places and the app rounds it to 1 decimal place.

The thermostat works with precision of 2 decimal places sent by the device and displayed in infoPanel.

Place the sensor about 1.5m from the ground and in an area not exposed to sudden changes in temperature, air currents, heat emitters.

If your heating system has little thermal inertia, it is due to hot air, select an On-Off differential in low preferences (<= 0.5°c).

to adjust this parameter see this paragraph.


You can install CLI in a PC to monitor the device and driver logs

Edge Driver or Device Handeler for a TUYA (Zemismart) Zigbee plug with energy mesurment capabilities - #18 by Mariano_Colmenarejo

The one I think’s working better.

11:58 Start value
Outside temperature 14.0C read with Telldus sensor, radiator currently off set to start at <20C turn off at >23C using this sensor.
Telldus sensor same room: 20.7C, 58%
11:58 Pick it up in hand
12:35 Telldus Outside: 14.2C
13:22 Turn Radiator on manually
13.22 Telldus 20.9C, 58% Outside: 14.2C

Time Component Capability Attribute Value
10/15/2022, 15:22:58 main temperatureMeasurement temperature 23.2 °C
10/15/2022, 15:01:53 main relativeHumidityMeasurement humidity 53 %
10/15/2022, 15:01:53 main temperatureMeasurement temperature 22.7 °C
10/15/2022, 14:40:37 main temperatureMeasurement temperature 22.2 °C
10/15/2022, 14:36:16 main temperatureMeasurement temperature 22.1 °C
10/15/2022, 14:16:21 main relativeHumidityMeasurement humidity 54 %
10/15/2022, 14:16:21 main temperatureMeasurement temperature 21.6 °C
10/15/2022, 13:57:55 main temperatureMeasurement temperature 21.1 °C
10/15/2022, 13:08:53 main temperatureMeasurement temperature 20.5 °C
10/15/2022, 12:56:50 main relativeHumidityMeasurement humidity 55 %
10/15/2022, 12:56:50 main temperatureMeasurement temperature 20.6 °C
10/15/2022, 12:18:00 main relativeHumidityMeasurement humidity 53 %
10/15/2022, 12:17:59 main temperatureMeasurement temperature 21.1 °C
10/15/2022, 12:11:07 main relativeHumidityMeasurement humidity 52 %
10/15/2022, 12:11:07 main temperatureMeasurement temperature 21.6 °C
10/15/2022, 12:07:36 main relativeHumidityMeasurement humidity 51 %
10/15/2022, 12:07:36 main temperatureMeasurement temperature 22.1 °C
10/15/2022, 12:05:16 main relativeHumidityMeasurement humidity 50 %
10/15/2022, 12:05:16 main temperatureMeasurement temperature 22.7 °C
10/15/2022, 12:03:35 main relativeHumidityMeasurement humidity 49 %
10/15/2022, 12:03:35 main temperatureMeasurement temperature 23.2 °C
10/15/2022, 12:02:25 main temperatureMeasurement temperature 23.7 °C
10/15/2022, 12:01:24 main relativeHumidityMeasurement humidity 48 %
10/15/2022, 12:01:24 main temperatureMeasurement temperature 24.3 °C
10/15/2022, 12:00:44 main relativeHumidityMeasurement humidity 47 %
10/15/2022, 12:00:44 main temperatureMeasurement temperature 24.8 °C
10/15/2022, 11:59:33 main relativeHumidityMeasurement humidity 52 %
10/15/2022, 11:59:33 main temperatureMeasurement temperature 25.3 °C
10/15/2022, 11:59:23 main relativeHumidityMeasurement humidity 63 %
10/15/2022, 11:59:23 main temperatureMeasurement temperature 24.9 °C
10/15/2022, 11:59:13 main temperatureMeasurement temperature 24.2 °C
10/15/2022, 11:59:02 main relativeHumidityMeasurement humidity 83 %
10/15/2022, 11:59:02 main temperatureMeasurement temperature 23.1 °C
10/15/2022, 11:58:52 main relativeHumidityMeasurement humidity 81 %
10/15/2022, 11:58:52 main temperatureMeasurement temperature 22 °C
10/15/2022, 11:58:42 main relativeHumidityMeasurement humidity 70 %
10/15/2022, 11:58:42 main temperatureMeasurement temperature 21.1 °C
10/15/2022, 09:51:00 main relativeHumidityMeasurement humidity 55 %
10/15/2022, 09:51:00 main temperatureMeasurement temperature 20.7 °C
10/15/2022, 08:24:08 main legendabsolute60149.atmosPressure atmosPressure 1002 mBar

Thanks, I try to install CLI for better loggings, CLI log above

Going to buy the Sonoff SNZB-02 to see if they perform better, but need to buy them online since no one is selling them locally.


I’ve found this information for a Homey Aqara driver.

You need to send the configuration settings while the sensor is awake, so that’s maybe why I can’t update the settings to send 0.1C temperature change.

I will try to update the settings within 30sec of paring as they suggest and see if that helps.
Maybe it would also be possible to do this with a change in driver code - to send the config settings, just after a confirmed read of the sensor.

The configuration is sent to device in the pairing, which is awake. In this first configure send de values selected in preferences.
That’s why I told you to try to pair it as close as possible to the hub, to ensure that the binding and configuration message arrives correctly.

Indeed, there are devices that support configuration changes better than others.

I found out that it’s not possible to configure the Aqara sensors, they only send out updates on 0.5C or 6% humidity changes. Should also send out one message every hour even if no change, but that seems to not be correct, because I don’t get any update for several hours sometimes. And read on other forums that’s what they experience as well, the older model send out a bit more often.

I bought the Sonoff SNZB-02 instead, and they work perfectly and is possible to send config to.
So happy with Sonoff SNZB-02.

1 Like