SmartThings Community

Connection to Domoticz defined devices like Blinds and On/Off switches

somfy
x10
rgbw
project_shades
(Toby Field) #745

Thank you for the quick reply. I just updated the app as well as the server software. Hopefully this will help with the “not responding” messages. My Domoticz implementation is really just to help me create a link between SmartThings and my two YeeLight strips - a little over kill I guess but a fun experiment.

Cheers

Toby

1 Like

(Richard Blackman) #746

Wow this thread has become popular, great to see that you are keeping up with this project, thanks for all your efforts. Unfortunately I am having the same issue as a previous member in that it is disconnecting/reconnecting constantly. Sending me alerts 40-50 times a day, my phone is going nuts.
My Domoticz server only has 6 contact switches and 1 relay left in its control, everything else is now in ST. I was hoping to keep this going for a while longer to spread out the cost of new sensors but if there’s no way around this issue I guess I’ll have to just go ahead and do it. At the moment I wouldn’t mind if it bounced all day if only I could stop these alerts, is there an option I’m missing?

0 Likes

(Martin Verbeek) #747

Can you check if you have the latest version installed? Made some changes that should help.

Verzonden vanaf Samsung-tablet.

-------- Oorspronkelijk bericht --------

0 Likes

(Richard Blackman) #748

Yes I do, I just updated it last week to see if it would fix it.

0 Likes

(Martin Verbeek) #749

Thanks Richard, will add an option to disable checking…

met vriendelijke groeten,

Martin

0 Likes

(Bartosz Kubek) #750

Hi.
For me, I cannot get the Temp sensors from Domoticz to send notifications to ST. In “Live Logging” in ST IDE Dash I cannot see any “SENSOR” logs.

In Domotocz Settings->Notifications, I have set notification interval to 1m.
Other Domoticz devices like Smart plugs, are correctly transfering on/off signals to ST devices instantly.

Please help me figure it out. Trying to solve this puzzle entire day.

Best,
Bartosz

0 Likes

(Martin Verbeek) #752

V7.27 kills the push notifications

0 Likes

(Martin Verbeek) #753

Hi Bartosz is this new or did this surface recently?
And does the domoticz device has notifications set?

0 Likes

(Richard Blackman) #754

Thanks, I just updated my system.

0 Likes

(Bartosz Kubek) #755

Thank You for fast replay.

Here, notifications panel for this device.

For few months I got it running correctly for Switches (ZigBee xiaomi wall plugs->Xiaomi Gateway->Domoticz->SmartThings).

This time I decided for first time to add thermometer. The xiaomi one. I have no other thermometer.

In Domoticz, this thermometer reports temps correctly:

Those xiaomi wall plugs, also are power meters (Sensors) and those seams to send notifications. Log dump from now:

Finally, this Domoticz runs in a docker container, on my Synology NAS. If this changes anything.

Do You see anything is missing here?

0 Likes

(Martin Verbeek) #756

Will check it out, had an earlier report on temperature problem.

Verzonden vanaf Samsung-tablet.

-------- Oorspronkelijk bericht --------

0 Likes

(Martin Verbeek) #757

do you see any Notification messages in the Domoticz log for SENSOR 72 Temp xx??

0 Likes

(Bartosz Kubek) #758

In fact, I do.

2019-03-01 13:50:23.731 Status: Notification: SENSOR 72 Temp 23.7

I cannot see if there was more of this more in the morning, because I am not logging into file, and the Dashboard log is short. I will start logging into file today, and let You know after the weekend.

My setting looks this way though:
image
For sure I see no SENSOR 72 reports every minute.

What gets me completely confused, is that this device in STApp (android) is now showing in “Recently” tab many updates, but not the one at 13:50 (as above in the log):

.
Question then: does the STApp shows only changes where value does change? So as temp was still 23,7 starting from 11:57 (screenshot above), new reports does not apply to this “Recently” list?

0 Likes

(Martin Verbeek) #759

I will not show in the dashboard if it does not change (normally). You will however see the events in the ide for the device…

met vriendelijke groeten,

Martin

0 Likes

(Bartosz Kubek) #760

Good morning!

Ok, so I enabled Domoticz file log, and here is result:

ash-4.3# cat /volume1/docker/Domoticz/config/domoticz.log | grep “SENSOR 72”
2019-03-02 16:48:25.031 Status: Notification: SENSOR 72 Temp 23.0
2019-03-02 17:13:01.156 Status: Notification: SENSOR 72 Temp 23.3
2019-03-02 18:07:01.975 Status: Notification: SENSOR 72 Temp 23.3
2019-03-02 19:05:44.117 Status: Notification: SENSOR 72 Temp 23.2
2019-03-02 20:03:16.023 Status: Notification: SENSOR 72 Temp 23.2
2019-03-02 20:54:51.160 Status: Notification: SENSOR 72 Temp 23.2
2019-03-02 21:53:23.366 Status: Notification: SENSOR 72 Temp 23.3
2019-03-02 22:11:54.229 Status: Notification: SENSOR 72 Temp 23.4
2019-03-02 22:45:59.039 Status: Notification: SENSOR 72 Temp 23.4
2019-03-02 23:43:15.736 Status: Notification: SENSOR 72 Temp 23.4
2019-03-03 00:36:51.441 Status: Notification: SENSOR 72 Temp 23.4
2019-03-03 01:35:13.628 Status: Notification: SENSOR 72 Temp 23.4
2019-03-03 02:29:04.420 Status: Notification: SENSOR 72 Temp 23.5
2019-03-03 03:21:34.572 Status: Notification: SENSOR 72 Temp 23.5
2019-03-03 04:15:15.328 Status: Notification: SENSOR 72 Temp 23.5
2019-03-03 05:10:11.353 Status: Notification: SENSOR 72 Temp 23.5
2019-03-03 06:01:01.179 Status: Notification: SENSOR 72 Temp 23.5
2019-03-03 07:00:28.495 Status: Notification: SENSOR 72 Temp 23.4
2019-03-03 07:57:50.171 Status: Notification: SENSOR 72 Temp 23.4
2019-03-03 08:50:50.917 Status: Notification: SENSOR 72 Temp 23.4
2019-03-03 09:44:36.687 Status: Notification: SENSOR 72 Temp 23.3
2019-03-03 10:35:01.473 Status: Notification: SENSOR 72 Temp 23.3
2019-03-03 11:34:38.955 Status: Notification: SENSOR 72 Temp 23.4
2019-03-03 12:25:48.843 Status: Notification: SENSOR 72 Temp 23.4
2019-03-03 13:17:03.968 Status: Notification: SENSOR 72 Temp 23.3
2019-03-03 14:17:16.524 Status: Notification: SENSOR 72 Temp 23.3
2019-03-03 15:13:12.924 Status: Notification: SENSOR 72 Temp 23.2
2019-03-03 16:06:58.694 Status: Notification: SENSOR 72 Temp 23.2
2019-03-03 17:02:24.897 Status: Notification: SENSOR 72 Temp 23.2
2019-03-03 17:58:51.518 Status: Notification: SENSOR 72 Temp 23.3
2019-03-03 18:53:22.479 Status: Notification: SENSOR 72 Temp 23.4
2019-03-03 19:49:39.021 Status: Notification: SENSOR 72 Temp 23.4
2019-03-03 20:43:44.933 Status: Notification: SENSOR 72 Temp 23.3
2019-03-03 21:35:09.977 Status: Notification: SENSOR 72 Temp 23.3
2019-03-03 22:28:30.636 Status: Notification: SENSOR 72 Temp 23.3
2019-03-03 23:27:48.070 Status: Notification: SENSOR 72 Temp 23.2
2019-03-04 00:27:25.535 Status: Notification: SENSOR 72 Temp 23.3
2019-03-04 01:23:17.003 Status: Notification: SENSOR 72 Temp 23.3
2019-03-04 02:19:23.346 Status: Notification: SENSOR 72 Temp 23.2
2019-03-04 03:17:15.238 Status: Notification: SENSOR 72 Temp 23.3
2019-03-04 04:11:01.002 Status: Notification: SENSOR 72 Temp 23.2
2019-03-04 05:04:11.675 Status: Notification: SENSOR 72 Temp 23.3
2019-03-04 06:03:44.233 Status: Notification: SENSOR 72 Temp 23.3
2019-03-04 07:01:41.243 Status: Notification: SENSOR 72 Temp 23.3

As You can see, a notification comes ~once per hour. I would expect it to come once per minute.

If I go in Domoticz dashboard: Temperature[tab]->Base Floor Temp & Humidity[device]->Log[button on device] I can see that Xiaomi Temp sensor is sending readings like once per 5 minutes:

DateTime Humidity Temperature
|2019-03-04 05:55:00|40|23.3|
|2019-03-04 06:00:00|40|23.3|
|2019-03-04 06:05:00|40|23.3|
|2019-03-04 06:10:00|40|23.3|
|2019-03-04 06:15:00|40|23.3|
|2019-03-04 06:20:00|40|23.3|
|2019-03-04 06:25:00|40|23.3|
|2019-03-04 06:30:00|40|23.3|
|2019-03-04 06:35:00|40|23.3|
|2019-03-04 06:40:00|40|23.3|
|2019-03-04 06:45:00|40|23.3|
|2019-03-04 06:50:00|40|23.3|
|2019-03-04 06:55:00|40|23.3|
|2019-03-04 07:00:00|40|23.3|
|2019-03-04 07:05:00|40|23.3|
|2019-03-04 07:10:00|40|23.3|
|2019-03-04 07:15:00|40|23.3|
|2019-03-04 07:20:00|40|23.3|
|2019-03-04 07:25:00|40|23.3|
|2019-03-04 07:30:00|40|23.3|
|2019-03-04 07:35:00|40|23.3|
|2019-03-04 07:40:00|40|23.3|
|2019-03-04 07:45:00|40|23.3|
|2019-03-04 07:50:00|40|23.3|
|2019-03-04 07:55:00|40|23.3|

Conclusion: It’s good, but not perfect.
I cannot get Notifications for a sensor to be sent more often then 1/hour.

0 Likes

(Arnoud) #761

I hadn’t updated my installation for ages, but since I recently got a Smart Meter at home (still waiting on the cable to connect to it to be delivered) I decided to get everything updated again.

I don’t know what I did wrong exactly, but after a bit of playing I had three Domoticz Server smartapps installed that all refused to be removed. After a lot of trying I found that the Alexa smartapp was somehow blocking deletion. Uninstalling that allowed me to delete all Domoticz Server smartapps and start from scratch.

The main reason why I am posting here is that it looks like the issue that was present in 2016 with my Somfy blinds reappeared in the current build: I cannot stop my blinds from moving. I think I had the same issue before:

I have enabled “Stop command supported?” in the settings, but that didn’t help.

I can’t remember if I manually edited the groovy source in the past to get this working, but I can tell that with the default source it does not work.

So now when the blinds are moving, I can only revert the direction, but they won’t stop with the Preset button. Pressing the preset button while the blind is open does nothing (on the remote it moves to the preset position if I press it). Using the slider in the smartapp will move the blind to the preset position no matter what position I put the slider in.

I will do some more digging, but at least it is not working out of the box.

0 Likes

(Martin Verbeek) #762

If it is a Somfy, disable stop supported setting. It should detect it is a Somfy. I have the same old remote and works.

Verzonden vanaf Samsung-tablet.

-------- Oorspronkelijk bericht --------

0 Likes

(Arnoud) #763

I have disabled the ‘stop support’ setting, but that hasn’t helped. Previously the middle icon was called ‘Stop’ but it could be that I manually edited that in the source last time.

Should those weather icons be on the bottom of the screen? This is just a simple Somfy motor, nothing fancy without weather options.

0 Likes

(Martin Verbeek) #764

Could you paste the devices variable from the app settings in the idea? Just want to check if the detection is being done correctly. The weather things should only be added when you have the smartscreens app, this app will add those tiles. Or you have an old devide handler. From what GitHub are you getting the updates? I have changed the repo a while back…

Verzonden vanaf Samsung-tablet.

-------- Oorspronkelijk bericht --------

0 Likes

(Arnoud) #765

I deleted all device handlers and pulled the device handlers from this one yesterday:

That was the one that was on the wiki page. And those seemed to have been updated recently.

I am not sure what you mean by “device variables from the app settings in the IDE”, so here is what I think you mean:

Or possibly, did you mean this one:

{10000={deviceType=domoticzPowerReport, dni=7ea37bdc-db8e-45c3-bfa3-f5c683c48416:Power Reporting Device:10000, idx=10000, idxPower=167, name=Power Reporting Device, subType=Energy, switchTypeVal=0, type=Sensor}, 10001={deviceType=domoticzPowerReport, dni=7ea37bdc-db8e-45c3-bfa3-f5c683c48416:Gas Reporting Device:10001, idx=10001, name=Gas Reporting Device, subType=Gas, switchTypeVal=0, type=Sensor}, 109={deviceId=0001, deviceType=domoticzSensor, dni=7ea37bdc-db8e-45c3-bfa3-f5c683c48416:IDX:109, idx=109, ip=192.168.99.155, name=Weather - Veldhoven, port=8080, subType=Temp + Humidity + Baro, switchTypeVal=, type=sensor}, 128={deviceId=060666, deviceType=domoticzBlinds, dni=7ea37bdc-db8e-45c3-bfa3-f5c683c48416:IDX:128, idx=128, ip=192.168.99.155, name=Rolluik Werkkamer, port=8080, subType=RFY, switchTypeVal=3, type=switch}, 129={deviceId=060666, deviceType=domoticzBlinds, dni=7ea37bdc-db8e-45c3-bfa3-f5c683c48416:IDX:129, idx=129, ip=192.168.99.155, name=Rolluik Slaapkamer, port=8080, subType=RFY, switchTypeVal=3, type=switch}, 130={deviceId=060666, deviceType=domoticzBlinds, dni=7ea37bdc-db8e-45c3-bfa3-f5c683c48416:IDX:130, idx=130, ip=192.168.99.155, name=Zonneluifel, port=8080, subType=RFY, switchTypeVal=3, type=switch}, 131={deviceId=060666, deviceType=domoticzBlinds, dni=7ea37bdc-db8e-45c3-bfa3-f5c683c48416:IDX:131, idx=131, ip=192.168.99.155, name=Rolluik Woonkamer, port=8080, subType=RFY, switchTypeVal=3, type=switch}, 4={deviceId=0001, deviceType=domoticzSensor, dni=7ea37bdc-db8e-45c3-bfa3-f5c683c48416:IDX:4, idx=4, ip=192.168.99.155, name=Internal Temperature, port=8080, subType=Temp, switchTypeVal=, type=sensor}}

0 Likes