SmartThings Community

Connection to Domoticz defined devices like Blinds and On/Off switches

somfy
x10
rgbw
project_shades

(Martin Verbeek) #725

will try, could you tell me what the XX´s stand for so i can insert the correct names?


(Dick) #726

Power:
In the screen shot for the power, I don’t know what the 1660.0 kWh is, but if it is my power concumption for that day I need a private energy generator :joy: .
Maybe an add-up of 851948+807884? If so, then it is wrongly rounded to 1660.0 kWh and should be 1,659.8 kWh (or 1,660 kWh). But what is the use of such summation of the readouts? Suggestion is to present the consumption of that day: 7.515 kWh (no decimal, that will be always 0).

This what I think what the values mean:
“Total:851948;807884;0;0;488;0 Today:7.515 kWh”

Meter reading consumption low tariff: 851.948 kWh
Meter reading consumption high tariff: 807.884 kWh
Meter reading production low tariff: 0.0 kWh
Meter reading production high tariff: 0.0 kWh

Momentary power use: 0.488 kW
Momentary power production: 0.0 kW

Total power consumption today: 7.515 kWh


Gas:
For the gas it is a pitty that there is no momentary gas use/consumption (e.g. per time interval chosen in Domoticz for getting the output of P1). But that relates to the P1 meter output which is not presenting this value(s) and should be calculated in Domoticz with the chosen interval.
For the app:
“Total:793.809 Today:8.558 m3”

Meter reading gas: 793.809 m3
Total gas consumption today: 8.558 m3

I think this will do.

Regards, Dick


(Martin Verbeek) #727

yes, found that for the P1 meter in the meantime on the dz forum :slight_smile:

1660 is indeed what is coming from counter field in the device and is total. Momentary is on the device shown already as current, so i will try and get the low/high in with a description.

for gas, i could subtract current from incoming event and make sort of a momentary, would that help?


(Dick) #728

o, yes, if possible, smart idea!


(Alex) #729

Hi everyone and thanks for the work that you guys are putting all together, amazing!
I am getting my head around the Domoticz but can’t succeed, and I am sure I am missing probably something really stupid…

I have created my SmartApp from the 2000+ rows code on github.
I also have copied many of the DeviceHandlers too, in all the trials I made.

I have a Raspberry Pi 3 running Domoticz with a RfxTrx433E, reading 4 Oregon Scientific Temperature/Humidity sensors.
All seems ok from that end. I have also added the 4 independent rooms to that, on the various trials I made before getting here

I have added on the “Settings / Local Network” all the IP ranges to be whitelisted 192.168.10.;127.0.0.;10.0.0.*
Also tried to check that each device is configured to share changes when > 0 on the notification section.

The SmartApp has been added, all devices to be discovered etc.
But the device list is always empty, I can’t get how to add my devices.
The app shows like this

but the list of devices shows only a power meter (?)

I also get some disconnection notifications

I have checked on the IDE and live logged the process, but no error was generated.

If I look at the app status from “My Locations”
This is how the configuration looks from there

In there it actually shows the 4 devices in the “Options”

I can’t understand what I am missing :frowning:
Any idea guys?

Thanks in advance to anyone that can help!!!


(Martin Verbeek) #730

I have been fiddling around with that list option in the app, to make it more attractive. It looks like the devices have been created okay. So it should not have an effect on normal operations.

Could you do a list devices in the app with logging running to see if any error occurs.

Will check out later tonight.

met vriendelijke groeten,

Martin


(Alex) #731

Thanks!
I have run a log and opened the device list.
This is what is recorded (I hope it helps).

Let me know also if you have any tip on the reason for the disconnections :stuck_out_tongue:
Thanks again, much appreciated!!!

Alex


(Martin Verbeek) #732

Okay. I see what is going on. Only sensors :grin:. Will have to see what is the impact. Will be back.

met vriendelijke groeten,

Martin


(Alex) #733

By the way, I was curious and had a Zwave switch (the plug one). I have added that to Domoticz and it works fine there. But the SmartThings app is not adding that either. Just thought it might help adding this :slight_smile:


(Martin Verbeek) #734

I can take a few minutes before devices appear… It is not done immediately in the app, it is a scheduled routine that runs continuously every few minutes. Be sure that all device type handlers are present.

Keep your logging running for a while to check for errors that may have to do with this…

P.S.just looked a bit better and no devices are added to state.devices, which means you must encounter some errors during the add of the devices. Could you paste a piece of the log that contains the errors?


(Alex) #735

Hi! so, the zwave switch turned out to be a devicehandler missing. I installed it and the “list installed devices” populated with the switch. But no sensors.
I re-added the app and saw these errors

Then after a while these warnings

Thanks!!!


(Alex) #736

Another update :slight_smile:

I have installed the previous version of the SmartApp and it works fine. The sensors are all appearing and added to SmartThings.
It must be something to do with the latest version… If it helps.

Everything works now, except that sporadic “Domoticz server not responding” and “responding again” message eheheh


(Rob) #737

@ dudz40 Hi Martin, I need your help again. I have added some temperature sensors into Smartthings the virtual counterparts have been created in Domoticz just fine but unfortunately the always say 0 deg and don’t update ever. I cant see anything in either log. Your help would be much appreciated. Rob.


(Rob) #738

I noticed an update to the smartapp so I updated it and it and the temperatures are now updating in Smartthings.


(Martin Verbeek) #739

That was an easy fix :sleeping:

Verzonden vanaf Samsung-tablet.

-------- Oorspronkelijk bericht --------


(Rob) #740

Is there a way I can increase the rate a which the temperatures are pushed from Smartthings to Domoticz? It appears to be only every couple of hours. This is a comparison of two thermometers in the same room one in Domoticz and the other a virtual with data coming from Smartthings


(Martin Verbeek) #741

Wil check it out Rob


(Toby Field) #742

Hello

Did you ever make any progress on this? I am experiencing the same issue (occurs multiple times per day) but I am really not sure what the issue is. My server running the Domoticz software is not heavily loaded so I don’t think it is a load issue.

Thanks

Toby


(Martin Verbeek) #743

I am passing an update to Domoticz when SmartThings issues a temperature event for the device. I see that all is going well, but there are just not that many temp events, i see them most of the time on rounded temperatures (no decimals). I can match all temp events in SmartThings to updates done in Domoticz. Could you check if this is also true in your setup?


(Martin Verbeek) #744

The domoticz not responding is more of a problem in very lightly loaded environments ;-). With the latest version of the app it should not occur that often