Connecting a Sonos

Hi all,

I can’t for the life of me get my Sonos to connect to my Smartthings! I have a Sonos Connect wired to my router, with a Sonos Play:1 connected to that. I have tried hitting the Bridge button while the smartthings searches and everything. I have waited (well over) the recommended 5 minutes… I’ve done EVERYTHING I can think of! How are you guys getting your Sonos connected as a thing?! I’ve spent all day searching the internet for a clue on this, but to no avail. Thanks in advance to anyone who can shed some light!

The SmartThings auto-discovery only works with Zigbee or Zwave devices. For LAN and Cloud connected devices, you need to manually install the device type controller and the the specific device preferences. Unfortunately, I don’t have a Sonos, so I’m not sure where the preferred Sonos device code is.

You first need to request Smartthings Labs to be enabled on your account

Once they’ve confirmed it is, you can connect your Sonos through the smartapp.

Yup once you have the Labs you go into labs in the SmartApps section and goto Labs then goto Sonos.

Yea I finally figured it out. I already had labs enabled on my phone. I was under the impression though that Sonos(connect) and Sonos(control) were two different apps and the Sonos was added as a thing. This is not the case. The two apps are meant to be used in conjunction, using the Sonos(connect) app to “connect” and add the Sonos as a Thing. Then the Sonos(control) app essentially does everything else. I kept going straight to the Sonos(control) app because that was what I wanted to do, so I kept clicking “add device” from there.

Thank you anyway!

Thanks @robpfis07! I spent 20 minutes trying the same thing with the Sonos (Control) app. It is definitely not the most intuitive method to pair with Sonos using an app when ever other thing pairs through the Things > Add procedure. SmartThings should consider changing this before they make the Sonos feature GA.