Conbee and smartthings


I’m trying to learn more about my ZigBee network with smartthings, and so I bought a conbee and am trying to join the network as a router, but that isn’t quite working out:

Specifically, what I did:

  • Installed the latest version of deCONZ your web site
  • Made sure the firmware on the stick is current
  • Configured the network in deCONZ as follows:
    • Device Type: Router
    • Unchecked the predefined PAN ID
    • APS Use Ext PAN ID: 0x0000000000000000
    • Unchecked the custom MAC address
    • unchecked the static nwk address
    • unchecked APS acks
    • Channel Mask: Tried with both all channels checked and with just channel 24 (the one smartthings uses)
    • Security Mode: Standard - Network Key from TC
    • TC address: set to the zigbee id of the smartthings hub
    • network key: unchanged since it should get it from TC
    • TC Link Key: Left on default for now
    • NWK Update ID: 3 (actually tried with 2 first, see below)

I tried to join the network like this numerous times (of course only while the network was in pairing mode), and in fact just once, for a few seconds, it joined and seemed to see a neighboring router (a SmartThings Outlet), but then immediately dropped the connection again. Afterwards I also noticed in the network settings, that it really was able to connect once, briefly, as it actually configured the PAN ID to the correct one, and adjusted the NWK Update ID to 3 (I was initially trying with the default of 2), and the channel mask was changed to just 24 (I also believe it got the network key, as I think it looks different, but I’m not 100%). After that this never worked again :frowning: and smartthings never registered this as a “thing” or otherwise.

While trying to figure this out I also tried out the zshark a bit, and was able to intercept lots of traffic (and confirm that it’s really channel 24). (Of course flashing the proper firmware for each application.)

Any ideas what I might be doing wrong?
Also, I don’t have to be right next to the hub, or do i? At zshark seemed happy…