Complete Instructions to install Rule Machine & GitHub into IDE [DEPRECATED]

Lol when I searched for a thread I searched for how to install rule machine & GitHub. It didn’t show a thread so I created one. I should’ve searched for how to install github!

Thanks so much for this… BIG HELP. I was stuck on step #3 and #4 for weeks. Once I got the right page and clicked FORK everything was set.

Thanks again

I like to think I’m not an ignorant person, but I’m definitely not a programmer. I have looked at implementing this app a couple of times but gave up, not because it’s too complex, but I’m not willing to learn all the nomenclature and modules that appear to be assumed many of us know. I know it’s not the “How To’s” job to teach programming to us, but a lot of assumptions are made. I’m going to give this a more earnest shot in the next few days and appreciate this post. Maybe I can get through it now!

You could try Smart Rules right now if you have IOS, I know I will be giving it a whirl just out of curiosity when the Android app is released.

2 Likes

I use Smart Rules and I think it’s pretty terrific actually. Still, I like to see what other apps have to offer and also I like to support as many developers that I can as long as their stuff works.

1 Like

Kevin

Thanks for your valuable input on installing rule machine.
I was able to get to point No. 6 including enabling Git Hub Integration but there was nothing on the screen to"Authorise Application" and thus I couldn’t continue any further. Any thoughts/ideas to assist.

As a seperate but related issue is it possible to install user created apps without using Github? I must say I find Git Hub extremely challenging.

Look forward to your response

Richard

Hi Richard I understand your problem to be you did not get an authorize button to click on correct? I personally only know of one reasons this may happen, it’s because someone clicked on enable GitHub & Authrized it prior to doing step #5. Don’t worry this is ok if it was done, just proceed to step #7 & everything should be fine.

As to another way besides GitHub no unless you manually write your own code. Which can be done if you have a basic knowledge of the language the ST Hub uses (Groovy for the Java Platform). It is very similar to Ruby, Perl, & Python.

1 Like

And if this Isn’t the case then you will need to open up a ticket with ST Support.

1 Like

Would this be under ST Support or GitHub? I guess you are right, ST would the one to request first since it is from their site.

It’s an issue with ST support, as long as you created a GitHub account & folowed the steps above to no avail.

I can’t seem to get past step 6. Every time I select Enable GitHub Integration it brings me to an Enable Source Code Control page, requesting I select the link to add SmartThings as a collaborator. When I do that I get a Page 404 error.

Support from GitHub says it’s b/c I don’t have a SmartThingsPublic respository first, so OK, i create one first. I can then add SmartThings as a collaborator per the Enable Source Code Control page but then I can’t move on from there.

Stuck in river city

Rick

If you don’t have a repository is because yon didn’t fork this page
https://github.com/SmartThingsCommunity/SmartThingsPublic19. This is what creates your personal repository then you can add step 9.

I am selecting Fork in the upper right corner. Is there something right after that on the same page to save the repository b/c selecting Fork doesn’t save it

Rick

And when I now select the link you provided, I get error 404 page not found

Rick

Thanks Kevin

I’ll try that tomorrow evening

Cheers Richard

That’s strange Rick it sounds like you’ve done everything correct the only other thing I can suggest is to open a support ticket with ST.

Well, got a response back from ST and they said they fixed it on their end and to try it again

The documented process got me a bit further but even after forking the page (that sounded a little dirty) still got the error “The Toy4Rick/SmartThingsPublic repository was not found on GitHub” so I when to GitHub.com and manually created the SmartThingsPublic repository then it all worked from there

I’m GTG now
Rick

1 Like

Glad to hear it Rick.

I got this error when adding the Rule Trigger (step 9)
GitHub repository bravenel/Rule Trigger not found

How can I proceed?
Thanks

The developer had withdrawn this app and support. The repository this was stored in no longer exists. If you still have the code you are welcome to continue using rm, but it is no longer distributable.

If you have an ios device the alternative smart rules is there for you.

Members of the community are also working on alternatives.