Changing IDE Shard

Is there any way to change which shard your device is on? I’m West Coast, but I’m on East. I’d like to move to the West shard, shave my cloud execution times down.

Present: graph-na02-useast1.api.smartthings.com

Possible?

I’ve heard you can possibly create an empty Location first. But you cannot migrate your data / configuration.

  • Login to the desired shard.
  • Add Location to My Locations.
  • Try to change the Location of the Hub using the Edit options.
  • Delete your existing wrong shard Location (which will wipe out everything).
  • Add Hub again in the App if necessary… Probably won’t work.

But why bother? The latency difference is certainly under 200ms.

1 Like

Hey @tgauchat!

Im un EU but i have the ST in the NA04 shard, is there a possibility to migrate every device to the new shard? Thanks

No.

There shouldn’t be noticeable difference.

No speed difference? Tks!

No.

There shouldn’t be noticeable difference.

1 Like

Hey tgauchat,

I’m having issues executing actions on a zigbee smart light controller model: HGZB-01A,

the execution location is set to the cloud,

When i perform actions (switching the light off), i get a “network or server error. try again later” error

I get the same error when i try to perform internet speed tests from inside the ST app.

I was wondering if you (or anyone) knows if this maybe related which shard i am on?

Cheers,

By now, there are hundreds of thousands of hubs / customers on every Shard, and I doubt that any one generally performs better or worse than another (in general).

Perhaps if there is a temporary overloading issue, memory leak, software deployment bug, etc., it can be - temporarily - isolated to one Shard; but that’s unlikely to last long, as, well, thousands of customers would concurrently experience and report it.

I see no value to purposefully changing Shards (it would require rebuilding your entire Location).

Perhaps there aren’t many people trying to integrate the same device in the same shard, Smart things maybe isnt widely deployed in Aus.

Perhaps you know another explanation as to why I cant perform speed tests or flick lights on and off the execute on the cloud?

Any helps would be awesome,

Cheers

What Shard are you on? You are probably on an AP (Asia Pacific) Shard, which, I presume has a growing number of customers in South Korea.

you’re right, im on graph-ap02-apnortheast2.

Im leaning more and more towards this shard being the issue. I dont understand why i cant execute any actions via the cloud unless it’s this? Any alternative ideas welcome …

Why do you think it’s the Shard? Have you tested on another Shard? Do you have any reports of other customers on your Shard with issues?

Your Location record exists within a cluster on the Shard. You may have corrupt data or dozens of other isolated or widespread SmartThings Cloud issues.

Call Support and they can check their internal logs.

I only think it’s that because i can perform automation when the device executes locally but anytime i wish to access the server i get the same “Network or server error. try again later”

Im definitely not 100% sure.

Ii have contacted samsung support, after a good two hours of being transferred around they said someone with more access will call me back

open to trying other suggested fixes, im not sure how to change which shard i am using but i would be interested to try and see if that resolves it

I don’t know for sure if this procedure works, but you can try at your own risk:

  1. Use a private / incognito tab.
  2. Navigate in URL bar to the full Shard URL you wish to test (e.g., https://graph-na04-useast2.api.smartthings.com/)
  3. Login with your normal login credentials.
  4. Go to the My Locations tab.
  5. Select: Add Location
  6. Perhaps Add a Virtual Switch or something to this Location.
  7. Using the New App remove your Hub from your current Location and add it to the new Location. All devices associated with the Hub will be messed up. You may want to remove all devices first.
1 Like

Has anyone done this successfully?

My devices are on shard na02. My 2019 Samsung QLED TV works correctly in ST only when added to na04 location. However, I can only expose one location to Alexa. What’s the best way to migrate devices from na02 location to na04 location?

Thanks.

Why not just move your TV to your primary SmartThings Location (by disconnecting and reconnecting it)?

A lot easier to move one TV than a whole bunch of Hub connected devices… No?

I did that. What happens is this: The TV gets added in na02 location and only works with Smartthings Connect app. Smartthings Classic can’t turn it on or off. Alexa discovers the device but commands do nothings. The same process with TV in na04 location works perfectly. Smartthings Classic and Alexa can turn the TV on and off.

Well - don’t expect that to last.

The Shards are supposed to be identical in functionality. So any differences will likely disappear whenever someone in operations finally does some cleanup / synchronization.

I completely agree with you. I’ve had a ticket open with ST for some time to figure out why my 2019 QLED TV advertised to work with Alexa does not. Self discovery found issue related to these shards. ST support has yet to let me know their findings.

I wish this was a service that ST offered… I signed up early, got a shard that’s a long ways from where i live… now there’s a much closer one. Really don’t want to go through the process of deleting everything to start over on a new shard. :frowning: