Change Network Device ID?

I have a GE keypad remote that only supports device IDs up to 32 (0x20). Due partly due experimentation, I’m up to 0x23 on new devices, with a number of gaps in the range. I added a switch I’d like to control with the keypad, but it’s ID is 0x23

I’ve tried editing the device ID in the IDE, but it doesn’t work until I change it back.

Is there any way to do this other than reseting the hub and adding all my devices back?

Thanks in advance

You’ll need to contact support.

I ran into the same problem. Ended up resetting network and rebuilding from bottom up putting devices I need to control with keypads on first. It worked, but is going to be a REAL pain if I ever want to add another keypad-controlable device.

SURE WISH WE COULD GET A ST-enabled controller like the keypad (Yes I know about the minimote, but really want a device with a dedicated ON and OFF not a “push once for on, push twice for off…maybe”