Challenge Proposal: Samsung TV integration via local network


(Daniel Consuegra) #1

Hi guys!

I was thinking… Would any of you devs be willing to create a DH and Smartapp to control a TV (KS8000 in my case) locally via ethernet? :slight_smile:

I know there’s IR and wifi… but I don’t trust wifi anymore… therefore Logitech’s Harmony remotes are out of the question… or are they?

Thoughts? Ideas?


(Dan) #2

Is there a story here? :wink:

I am guessing your TV has both WiFi and an RJ45 Ethernet Port, correct? Most likely, as far as the TV is concerned, these are both equally capable. If there was an Open API to control the TV via the LAN, it should work whether the TV is attached via WiFi or a Cat5 cable.

What TV functions do you want to control? The Logitech Harmony Hub provides the most seamless control while also allowing integration with SmartThings. Unfortunately for you, the Harmony Hub uses WiFi for integration with SmartThings.

So, it begs the question again… Why don’t you trust WiFi? :wink:


(Simon Tether) #3

Don’t know if it affects your TV but I’ve had a recent firmware update (yesterday) to my 2018 qled and 2017 6120 and it seems to have removed access to the tv web API. I have been using eventghost and a plugin to control my TV but it no longer works.
Smartthings has found my TVs and assigned an ocf TV device type. I can control them from both smartthings apps but the classic app has less available.



(www.rboyapps.com - Make your home your butler!) #4

Is this a custom DTH?


(Simon Tether) #5

No just what smartthings uses for my TVs when I added them.

I have looked for the ocf TV device type code but can’t find it

This is the TV in the IDE



(Daniel Consuegra) #6

Yep, basically a few things… For starters let me get my country out of the way, Spain… so there start my troubles I fear…

I’m sorry if this is long but I’ll spit it all out here… After seeing that the Samsung 8 series was compatible back in 2016, I went ahead and bought a KS8000 which at the time fulfilled (on paper at least…) all my needs… double tuner to record a program and view a second one… smart functions so that I could watch Netflix/Youtube/whatever without plugging a computer into the device… AAAAND most importantly, compatible (on paper I repeat) with smartthings…

Out of all the things I asked of it… the tv fulfilled all but one… from day one… the compatibility was nowhere to be found…

The most I found was one day the app found the device and added it… BUT to no avail… it never was able to even turn the tv on… much less change channels or other commands…

So! I contacted the support team several times… and at first they were willing to help… and they did all they could… but the system wouldn’t recognise the TV… afterwards, the original support team changed and ever since then… even though they are friendly and polite… they shielded themselves behind the fact that the TV was Spanish… and therefore not compatible… damn it! Noone told me that when I bought it! I could’ve imported one from the UK!..

Anyways… that brings us to today-ish… As of late I’ve noticed that whenever I use the wifi, except for my phone (Samsung Tab S3), everything seems sluggish and not up to the usability I expected… sooo, I started turning to RJ45 cable all over the home… and the speed went up… so that was solved…

Except for the Harmony remote… the bugger is very flacky to put it softly… sometimes it works… other times it doesn’t… and other times it starts working, but stops doing so in between operations! (turn the tv on, wait a minute, try to change channel!)… it’s gotten so much on my nerves, that I’m getting rid of it!

And it was in this turmoil that I thought… if ST has some local processing AND the tv is on the network… and I can see both IP addresses… what the f is stopping ST from seeing and usng my UE49KS8000 TV?

Why can’t I tell my ethernet connected Google Home mini (it works, trust me) to turn on the tv, and have ST detect the tv is on and change the mode to “movie night”?

There… that’s the story… not short but it’s the shortest I could do… :slight_smile:

Sorry if I bored you all to sleep!


(Dan) #7

Gracias por la explicación. That’s about all of the Español that I am good for tonight. It has been about 32 years since I took Spanish! :wink:

I also prefer to use a wired network wherever possible. Unfortunately, some devices are WiFi only and thus I have to make sure that is working well too!

I silently watched the whole Samsung/SmartThings TV issues unfold in these forums. It really is a disgrace at how Samsung and SmartThings have handled that whole situation. In fact, that event is the reason that I promised myself to never buy a Samsung Television. I am quite pleased with my new LG OLED television. The picture is absolutely amazing. Fortunately for me, my Harmony Elite Remote Control/Hub are working very well. No WiFi issues in my house.

Hopefully you will be able to get your system working the way you desire. Buena suerte, mi amigo!


(Ernie) #8

Perhaps you could use a Global Cache ip2ir contolled by an Anymote app on your phone. Anymote has an Ifttt channel which you could use to connect to Google Home. As for ST turning on “movie night” you could use an ST compatible power plug with energy monitoring to trigger your routine.


(Daniel Consuegra) #9

You fooled me when I started reading! haha! Not bad!

You mean you’re going to help me out by creating a DH and a Smartapp? :star_struck: 'cause that’s the only way I see a permanent fix to this issue… doing Smartthings/Samsung’s job… and then send them the bill!

Looked into it… not bad! For a mere 200 euros… lol! will dig deeper into it…

As for the Anymote app… need to investigate further… wonder if there might be a way for it to “click” a smartthings virtual button like I do with Harmony right now…


(Ernie) #10

Anymote can send Ifttt an email or web command to trigger ST through Ifttt. Or, Anymote has a Tasker plug-in which could use Sharptools or send a web command to WebCore.


(Daniel Consuegra) #11

hmmmmm… that sounds awesome!