SmartThings Community

CentraLite Keypads

keypad
dth_security
(Joel W) #1027

Yes I am hoping the DTH can be changed.

(Working on a secret project, are we, sir?) #1028

Just curious if anyone has found a more secure way to mount the keypad to the wall ? How it’s done now anyone could simply walk off with it.

(Mark) #1029

I have two keypads, they’re both inside my home.

If someone I don’t know can take the keypads off the wall, I’ve got bigger problems at that point than the keypads being carried away.

2 Likes
(Bernie H) #1030

Since they have set my alarm off, police will be on their way and been recorded on at least 4 cameras by then, they can have it if they want it that bad. LOL

2 Likes
(James K) #1031

What is the trick to getting ST to add the keypad? I’ve added the Device Handler from farther up, and the one of the Keypad apps, but the ‘Add a Thing’ is simply not finding the keypad to be added. I have a ton of z-wave components but this is my first Zigbee, is there anything different about adding a zigbee?

(Arn B) #1032

If the keypad is not getting a good signal from the hub you may need a zigbee repeater. Try moving it closer to the hub to get it to connect.

Not sure what you are using, but suggest the following:

First install this DTH

Then follow info at this link

After it’s installed, you need an app to make it useable with ST and SHM. I shamelessly suggest my app SHM Delay Version 2

3 Likes
(James K) #1033

Updated the Handler, actually already had SHM (v1) so updated to the newer version 2.

Still no joy. The process I am following is the same as I’ve used to add a Z-wave devices in the app, open the Things list, click + Add a Thing, press a button on the thing until it registers. Only with the keypad it is not registering. Also attempted to manually add the device in the API buy using the long UID string on the Keypad as both the Zigbee ID and the Device ID. Neither approach seemed to work, what am I doing wrong?

The keypad is sitting about 3 ft from the ST hub.

On a different topic, I setup your delay app for the two doors that would need a delay if the keypad was working, but I am not seeing anywhere in either SHM or SHM Delay that allows me to add User Profiles for what pin is used to arm/disarm. Where do I find that?

(Arn B) #1034

The Keypad can sometimes be a pain to get connected and is a two step process. I’m out of ideas other than to reset the keypad back to factory settings, then retry according to the directions in Zack Cornelius’ post. BTW is this keypad manufactured by Centralite?

Set Global “Activate Total Keypad Control” to ON/True

(Joey) #1035

can someone help me. I am having a very hard time getting the Centralite xfinity keypad into pairing mode. I tried the process of holding tamper and then inserting one battery, then release tamper about 2 seconds in but for the life of me I can get it to blink so its in pairing mode…am I missing something? I have tried over 100 times.

(Zack Cornelius) #1036

You should be able to remove both batteries, then hold the tamper switch in, put in one battery, release the switch.

They say “2 seconds”, but releasing the button after a full 2 seconds doesn’t always work. The best advice I can come up with is “Release the button sometime after the lights come on, but before the network light starts blinking”. It’s usually about a second or so after inserting the first battery that the keypad lights up, so 1 second “should work”.

(Joey) #1037

Thanks Zack. I will give that a try. Another question for you how will I know I have successfully got it into pairing mode? Someone mentioned the wifi icon will blink…is that correct??

(Zack Cornelius) #1038

The network icon should blink slowly (One “double blink” roughly every 2 seconds, I think)

#1039

I previously added the keypad before finding this device handler/smartapp. However, I do not see the keypad in the smartapp as something I can add to it.

Do I just change the device type in the IDE? If so, what would I change it to?

(Mark) #1040

If you saved and published one of the device handlers in this thread, then in the IDE you can change a device’s assigned handler to the name of the handler you installed. It’ll be at the bottom of the list, all custom device handlers are added to the end, after all the ST official device handlers.

#1041

Thanks Mark! I was looking for it alphabetically.

Has anyone used this to trigger a chime when one of the Iris sensors is open? I found some old threads but didn’t see how it was done.

(Mark) #1042

I would suggest checking out this thread:

For one thing, there’s a link to an updated version of the device handler for the iris/xfinity keypad that enables the chime function of the keypads.

Then the smartapps that Arn developed can be used to add entry/exit delays, chime on door opening, etc.

1 Like
(Cthebadge38) #1043

I am having this problem too but your fix is not working for me. I installed the DTH, it successfully paired to the ST hub but there are no beeps and the light continues to flash no matter how many times I hit the tamper switch again. Below is the last entry in my log file. I could only post the last line because I am a noob apparently. Lol The lines before this show the motion sensor logging when I wave my hand in front of it. However, I’ve attempted to save it, pull and re-insert the batteries but the only thing that will work sometimes is the volume button in the app will make the keypad beep. Any help would be greatly appreciated! Thank you!

7deced86-0563-4ed0-8d83-02284c6d4233 ‎11‎:‎43‎:‎56‎ ‎PM: debug [name:temperature, value:72, descriptionText:Iris 3405-L Keypad was 72°F, isStateChange:true, displayed:true, linkText:Iris 3405-L Keypad]

#1044

I just moved over to the Smartthings hub from Iris since they decided to shut things down. First off, I wish I bought a ST hub a long time ago. Anyway, I was able to get most of my Iris devices working with ST, except the Iris V2 keypads. I installed the DH and smart app at this first post of this discussion, and was able to pair the keypad as the Centralite. When running the 3400-X Keypad Manager, it says everything is good in green, but a few second laster it turns red and says “An unexpected error has occurred”. I just want to use the keypads to arm/disarm the alarm, is there a fix or another option?

(Arn B) #1045

Take a look a my Smartapp SHM Delay, especially section 14 that points you to a working DTH

(www.rboyapps.com - Make your home your butler!) #1046

You can check out this update to the DTH which supports all the features of the v2 keypad including the built in Siren