Centralite HA Thermostat

I’m poking around with my own version. I literally just got these thermostats on Wednesday, so this is very much a work in progress. I still need to work on these things:

  • Validate that the mode selected is supported (emergency heat for non-heat pump units)
  • Still need to catch and verify all operating state values.
  • Still need to catch and verify power source values.
  • Clean up and polish the code a little more, add comments where appropriate.

I have the UI pretty much the way I like it (works in the new app kind of), more importantly my wife, so this won’t change much:

If you want to play around with my code, here it is:

https://raw.githubusercontent.com/jsconstantelos/SmartThings/master/devicetypes/jsconstantelos/my-centralite-thermostat.src/my-centralite-thermostat.groovy

Thanks, John. I’ll take a look.

Updated code on 6-16-2016 to make it work with the new app and still work with Classic:

https://raw.githubusercontent.com/jsconstantelos/SmartThings/master/devicetypes/jsconstantelos/my-centralite-thermostat.src/my-centralite-thermostat.groovy

Screenshot_20190616-153908

I’ve tried the code from both DaveC and johnconstantelo, but my Centralite HA just sits in “Smartthings” as “Checking status…”. Thoughts?

I’ve made a few updates, so make sure you’re using the most current release.

What I recommend you try is update to my latest code (save and publish), swap over to the Zigbee Thermostat DTH temporarily, and then after a minute swap back to mine. Sometimes the new app doesn’t do well with custom DTH, and this seems to “wake it up”. Why? I have no idea.

Here’s the link again:

https://raw.githubusercontent.com/jsconstantelos/SmartThings/master/devicetypes/jsconstantelos/my-centralite-thermostat.src/my-centralite-thermostat.groovy

I’ll try that. Should I be using “Published” or “Self-published” for the version?

I tried self-published, and it seems to have mostly worked this time. But why do I have 2 “Heating temperature” areas? One is it’s own, and one is in “Set temperature”. Also, battery says 133%? Is that because there are Energizer Lithium E2 batteries in there?

I have no idea. Can you post a screenshot of what that looks like?

More than likely. The math takes the raw voltage and converts it based on a formula I’ve used for other handlers from ST’s own code. That’s an easy fix since I had to do that for another handler. I’ll have that updated in my Github repo by tonight.

Yesterday, when the app looked funny, I switched it back to “Zigbee Thermostat”, which seemed to be working better (only the battery function didn’t work, which didn’t show any reading for the battery). Before I did that, it looked like the first screenshot. Today, when I switched back to your code, it has even more repetition. That’s in the second screenshot.

Hi John- Looking forward to learning from this group.

1 Like

Yeah, not sure what to tell you. How does it look in the Classic app? I bet it’s normal. I’ve never seen that kind of behavior before. I’d say that there are leftover device states between switching DTH’s or something else screwy with the new app. I just set up another one of these at my sister’s house, and it looks normal.

Have you tried force closing the app and restarting when switching back and forth between DTH? If not, I recommend it.

I also updated my code to fix the battery reporting value.

Hey Jim! Welcome to the community and SmartThings!

Hi John- I think we may know each other (HTGOC). Hey, question for you, my centralite thermostat never seems to pair up to my hub. I’ve followed the instructions to get to join a network…am I missing a step in Smart Things?

I’m having the same issue. I’ve tried many different device handlers. Zigbee Thermostat seems to not duplicate the temperature settings. However no no matter what device handler I use for some reason, whenever I use my google home to change the temperature Google says "centralite HA thermostat can’t be set to that temperature. "

20-09-15-17-59-52 The new app still shows duplicate device controls.