Can't sign into the CLI

Perhaps @nayelyz can help? When i try to login using the CLI on windows using powershell, i enter the IP address of my hub, then my browser opens where i have to authorise access to the CLI. I grant it, then get the error “Failure trying to authenticate.”.
What to do to fix this? I am already signed into smartthings IDE on the browser that powershell opens to Authorise.
In the logs in the appdata folder i see this:

What command are you using to get started and generate the login sequence? I’m not quite sure where your entering the IP address of your hub comes in, as I have never had to enter the IP of my hub related to CLI queries. If you can explain the steps you’ve taken that might help.

There are two things that you can try:

  1. Try a “simpler” command to trigger the Authorization. For example:
smartthings devices
  1. In the Windows file explorer enter the path below and delete all the files in this directory:


Just as a reference, @Bry, he’s using the command below which allows us to see the driver’s logs:

smartthings edge:drivers:logcat
1 Like

both are not working.

if it’s any help, the page URL that gives the error is:

ok, please send the complete log of the debug mode of the CLI over DM, I need it to report it to the team, especially the App ID.
I’ve seen this error before, so hopefully, it can be solved the same way.

let me know how to make a log of the debug mode.

Oh sorry, I thought you already were using it because of the URL you shared above.
On Windows, you need to execute first:


And then, the smartthings logcat command:

smartthings <command>

this is the error:
[2022-09-29T21:22:32.015] [ERROR] login-authenticator - error trying to authenticate invalid_request
[2022-09-29T21:22:32.015] [ERROR] login-authenticator - Unable to find any configurations for app: 33f207c0-a578-4253-b851-3363ef8bbcaf
[2022-09-29T21:22:32.808] [ERROR] login-authenticator - unable to get authentication info

this is with debugging enabled.

1 Like

ok, thanks for the info. One last thing, can you confirm if the email you use here is the same for the SmartThings app and provide access to your account, please? To do so, please follow these steps:

  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

it’s enabled for around 3 more days.
my email for smartthings is …

ok, thanks for the info.
I deleted your email from the previous post for your safety. Sorry for the confusion, if you need to share private info, please send me a DM.

thought this was a DM :face_with_thermometer:
that was silly.

No problem, I replied to you before seeing you sent me a DM as well. Just as a future reference, we can identify if we’re in a DM or public post thanks to the envelope icon:

I’m having the exact same issue (with the exact same UUID, even). I’ve turned on support data access for 1 week, if someone could help me out from support.

Hi, @Jonathan_Whitall.
Have you tried the workarounds I mentioned above?

If so, then, the only thing missing is your email. Please confirm if it’s the same as your user here, if not, share it with me over DM.

I’m on a Mac, so I can’t delete that particular folder. I have tried the smartthings devices command with the same result.

I don’t know what you mean by my email being “the same as my user here.”

And I can’t figure out how to send you a DM.

Ok, don’t worry, I’ll send it to you and we can continue there.

Hi, @Jonathan_Whitall.
The team needs to continue investigating your issue and the support access is now disabled, can you enable it again, please?

Done. I’m replying with at least 10 characters so that my response to you doesn’t get rejected. :slight_smile:

1 Like

Hi, @Jonathan_Whitall, can you check if you can use the CLI correctly now, please?