Can't pair Xfinity XHK1-UE keypad

This is my first Zigbee device and I can not get it to pair. It is used so I suspect I’ll need to force exclusion or whatever the zigbee equivalent is. Any guidance I can find is not for the 4x AA version of the keypad.

1 Like

Thanks for the excellent lead.

I did get this to work but I remember it being a real pain because it required several exclusion and inclusion attempts.
I posted device handler code here Xfinity 2nd generation keypad help

I am having the same challenges with pairing…can you share the inclusion/exclusion steps you followed?

It’s been awhile but I think I just held down the tamper button when I inserted the batteries. I vaguely remember entering a pin or 0000 after doing this. It was a PIA! I do remember that! It took multiple tries.

I installed the device handler on my samsung smartthings hub and put the xhk1 in pairing mode; the green led in back flashes three times but the new samsung smartthings app does not see it. i tried pairing it with a generic z wave device but it doesn’t pair. i also tried the qr code in back but no luck. Does anyone have any ideas on how to get it setup?

Bring your keypad close to the hub and try these steps, if you’re having trouble scroll down on the topic below and use the factory reset instructions and then try it. You will need a compatible device handler and smart app to effectively use these keypads:

Thanks - have the rboy zigbee keypad device handler so it now is now paired. However, in rental lock automater, the xfinity xhk doesn’t show up as a lock, only my schlage physical locks. I’m trying to pair the keypad to control a myq garage door and have to sync up with the code programmed in rental lock automater.

Sounds like the wrong device handler is assigned to your keypad. If you have installed any other device handlers remove them or manually assign the Enhanced ZigBee Keypad device handler to your keypad from the IDE