Can't install/publish from GitHub but Copy/Paste works fine


(Allan) #1

I’m not sure if there is something going on again with GitHub integration or not. I just updated two DTH’s in my GitHub. I do a update from repo, select them, and execute update with this error:

Updated 0 devices and created 0 new devices, 0 published (2 skipped due to errors)

Usually this means there is something wrong with the code. So I go to GitHub, view as raw, select all, copy, and paste it as New Device -> From Code. DTH installs fine. Assign it to a device. Device works fine, no errors in logging (which is also a bit buggy right now…). Is there anywhere to go to look and see why there were errors? I already checked the basics…no other devices with the same name, meta data definition is good. Also tried doing them one by one with same skipped result. I went back and tried a different DTH, a old one, and that one installed correctly so that tells me there is something with these two newly updated ones but I would think they wouldn’t install locally if that were the case.


(jkp) #2

Which DTHs?


(Allan) #3

I think I may have figured it out but I didn’t think this was the case. The DTH was called in GitHub:

child-contact-sensor-enhanced-runtime.src/child-contact-sensor-enhanced-runtime.groovy

Inside the DTH it was called:

name: “Child Contact Sensor Enhanced with Runtime”

I renamed it on GitHub to child-contact-sensor-enhanced-with-runtime.groovy and it worked. So I went to the other DTH and same thing, renamed the file name to be exactly the same as the name within the DTH except dashes in place of spaces and that one works now too.

Is that a new requirement or did I just happen to always name things the same internally?