Can't enter on/off times in STSC Smart Lighting

I’ve been using SmartThings for a couple of years with a number of Smart Lighting automations added from within the Classic App.

I’ve been using STSC in parallel for around 10 months. No issues, until recently when I wanted to change the set times for a device (using Smart Lighting).

If I do this in Classic, everything works fine and the automation runs as expected. However, if I try the same thing in STSC the new times won’t populate (and the screen refreshes while still scrolling the time ‘wheel’ for the ‘off’ time). If I create a new Smart Lighting automation in STSC, the same issue; the times refuse to accept (nothing shows in the on/off fields).

All behaves correctly in Classic after setting the times there.

When I go back to STSC to look at the automations just created in Classic, the times are missing. The automations do run correctly though.

Anyone else experienced this in Smart Lighting?

Worried that this doesn’t get fixed before Classic is shut down.

I’ve reported to Support. Awaiting feedback.

(I’m using iOS 13.3 and latest versions of the apps)

1 Like

I am on iOS 13.3 and I am unable to duplicate this. You are not hitting the clear text in the time wheel by chance? I find that sort of confusing because it is the only text in the window and I want to hit it after selecting the time.

Only advice I can offer is try removing the ST app and perform a fresh install, login back in and see if it is working.

@23dash and @jkp, I can see a similar behaviour.

Set turn on time at 19:00. Works. Try to set turn off time to 2:00. It doesn’t accept it.

But you can set on time to 19:00 and off time to 20:00. I works without any issue. And then when 20:00 was set, then it allows you to change it to 2:00 AM.

@jkp can you try it? If you can, then please tag Brad. It might be an issue with today and next day time difference.

By the way, I am using the Android app.

UPDATE: Actually I spoke too early. It is not allowing me to change to 2:00. I was allowing once only. Now it just leaves it empty or clears it.

So tagging @Brad_ST. Can you check this and add to the bug list? It shouldn’t be flakey. :wink:

I can select start at 7pm and end at 2 am. Select 2am is flakey but I can select it after a few attempts.

It shouldn’t be flakey…

Well, I was going to check it with voiceover, but although I can get to the page and select the device and time as a trigger, it never gives me the pop-up fields to enter any time at all. Sigh. :scream:

@Brad_ST I have not had good luck reporting voiceover problems through the regular support line, they don’t seem to have any understanding of what I’m talking about. Do you know any other way I might be able to report this kind of problem?

2 Likes

@GSzabados The on/off times I’m trying to set in STSC are on the same side of midnight.

@jkp Reinstall of the app has helped with the creating of a new lighting automation. However I still cannot edit the ‘off’ time of an existing automation. The ‘off’ time I scroll to does not appear in the ‘off time’ field when I click ‘done’ on the scroll wheel (and a message keeps popping up saying ‘processing’ while I’m still moving the scroll wheel).

Also, the ‘off time’ field is blank in STSC for an automation which displays correctly in Classic.

The behaviour I’ve described is exactly the same on an iPhone and an iPad both on iOS 13.3

Something’s not right…

Definitely report the issue to ST support

Thanks @jkp

Ticket been with Support for a couple of weeks

2 Likes

@23dash Are you able to share screenshots either here or via your support ticket? Are you seeing results like JD’s screenshot?

The page refreshing while selecting the off time is a known issue for iOS.

I will try to flag this.

5 Likes

Thanks! If there’s a specific team or department or keyword or something that I could give the first line support people so they would know who to pass voiceover problems to, I’d be happy to do that too. Right now, I just can’t get them to understand what “voiceover“ is so we aren’t getting anywhere.

Here are screenshots of an automation in both Classic and STSC (time fields are blank in STSC)

!

Here’s a screenshot from STSC of another automation which displays correctly in Classic. The automation switches devices off at 01:05am

This from the Android app. It does show “processing…” before. The time selected for the off time is 2:30. (It is Hungarian, Kikapcsolás=Turning off)

It lets me save it, but it doesn’t show the value. If I try to select a different time for off, the it shows “processing…” again, and it clears the field completely.

I have played more and I think it is the single digit hours. I managed to produce the same result on the on time selection too. And I cannot save it.

Try to set any times before 10:00.

Thank you for the screenshots.

I have tried over and over and am unable to reproduce the issue. I tried with two different iPads and an iPhone. I changed the time format to a 24 hour clock and tried setting the time before 10 AM.

Is there a step or detail I might be missing to be able to reproduce?

I have tried both on mine and my wife’s Galaxy S10 with the latest OneApp. Both producing the same.
When I try to set on time to 2:30 it just gives a horizontal line and cannot be saved. (My wife’s phone is set to English (UK).)

Hi Brad

I’ve done nothing unusual or special in setting these automations. Just gone step by step from top to bottom as expected.

The only possible significant point is that I had Smart Lighting running in Classic a year before I downloaded STSC and started viewing/editing in that app as well as in Classic.

Hope you can get to the bottom of this before we lose access to Classic.

Ok. I am able to reproduce an issue with Android if I set the language to English (UK).

I am still unable to reproduce with iOS. Dave - can you share what model of iPad you’re using? Also, can you confirm your language/region and time setting?

2 Likes

Hi Brad

iPad Air (2019 model), iPhone XR
English UK GMT

The 10am thing is significant. I can successfully enter times between 10 and 23 hours, but cannot enter times between 00 and 09 hours. Something to do with the leading zero on the 24 hour clock?

Let me know if you need anything else

Got it, thanks!

I was finally able to reproduce with a larger iPad so I’ll get a bug report filed.

3 Likes

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.