Can't edit simulated switch type?

So, I’m trying to edit the colors of a simulated switch that I’m using as a check switch within Rules Machines. I created a simulated switch that I can use to hold the rule in check, but I’d like to edit the color of the background such that it blends more seamlessly with my other devices in the room. That is, the rule is held in check when the switch is ‘on’, but ‘on’ is defaulted to green…I’d like on to show up as ‘ffffff’ and ‘off’ (meaning the rule is active) to show up yellow (so I know it’s running) using the color ‘ffff00’.

Unfortunately, when I try to create a device type and use the simulated switch as the temple, it just won’t take. All the other templates take, including other simulated device templates…just not the simulated switch. Anyone know what I’m doing wrong?

I tried searching the forum, but didn’t find anything in the first 45 min, so I figured I’d ask.

I’ve tried editing a standard z-wave switch type, and the got the results that I want, but since there’s no physical switch to poll against, I can’t get it to change states…which makes sense. Can I just remove the capability “Polling” line???

It appears I need a simulated switch…which brings me back to the questions at hand: how do I create a device type with the simulated switch template…?

What do you mean “won’t take”?

Are there error messages??

(The platform is flaky today, what else is new right?, but that could be the problem.)

Literally nothing happens. Every other device type transfers to the editing window when selected, but when I select that one, nothing happens.

I commented on this earlier today, many of the device type templates no longer copy into the new device window in the ide, it’s actually been a feature for a week or more…


I created 4 virtual toggle switches from github code that work fine, controlling routines, BUT when I add them to turn off via Good Night Mode, they weirdly turn ON, when they were off already!
Any ideas?

That fixed it! All working correctly now.Thanks

1 Like