Can't Delete Roomie Remote SmartApp/Devices


(Beth) #1

I’ve spent the past two days trying to delete the Roomie Remote smartapp and associated device because I accidentally broke the pairing between the ST app and my Roomie Remote (I think it may have been an IP change, but not sure). I have searched through all the threads and tried everything I could find, but it simply refuses to be deleted.

I seem to have a Roomie Remote Agent Connect device type, three three different Roomie Agent instances, only one of which appears ever to have been active. Then a supposed Roomie Remote smartapp which is elusive and shows the three different Roomie Agents as “children”.

I have tried deleted the smartapp from the ST app. Tried deleting the “things”. Tried disconnecting any “Things” that were using the smartapp RoomieRemote. All say “There was an error deleting your smartapp”.

I then tried deleting from the IDE. Went to the obvious places, can’t uninstall smartapp, thus can’t uninstall devices. Went to Home location to display all smartapps, click the x, neither Roomie Remote app or Roomie Agent app can be deleted there either. Tried deleting the code from all of them - device type, device, smartapp - nope. Tried reinstalling overtop of the different codes and republishing. Still can’t delete, still can’t pair with SmartThings from within my actual Roomie Remote app.

The only clues I’ve gotten are the one error I get from trying to uninstall one of them from IDE:

Oh No! Something Went Wrong!
Error
500: Internal Server Error
URI
/installedSmartApp/show/72361690-4512-481a-9a5f-78a835384894
Reference Id
da85b2c9-3564-42d3-8631-ea15f18814c4
Date
Sat Jul 11 17:10:01 UTC 2015
Class
groovy.lang.MissingPropertyException
Message
No such property: id for class: org.codehaus.groovy.grails.web.taglib.NamespacedTagDispatcher

Oddly enough, when I am in the Roomie Remote app and try to add SmartThings again, it does login to ST just fine, shows all my “things” and allows me to check the ones I’d like to control, but when I click Authorize, it says it can’t pair. If I could get the thing to re-pair, I wouldn’t be trying to delete the whole thing from ST. I’d just try to delete the two “empty”, inactive Roomie Agent instances.

Sent a note to support, but I’m too new to know if a problem really needs support to fix it, or if I just don’t know how to fix it yet. Would love to be able to figure this out.


#2

Have you tried asking RoomieRemote support? They write that smartapp, so they should know. (It’s an official integration from their side, but to SmartThings, it’s just another user-written smartapp.)


(Beth) #3

I hadn’t contacted them yet, simply because I’ve heard they aren’t terribly responsive, at least on their forum. Maybe they’ll be better about direct support so I will give it a try. Thanks!


#4

I’m sure SmartThings support could help you force delete the instances on the ST side, I’d just be concerned about getting things right on the RR side.


(Beth) #5

Thanks, JD - I’ve sent them a support request as well. Hopefully they will respond with a fix, in which case I’ll report back here in case anyone else runs into this issue.


(Beth) #6

Just as an update, I did hear back from Roomie Remote support. They told me that the issue is related to the ST bug that is affecting OAuth. ST support also said they would look into the issue.

So here’s hoping the bug gets squished soon.


(Lost and Confused) #7

Unrelated directly to the roomie remote app, but I had a similar problem with a Foscam App that I had multiple instances of. I had to uninstall the current Android App, then get an older version of the Android SmartThings App loaded and then I could delete the Foscam App. Might be worth a try.


(April Wong) #8

Hey! Just wanted to let you know that we’re aware of the Oauth issue. We’re currently testing a fix right now, so I cross my fingers that it will be resolved soon.