Can't Create Automations

I am a new Smartthings user, but not to IOT/smart home stuff. just got the hub the other day. All devices and such migrated over fine. I created a few basic automations for the lights. However after a few hours automations refused to save due to “network or server error.” Its been a few days now, and the most basic automations refuse to save. I have tried multiple ones. I have reloaded the app, rebooted the hub, rebooted routers, called into customer service and nothing has worked.

Smarthings seems like a good platform, but its clear why it also gets so much bad press. It broke on me just a few hours after getting it up and going. Is it me?

I get that sometimes too. Does it trigger a popup to rename it?

I’ve found by “renaming” it (I always just give ti the same name as before), it tends to save. If it gets hung up on the spinny wheel bit, after a while I just force close the app. I go back in, and it’s saved and works.

Edit: And welcome to the forums!


First rule of SmartThings: it’s never just you. :scream:

That said, that particular message is used for a lot of different underlying causes. So it can be hard to diagnose. And it depends how much time and effort you want to put into it.

The first thing we need to know is from the first rule of home automation: “the model number matters.” (That’s true regardless of the platform you’re using.)


What are the specific brands and models of the devices that you are trying to create the automations for, and how many of them do you have?

There are some undocumented “guard rails“ which can trip up people coming over from a different platform if they have a whole bunch of devices.

FAQ: Limits and Guardrails (max # of automations, devices, etc)


Thanks for the replies, unfortunately no renaming it doesn’t help, thanks for the tip though.

JD, the main thing I am trying to control are some Ecosmart Zigbee bulbs, i have a bunch of them. However even if I try to control a wall switch or smart plug of another brand it doesn’t save. As far as I can tell I simply cannot save any new automations.

Thanks for the link to the guardrails though, that is helpful. Right now I just would like to add one simple automation, but I cannot.

And you have no automations at all yet? What country are you in, what model hub do you have, and did you buy new or used? ( i’m just trying to start from the most basic stuff and then work from there. Very soon I’m going to ask you how many devices you have added to your account, so be ready for that. :wink:)

Thanks, I have two automations that stuck, they were the first two I tried. I have a v3 hub. I did buy it used off of Amazon, it was a warehouse deal. The unit has some cosmetic stuff on the lid. So it might be that?

I have about 30-40 devices connected to the account.

What’s the model number off the bottom of the hub? And what country are you in?

The V2 hub was manufactured with different radios for different regions, but otherwise was essentially unlocked.

The V3 hub and the new V3 app are region locked for a number of different things. This has tripped up a number of people buying used equipment, particularly if it happens to come from another region. And there’s no real error message in the app to explain what’s going on.

Ooohh did not know that. I am in the USA, the model number is IM6001-v3P01

Ok, that’s the US model (assuming it’s not a counterfeit). so that shouldn’t be it. check the location on your account and make sure that the address is correct and is a US address.

It is set to my home address. It would be a very good fake. Again everything works fine…just not creating automations

Not sure what to say then if Support can’t find anything. Definitely weird, though.

I’ve been having the errors (as have a number of users on the Facebook group) and the popup drew my attention too, especially as it has never worked properly for me (the piston always ends up with the default name regardless).

However yesterday the automations only saved if I made no attempt to change the name from the default. Today they only saved if I did change it (although it didn’t take).

I should add this error happens with even the most trivial of automations.

1 Like

This is the same issue as reported here:

1 Like

I thought so too, but the OP in this thread says they have “30–40 devices“ and they got the error trying to create their very first automation ever. Even if it was set up to turn on every device, they wouldn’t hit that limit.

Well I read that thread a little and that seems to be the only logical solution. If actions include changing color temperature and brightness of the bulb. And so for every bulb I have 3 actions and I do that to 15 bulbs… perhaps my first two automatons took all of it? I seriously doubt it, but it must be it.

Maybe what happened as another user mentioned was that failed saves ghosted on my account and so the system sees many more actions that are already there??

I simply can’t believe that me, a new person with a moderate amount of of devices has already hit the ceiling on automatons. It means this is a severely limited platform.

1 Like

I didn’t say that my first automation failed, or I didn’t mean to imply that. I mentioned I created a few (two to be exact) automations at first, that I thought were simple, but perhaps they are “action” heavy? Those first two stuck and then the rest have failed.

This action theory is the best one I have heard yet, because it makes sense why I was able to create two and then it stopped all together. If this is a case how is this platform usable to people who have more than a handful of devices and smart bulbs??

Because they built out their system while using the previous app version, which doesn’t have the guardrail limits.

That said, ST has stated many times that their typical customer has fewer than 15 devices and never uses any custom code.

What they haven’t said publicly but is pretty obvious is that their largest customerbase is people with very expensive smart Samsung tv’s and appliances who just want to add a few lights and maybe a video doorbell. (Because most people with $5,000 refrigerators aren’t looking for a cheap DIY system.)

The people in this forum tend to be power users, and often, um, “frugal” power users. Not the typical customer.

There seem to be 3 custom automations. By my count one of them has 6 actions, one has 18, and one has 226 and if I’m math is right that adds up to 250. I’m not exactly sure how a single automation has 226 actions but I’ll DM you to discuss in greater detail.

One way to reduce bumping into this limit is to leverage Scenes or Smart Lighting.

1 Like

May I ask if that was specifically referring to the OPs issue? Only a number of people have been reporting similar errors that they’ve only been aware of for a few days, and they also find they can save sometimes. As far as I can tell my modest eight automations (to replace the four default Routines) have ten simple actions between them, and my three scenes add about twenty-three. So on the face of it that shouldn’t be an issue for me, for one.