Can't add smartthings hub(2018) at new smartthings app

um. I think that they check the sever location.

I wonder if a VPN would work?

1 Like

I’m from Israel and I wanted to buy the 3rd gen hub from eBay and start my own smart home but thanks to this thread I might reconsider… If you do succeed in adding the hub to your ‘things’ would love to know how…

EDIT: got my V3 Hub and pairing was easy on my main Israeli account, I plugged the hub in to the router and power source… few moments later got asked by Smartthings Samsung connect appif id like to pair the Hub, no new account, no vpn, nothing.

This is probably illegal anyway due to the z-wave frequency differences. canada, USA and Mexico use the same z-wave frequency.

Yes, right.

In KOREA, the market is very small. so they do not want to lunching the smartthings.

I took all the possible steps to resolve it quickly.

initializing the unused iPhone and set the language and region to English / US.

After setting up VPN (US server), everything is done.
Install smartthings app, I try to login to my existing account --> Failed
Create a new smarthings account and login -> Success.(VPN!!!)

As a result, I think server location is important when creating a smartthings account.

When I log in with a new account on my current iPhone, the hub category looks OK.


Good idea. thank you.

1 Like

Try it!!!

Oh no. I’m in Australia using v1 hub with classic app without issues. Just got the 2018 hub delivered, and to find out that it’s region locked is crazy.
[Edit] @hayunhwang, thank you. I VPN’ed into US to create a new account (using the new smarthings app), and now I can add the hub.
[Edit2] Some people say I can add 2018 hub using the new app, and use the classic app after that. When I log into the classic app using my newly created account (from the new app), I can’t see the 2018 hub, nor can I add it (since it asks for the v1/v2 hub claim code). I need the classic app for the custom device handlers. The battle continues.

Can you add normal zigbee devices? I’m in Australia using a v2 hub. I have the new app working OK-ish, the main issue is that I can only add Samsung TVs, fridges etc.

It’s not a big deal at the moment as I can use the classic app to add things. But if creating a new account with a US VPN works then that may be enough for me to start again.

Using my AU-created account, I only saw the Samsung appliances in the add device section. But when I use my US-created account, I can see more devices (screenshot). BTW I don’t need to be connected on VPN to be able to add all devices.

But this doesn’t help me. I have a couple of custom device handlers. So I really need the new hub to work with the classic app, or Samsung to allow custom DH on the new app.

yes. you can see new hub and add things at classic app after add new hub at new app.
I did that way. and use it.

1 Like

Thank you. Linked the accounts, logged out and logged back in to the classic app, and the hub is there! I will slowly start migrating.

i have smartthings hub third generation and tried to connect with smartthings app on ios.
the hub can not be found automatically so tried to setup manually and followed the instruction but still couldnt find the hub it says your wifi hub isnt ready yet . wait for the LED to start blinking red and green, then try again.
it is blinking red and green tried with different device, used different ethernet cable also reset the hub, none of them worked.
my neighbour used the same hub and could connect it.
what is the issue?

This! Thanks for this!
I got my ST2018 up and running in Norway!

Hi Nicho
Being from Denmark I wanted if your solution might work for me…? Would you be kind and explain to me, how you got the new 2018 hub up and running?
Many thanks/jfs3004

Hei Jesper.
Beklager sent svar, jeg har byttet mobiltelefon og glemte mailen din.

Essensen i det jeg gjorde var å slette min Samsung konto, for å så lage en ny en med USA som land.

Dette gjorde jeg ved å bruke en computer med VPN og browseren brave, som støtter Tor nettverket for anonymitet.

Håper det var oppklarende


Sorry for the Norwegian language. I dumbed out and thought it was a PM.

Hej Nicho

Mange tak for dit svar.

Da du oprettede Samsung konto i anden omgang, brugte du da samme credentials som i den Samsung konto du slettede?

Med venlig hilsen/Jesper

Hi Jesper,

I did use the same credentials when i created the new account (after the previous was deleted)