Cannot save automation

I have had this long-running problem creating automations in SmartThings and get a “Network Error” when I try to save it. It does this on multiple Devices (phone and tablet) and it does not seem to matter whether it is a simple or complex automation.

Furthermore this has been going on for several months both with the old ST App and the new one. Has anyone else experienced this? I find it hard to believe it’s a network bandwidth issue since I regularly watch movies on my tablet with no issues.

What am I doing wrong? Has anyone else experienced similar issues?

Custom device handler being used for any of the devices? What is the device in your example above?

1 Like

Give it a try now. You had a C2C device that was out of sync in some places. I re-synced things and you should be good to go.

1 Like

It’s a Feit Electric smart light bulb that I have added to ST using the Tuya app and the instruction I found in this forum. I know this is not a supported device, but the ST does control it - just not using an automation to turn it on and off at a set time.

UPDATE: see below. Problem fixed.

Wow - that fixed it! Incredible Brad. Thanks for the help.

What is a ‘C2C Device’ and is resyncing something I can do if I have problems in the future?

Great support!


1 Like

Hi Paul! C2C is a cloud-to-cloud. I wouldn’t expect this to happen again but would recommend contacting as they’ll be better able to identify which device, if any, is causing the issue. Sometimes renaming a device can trigger a sync. I’m not sure how you would know which device was out of sync though.

1 Like

Thanks so much Brad. This automation works now.

All the best,