Cannot manually control devices that use Edge Drivers in the iOS app


I have an irritated issue, which frustrate me a lot and that is that I cannot control devices using Edge Drivers in the IOS smartthing app.

  1. I install a Aeotec Hub v3, clean install (also tried factory reset)
  2. Add multiple devices, even Ikea Trådfri Bulb
  3. But when they use a Edge Driver I cannot control / retrieve parameters from the ST IOS App. However using Routines, Scene, Light group it will update the device
  4. If I integrate with Google Home, am able to control the devices through Google Home App (but there is no sensor data there).

Am I doing something wrong now, am I supposed to example be able to Dim an Ikea bulb from the ST App?

Anyway Idea, or should I just scrap this and move over to another hub!


That definitely doesn’t sound right.

First question—does the hub have an active internet connection?

This confuses a lot of people, but the SmartThings app ALWAYS requires an active internet connection to talk to the hub, even if both are on the same WiFi network, they didn’t have to design it that way, but they did.

If the hub does an active internet connection, when you turn the bulb off with Google home, does the bulb status change in the app?

Next step: unplug the hub and leave it off for 10 minutes, then turn it back on.

Turn the phone off and on.

Sign out of the SmartThings app and sign back in.

(Those 3 steps are just to try to force the hub to re-sync with the cloud.)

If you still can’t control the devices just through the app, I’m afraid you’ll need to contact support. See the options at the bottom of the following page:

You mentioned Edge drivers. Does that mean that you have devices not using Edge drivers that you can control? Or is it just that none of the devices can be controlled and they use Edge drivers?

How does not being able to control the device show itself? Do you get error messages? Do the device statuses ever update?

Does using mobile data rather than Wi-Fi on your phone make any difference?

Have you tried reinstalling the app?

Do you have another phone or tablet you can install the app on to test?

What if you use

1 Like


  1. Un-install App, reinstall didn’t work
  2. If am on Local Wifi or Mobile same problem, it just spinning and app freezing when clicking example on my Thermostad (heatit) which using Edge Driver.
  3. Added Fibaro Smoke, using build in (I see it get added as Cloud device), no problem using that, if I use the custom Edge driver for it, it stop responding in ST App.
  4. Tested with, first try it showed the activity log, next try it allowed me to controll it. In th ST app I can see example on thermostad which temperature set point are on (using scene to adjust it!)
  5. Am out travling now, not able to test on another device, however am on a 1 week old Iphobe 14pro…

So, not sure how to fix this, is there any cache on iphone that still there even if I reinstall the app?