Cannot Change Picture on Presence Sensor


(Jeremy Salvador) #1

I sent my wife’s phone an invite to be part of the Smartthings network we created, then I made her phone a mobile presence sensor and assigned a picture to it.

I am now trying to change her the appearance of that mobile presence sensor to grumpy cat, but unfortunately it is not letting me. I can make the changes, but after restarting the app, it reverts back to the old picture.

This might be a minor bug, but I sure would like to change her picture to one of grumpy cat.


(Blake) #2

How did you “send” her an invite to be part of the network?


(David Forgianni) #3

@Blake in iOS you can invite someone to ‘share’ your account via the Left Menu>My Account. We currently do not support adding users (email addresses) that already have a SmartThings account.

@Jeremy this will be fixed in the next App Store build hopefully available soon, thanks for the heads up and report of the issue.


(Jeremy Salvador) #4

Thanks David!


(Blake) #5

Thanks for the info.
Just curious - is Android on the same development path as iOS, just delayed? This is one of the many things available in iOS that’s either unavailable or doesn’t work on Android.


(Emily Allen) #6

@blehke Good question, and the answer is that it’s a little bit of both. As you’ve noticed, Android is behind iOS in feature development right now for a variety of reasons. Custom images on presence tags (as well as custom icons on other devices) are actually something that’s being worked on this very moment. We’re aware that’s a big gap, especially for people who have many of the same kind of device, like outlets and switches.

That said, our Android developers have the advantage of being able to “skip” some of the things that our iOS developers built that will no longer be part of the UI, and we hope to be caught up on basic functionality soon. After that, the apps will likely diverge to take advantage of some of the things the Android platform can do that iOS can’t.

Thanks!

Emily Allen
SmartThings QA


(Steve S) #7

How did you add a second iPhone?? I’ve been trying and it only seems to accept one or the other.


(Bits) #8

Hi Jeremy,

Have you managed to change the pic with the new app? Still doesn’t work for me.