Cabinet lights Issue: GE 12723 Auxiliary Has Long Smart Lights Delay When Used at the Wall

I finished installing led cabinet lights and love how they turned out. But now when testing functionality I have run into an odd issue with smart lighting control in ST. The main kitchen light has two GE ZWave + switches and the cabinet lights run off of a GE ZWave + Paddle Dimmer Switch. My smart lighting rule triggers the cabinet lights to turn on when the main kitchen light turns on. This works flawlessly from ActionTiles, the ST app and through voice control with Alexa. Where I run into the issue is with a physical switch activation. The primary switch operates the kitchen light and the cabinet lights almost simultaneously, whereas the add on switch initiates a very long delay (8 seconds). Any suggestions? I’ve done a ZWave repair with no success. Thanks in advance for any suggestions and hopefully a solution!

Kitchen switches

Main Lights
GE ZWave +
(Primary) 14291
(Add On) 12723

Cabinet Lights
GE ZWave + Dimmer

Are you using smartthings device handlers, or custom DTH?
When you say “the add on switch initiates a very long delay”, what are you referring to? is the Delay in turning on the main light, or delay for the cabinet lights, or both?

The 12723 is a dumb switch, no radio at all, which works via a physical traveler wire to the GE master switch. Then the GE master switch comes on.

I’m assuming that the overhead Light comes on pretty quickly when you press the auxiliary switch? But then the delay is between the overhead light coming on and the LED light coming on, creating a “popcorn effect“?

But if you physically press the master switch, then both the overhead light and the LED light come on almost right away?

If so, there’s a reporting issue where the master switch is not telling the hub that the auxiliary switch asked it to turn on. So you have to wait until the next time the master switch is polled in order to trigger your automation.

A zwave repair won’t help this, because it’s not an issue with your Z wave network. The issue is on the settings for the master switch and when it reports to the hub.

I’m tired today, so I can’t check the settings for that particular model, hopefully someone else will chime in. This is a fairly common issue in a three-way set up, but the solution will depend on the exact model of master switch involved.

One more possibility: you have a somewhat unusual configuration in that you have a dimmer switch following a binary on/off switch. What have you used to create a rule where one follows the other? To be honest, I’m not sure exactly how that’s going to work, usually it’s either two dimmers or two binary switches.

Can you look in the logs and see exactly what command is being sent to the dimmer switch?

I’m using the Smart Lighting app through ST. The delay occurs after the main kitchen light turns on and before the cabinet lights turn on. Only occurs when the add on switch is cycled. The primary main switch cycles perfectly in sync with the cabinet light dimmer switch. The issue has been narrowed down to the communication between the add on switch and the primary switch.

Yes that is exactly what is happening. When you get some free time I would greatly appreciate any info you may come up with!

Thank you!

I will pull the logs when I get back to that location and run the switch cycle again

Thanks for the help!

1 Like

Can you post a screenshot of the automation that links the two switches? I’m still curious about what happens when you tell a dimmer to follow a binary switch.

OK, let’s see the log entries. I’m wondering if the smart light automation is sending a turn on but at 0% brightness and then you’re having to wait for the polling to pick it up. Or something like that.

An experiment to try if you have another binary on/off switch, although it might take two people.

Temporarily set up a rule so that turning on the master switch in the kitchen curtains on a different on/off switch. If it’s close enough for you to see, that would be ideal, otherwise you’re going to need two people.

Now see if there’s the same lag on that second on/off switch when you use the auxiliary switch in the kitchen.

I’d also like to see the log entries for that second switch.

If this does turn out to be the problem, there will be a couple of different ways to fix it depending on the specific details of this case.

Ok, I set up a temp rule operating the hallway light from the main kitchen light with the same results. The primary switch communicated instantly, whereas the auxiliary had an 8 second delay. Below are the logs for the primary and the aux switches when executing the original rule.



And the hall is a plain on/off switch, not a dimmer?

that is correct

Do you have the log for the auxiliary from the previous four minutes?

There isn’t any. I cycled one switch and cleared the log. Then repeated for the 2nd switch.

Then it would be better to see the log for the LED switch from the time you press the auxiliary. That’s probably where the lag is, between the master and the LED switch, so let’s see what’s going on there.


I installed the following Device Handler and associated the 2 switches. Now all works flawlessly, including the Add on switch. As a bonus I can also now double tap either of the switches and the overhead sink light comes on from the same switch as well.

Thank you for the assistance!

1 Like