Bulbs not turning off


#1

I have “smart lighting” smartapp installed. It turns my Lightify bulbs on/off.

However the bulbs are not turning off when I check. The smart lighting turns them on via motion sensor (ST type) and after no motion for 4 minds should turn them off.

eg I’ve just checked now, motion was detected at 9:59pm. No motion at 10:04pm yet they are still on at 10:27pm.

Checked in ST app and the recently tab of all the notion stopped at 10:04pm and shows no motion now.

What’s up? It’s frustrating as they are starting on.
Thanks


(Robin) #2

I take it all of the ‘more options’ are left blank?

Can other smart apps turn the light off?

I have a similar issue with a Fibaro Dual Relay, but with CoRE (and rule machine)

CoRE / RM can turn the 2nd switch on but not off… I think it must be something to do with the way the DH is reporting it’s state to the cloud. By defult, CoRE and most other smartapps won’t bother sending an off command if they think the light is already off.

What’s weird in my case is that the ‘on’ state shows correctly in the main ST app but CoRE / RM thinks it’s still off!

I never truly got to the bottom of it but I did find a workaround.

Using CoRE I disabled ‘command optimisations’ to force it to send the ‘off’ command regardless of the perceived state… This solved the problem but I certainly won’t be buying any more dual relays (I’ll stick with the single ones going forward!)

I cannot test for the same problem in Smart Lighting as it cannot see the 2nd switch on the dual relay.


#3

If you change the delay after motion sensing for the lights to turn off again to zero, it takes about 15 seconds after you leave the room for the lights to go off. Try change it to that and see if it works

Also, can you turn them on and off under the Things menu in the ST app?


(Joe) #4

I had that rule set up on allot of lights but had to delete as they were turning them on randomly even lights on zwave switches


#5

Same here. I had to create 2 rules. One to turn it on when there’s motion and one to turn off when there’s no motion


(Joe) #6

Might have to try that


(David) #7

There is a toggle switch in Smart lights to turn lights off with the possibly of a delay


(Robin) #8

He is setting that to 4mins so he already knows about the toggle.


#9

I have the toggle on after no notion turn off. I can control on/off via the app fine.

They are coming on but not switching off after they notion stops. Getting still disappointed with ST. I use basic functions I would say, Samsung smart apps and it can’t do basic things like switch on/off my lights. This is a function I rely on for security to.


(Robin) #10

If local processing is not important to you… Have you tried setting up the same rules in CoRE? You get a lot more options.

I have similar motion rules but with added locks (controlled via switch double clicks) to lock on / off the lights or override the night only settings etc.


#11

I’m a pretty basic user to be honest and don’t know what CoRE is. I’ve bought SmartRules iOS app which helps, but again the promise of updates from the developer has never happened.

Samsung should get this basic thing working though. It’s only switching my lights on and off surely?


(David) #12

Could you post a screenshot of your smart lighting Rule for this.

Also you might want to check all your different rules and make sure there isn’t one that is set to keeping the light on once its one.

If you click on the Light in “My Home” -> “Things”, click on the SmartApp tab to see what SmartApp it is subscribed to that might help track is using it.

I once had a rule that had lights following each other, then tried making one based on motion using the following light and it would never turn off unless the parent light was off as well.

Have you submitted a ticket with support? Maybe there is something wrong deeper than we can look at.


(Robin) #13

I’m surprised… Looking at your profile you have been an active forum member for over a year, how could you have not heard of CoRE??

The following link will change your world… And initially confuse the hell out of you (but we can help with that :slight_smile:)


#14

A year already… I’m a basic user as mentioned. I wanted it for security mainly, lighting, and convenience for switching lights on/off when in house.

I bought a Fibaro relay months ago and still haven’t fitted it, as wife at moment keeps switching off the switch to my smart bulbs.

I used to use another rule machine from the community, can’t remember name bit it stopped. Then an even better solution for me anyway an iOS app, SmartRules came out. But although promised, hasn’t been updated, but still works. [quote=“R2D2, post:1, topic:68100, full:true”]
I have “smart lighting” smartapp installed. It turns my Lightify bulbs on/off.

However the bulbs are not turning off when I check. The smart lighting turns them on via motion sensor (ST type) and after no motion for 4 minds should turn them off.

eg I’ve just checked now, motion was detected at 9:59pm. No motion at 10:04pm yet they are still on at 10:27pm.

Checked in ST app and the recently tab of all the notion stopped at 10:04pm and shows no motion now.

What’s up? It’s frustrating as they are starting on.
Thanks
[/quote]


(Robin) #15

The old rule machine you are probably referring to was actually called ‘rule machine’… It was produced by @bravenel but he discontinued it when he got fed up with constant ST stability issues! It actually still works if you still have the code, but is no longer available to new users (and licence restrictions prevent us from sharing it). I still use it for some old rules (if it ain’t broke and all that) but anything new I now do in CoRE.

Smart Rules is OK I suppose but it’s a pay-for app and lacks a lot of functions.

CoRE, for want of a better word, is AWSOME!!

It walks all over everything that came before and probably ever will be, and it’s free!! The maker @ady624 is quiet simply a don!!


#16

I have a ST motion sensor that activates some wemo bulbs directly connected to the ST Hub as well as some Hue lights through the Hue Bridge. Both work fine and switch off after the preset time. I wonder if it could be an issue with the Lightify bulbs. Do they connect directly to the ST Hub or through a bridge/hub?

PS. The ST motion sensor is slow to react. I grabbed a Hue motion sensor for the hue lights and it works much faster


#17

My lightify are direct to the ST hub yes


(Joe) #18

I think that is causing the problem. Create two rules and it might fix it. Did for me.


#19

Happened to me, it turned out one of the motion sensor was misbehaving. Go to “My Home” and check if any of the sensor used in this rule are showing any warning