Bug in power consumption

Hi, @nayelyz

I was asking @Mariano_Colmenarejo for help who recommended me to talk to you…
I have a Neo coolcam Z-wave socket with energy meter, but it has a bug in the energy meter. It won’t let me reset the costs…
This socket does not have Driver Edge yet… It was added by the app and I chose to add by brand …


This one I already added by z-wave device and the consumption meter doesn’t even appear… if I choose a different driver it also appears like this… and it doesn’t let me reset the consumptions…


the default driver it looks like this


You can help?

Thanks

Hi, @Helder_Rodrigues!

For this device, is this the fingerprint?

I see the energyMeter capability should show a pushButton but it’s missing. Can you check if that button appears in this tool, please? my.smartthings.com
If not, I think you can send the command directly from the API: API | SmartThings Developers
Or the CLI, sample command:

smartthings devices:commands deviceID main:energyMeter:resetEnergyMeter()

When you get an “out of range” message because the value received is out of the limit (0-999.9), you can confirm that using the CLI as well:

smartthings devices:status deviceID

Is this device the same model as the first one? the device profile is assigned depending on the fingerprint

Hi @nayelyz , sorry for the delay in responding!

Yes, it’s the Neo coolcam socket,

I have several of these outlets. But only in one outlet, I uninstalled and re-added the new system… The others are supposed to migrate automatically right?

I’ll be honest, I’ve tried to do this, but I don’t understand anything and I couldn’t!
Sorry

Hi, @Helder_Rodrigues

I am Andres, a member of the Developer Support team.

  • Do you know the fingerprint of your device? Can you please share it with us? If you don’t, please let us know. It should look something like this:
  • Do you know what the CLI is? Do you have installed in your computer?

  • Have you ever used the web version of SmartThings my.smartthings.com? Please, click that link, login and let us know if you see things differently

Hi @andresg

I’ve already opened this link, but I don’t use it, when I open the device it appears like this… This image is from the socket I added with edge driver…

If I change the driver for Mariano Z-wave Thing Mc give me this info

Z-Wave Device:
Id: 0f50ed6b-2e55-4a4d-bf48-9931b8613d1c
DNI: 0x6A
Manufacturer: 0x0258
Product Type: 0x0200
Product ID: 0x1027
End Point & Command Class: [0]: ZWAVEPLUS_INFO, SECURITY, SECURITY_2, TRANSPORT_SERVICE, POWERLEVEL, VERSION, ASSOCIATION, MULTI_CHANNEL_ASSOCIATION, ASSOCIATION_GRP_INFO, MANUFACTURER_SPECIFIC, DEVICE_RESET_LOCALLY, SWITCH_BINARY, METER, NOTIFICATION, CONFIGURATION, SUPERVISION

As I said earlier I have several of these outlets…
Which are still without the controller… In Grovy they appear like this…

Switch Device Sirene Garagem

Name Switch
Label Sirene Garagem
Type Z-Wave Metering Switch
Version Published
Device Network Id 09
Status ONLINE
Hub Hub
Group Garagem
Last Activity At 2022-10-20 8:59 AM WEST
Date Created 2021-12-07 9:54 PM WET
Last Updated 2022-08-19 10:16 PM WEST
Route This Device (09) Persiana Cozinha (2A) Hub
Metrics * Received Messages From Device: 2764
  • Received Messages From Device (Duplicates): 127
  • Messages Transmitted to Device: 218
  • Messages Transmitted to Device (Failures): 2
  • Updated Time: 2022-10-19 10:48 PM WEST|
    |Data|* MSR: 0258-0200-1027
  • networkSecurityLevel: ZWAVE_S2_FAILED|
    |Raw Description|zw:L type:1001 mfr:0258 prod:0200 model:1027 ver:2.23 zwv:6.04 lib:03 cc:5E,98,9F,55,73,86,85,8E,59,72,5A,25,32,71,70,6C|
    |Current States|* energy: -2.1474778E7 kWh
  • power: 0.0 W
  • switch: off
  • checkInterval: 1920 s
  • switch: off|
    |Execution Location|Local|
    |Events|List Events|
    |In Use By|* SharpTools
  • HdR Casaa / HdR Casaa (webCoRE Storage)|

Power consumption is out of range and I can’t reset.
On the new platform it looks like this…

Quite honestly, I’ve tried to install it, but I couldn’t, I don’t know if it’s because I don’t have permissions on the company’s pc!
And I don’t understand much either! Sorry!

Hi @andresg any progress on this topic?

Thanks

Hi, @Helder_Rodrigues

No news so far. I pinged them again to see if this helps moving thing forward.

Hi, @Helder_Rodrigues

We would need you to provide us Support Access to move forward with our investigation. The way to do that is by following these steps:

1.Go to the SmartThings Web
2. Log in to your Samsung Account
3. Select Menu (⋮) and choose Settings
4. Toggle on Account Data Access
5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

And please confirm us the email address linked to your Samsung Account. Is the same one you have in your Community account?

1 Like