[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

Did you only update / add the DH for the Thermostat and everything else is at whatever the previous version you added?

What version of NST Manager are you running? It should display when you open NST Manager from mobile app.

Only added the Nest Thermostat DH, I had all the others previously. Version 5.2.3

Are the SmartApps and Device Handlers all black in IDE?

Everything is Black in the IDE

Interesting.

So when you open NST Manager in mobile app does it say 5.23 at top?

Yeah, everything looks fine until I tap on manage devices. Then just gives me an error. No other menu item is giving an error.

From the main screen above Manage devices do you see “null” next to or under your location?

No, shows my current home/away status

Are you using the old nest token (supplied by NST Manager) or did you create Nest Developer Account and using the ClientSecret / clientID?

I created a Nest Developer account and I am using the id/secret

Ok so when you created that, did you add ALL 5 permissions including the Thermostat?

Yes and the Thermostat was read/writev6. “NST Manager can trigger actions in SmartThings when a temperature, humidity, HVAC mode events occurs.” for description

Ok so let’s troubleshoot backwards. You said you only added the Thermostat DTH.

  1. Exit out if NST Manager mobile app.
  2. Delete the Device Handler you just created.
  3. Go back into SmartApp and see if the same error occurs on Manage devices.

Did that, but still same error message. Also getting the same push notification I mentioned above. Weird

I have something to try but first I want to eliminate some other stuff.

In IDE goto Locations/installed SmartApps/scroll down to Other and give me screenshot of the NST stuff.

Or do you need me to click on each one

No youre good.

I pushed an update that should correct this.

3 Likes

I am running the android Smartthings app on a Galaxy S5 phone. Went to Marketplace / SmartApps / My Apps / Nest Manager and keep noticing the following Error message:

“You are missing the Client ID and Secret. We can no longer provide you with a built-in Nest Client ID and Secret. Please check the Wiki for Detailed instructions on creating your own Nest Dev ID and Secret.”

When I login to the smarthings IDE and edit the “Nest Manager” SmartApp and click on “OAuth”, I see that a Client ID and Secret was already specified. I have already tried checking the box: “Refresh client secret (warning: this will make your current secret invalid)” and update but that did not fix anything (still get the error message from the phone app).

I then even tried to install every single SmartApp and Device Handler in the IDE but after installing all of them, I still get the error above. The following is now all installed in my smartthings ide (server side):

SmartApps:
NST Manager
NST Automations:

Device Handlers:
Thermostat:
Protect:
Presence:
Weather:
Nest Cam: