[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

did you check for updates in both My SmartApps and My Device Handlers in IDE and all are published? Also, opent the NST Manager and click Save.

No such luck. The NST was saved. There was nothing to update in device handlers or smart apps. However two instances on the app exist when i click update from repo: ‘nest-manager (beta)’ and ‘nest-manager (master)’. …but when I look at my smart apps i see only one version of the app and a separate automations app.


I’m having to reset my token everyday to get my nest manager to communicate. It just seems to stop even though it say api is good etc. Has anyone got any advice. Has worked fine for ages but last few months been a pain.

Thank you

FYI, in case anyone is wondering… Nest is having issues at the moment :slight_smile:


Would that explain why I am constantly (every 5 minutes or so) getting messages like the following:

  • NST Manager Data update IssueS: The app has not refreshed data in the last (108501) seconds. Please try refreshing data using device re (***and the rest cuts off)
  • NST Manage API CMD Failed: the (nestCmdResponse 0 (structures{away:home})) CMD sent to the aPI has failed. Status Code: null ErrorMsg: Rec (***and I don’t know if there is any text beyond this).

These messages popped up today around 3pm Eastern time and they won’t stop. If the Nest issues are not the cause of this, what is? I have changed nothing since the initial setup. I do keep up with the latest updates (running version 5.6.4 now).


1 Like

Yes it would

Thank you for the quick response! Using your Nest status link, it looks like they show all systems as OK now. Perhaps they are not that accurate or whatever changes they made need to trickle through the network?

Also, is there a way to disable these notifications? Or at least send me every 5th one? It’s like every 5 minutes since 3pm.

In NST Manager, go to the Notifications section where you can disable alerts for the api

I don’t know how I never saw that before. That is exactly what I needed. Thanks for the assist!

The Nest platform is back but I am still offline in ST’s and continue to receive notifications.

Same with me.

It’s not just Nest, it’s the entire Google Home platform is having stability issues. It’s likely Google trying to migrate Nest stuff over/make changes to the Google Assistant API to accommodate Nest stuff.

Yea, I saw that on downdetector.com. My Nest thermostats have reconnected to ST’s now. Not sure if it is related but I did reboot them.

@tonesto7, Reading between the lines, I think that we are going to have an api going forward. The backlash that Google received from the initial announcement was pretty severe and they seemed to back track. That being said what are the chances that we could get the Nest temperature sensors listed as devices in ST’s? I could see real value in that.

So I’ve been battling with Keeping my thermostats updating in smart things for I’d say 6 months at this stage.

I’m always updating the app/device handlers when available but no matter what my thermostats stop responding after about 24hrs.

It usually ends up my uninstalling everything and reinstalling to get them responding. I use them in my own application through ST and the NST integration is brilliant if they would just continue to update.

I have the streaming service running on a pi but in general I don’t think it’s working because even if I have it on there is no difference. Trying to check for updates to it on pi returns an error.

I would really love to make this reliable and I really appreciate all the work done on this but it’s just become so frustrating at the moment. Has anyone else experienced this and is there a solution?.

I have not experienced this. Do you have any information in your “Live Logging” in the SmartThings IDE ?

Nest does have command limits, so if you start sending nest a lot of commands in a short period of time, they will block all commands. This should be visible in NST Manager app and / or IDE live logging.


Thanks for your reply.

I am not issuing many commands at all and for sure not near anything like that rate limit.

Here is the latest log for NST manager when trying to change the temperature on my downstairs nest.

Alas it doesn’t update on the best itself and remains unresponsive. ???

I have this same exact issue for about the same amount of time. Some days I have to reset my token every day, some i just have to enter the smart app and press save and others it works for a couple of days then goes unresponsive again. Tried re-insralling from scratch and still have the issue. Prior to this time period it’s been rock solid.

If you find an answer please let me know.

The logs show commands being queued but none of the execution /response data to those commands…

So need to see more logs…

You may want to:

  • start live logs

  • go into ST classic mobile app - and go into nest manager and hit done

  • see what is in the logs. If everything is ok then issue a command so it shows both the queuing of the command and the responses.

So I’ve went into the NST smart app and enabled all the logging I could. I then tried to change the temp in my upstairs thermostat and updates are streaming in again.

Here’s the logs. Updates started coming in at 9:36 pm.

Here’s the logs for the nest thermostat upstairs

As with before it will most probably update for a day or a little more and then stop updating.